RT5 Installation Error: Read-only file system Stack


I am in the final steps of installing RT5 using the very helpful instructions from the ManualInstallation WiKi. Apart from a couple of minor alterations (cpanm --force GD::Graph, somewhere and the empty string for WebPath, elsewhere) I think I have followed the instructions correctly. However I am getting a 504 Gateway Timeout when I browse to RT site using its raw IP address. The httpd logs reveal nothing. But journalctl reveals the following error: “Could not create ‘/opt/rt5/var/mason_data/obj/.__obj_create_marker’: Read-only file system Stack”

I’ve tried changing file permissions as well as running “make fixperms” again, to no avail!

What could be wrong please?

Do you use SELinux? That’s usually something we trip over (and now check early on!)

Yes. Using SELinux. But “sestatus” reveals it’s “disabled”.

Ok. So now I’ve “setenforce 0” and the error changes to “503 Service Unavailable” and there’s no journalctl errors revealed but I’m checking the httpd errors.

Also check in the SELinux audit log as that might give some hints as well (often /var/log/audit/audit.log).

I am still getting the Gateway Timeout error and the audit log reveals several SERVICE_START and SERVICE_STOP entries all related to rt-server…

What are the rights on this file/dir?

ls -al /opt/rt5/var/mason_data/obj/
total 0
drwxrwxrwx 2 apache rt 6 Aug 8 10:18 .
drwxrwx— 5 apache rt 41 Aug 8 10:18 …

I think I may have done a chmod a+rwx on the obj directory at some point!

Update. I backtracked to a backup that I’d made just before the “Set up RT FastCGI service” steps. I ran “/opt/rt5/sbin/rt-server --port 8080” as per the README and am now able to browse to http://ip-address:8080 as I am troubleshooting… P.S. I also had to allow 8080 through the firewall!

The same problem. I followed ManualInstallation - Request Tracker Wiki.
AlmaLinux 8.6

FastCGI can’t create anything in /opt/rt5/var/mason_data/obj/. My (silly) workaround is to start the standalone server, log-in and click on the elements in the web-ui. Afterwards I stop the standalone server and restart the FastCGI server, now I can visit the elements I’ve clicked before, when I click on anything else “Couldn’t create object file” again

best regards

Okay I found the problem. The “rt-server.service” in ManualInstallation is not complete.
You have to add the line “ReadWritePaths=/opt/rt5/var”. And before you start you
should “rm -Rf /opt/rt5/var/mason_data/obj/*” and “rm -Rf /opt/rt5/var/mason_data/obj/.*”

The problem is the DynamicUser which implies the ProtectSystem.

And there is a another problem

postfix/postdrop[264962]: warning: mail_queue_enter: create file maildrop/295526.264962: Permission denied

I had to add the maildrop folder to the ReadWritePath and to add postdrop to SupplementaryGroups