RT 5.0.0 upgrade database error

Hello everyone!

I was trying to upgrade my Request Tracker from 4.4.4 to 5.0.0, and everything seemed good until i got the following error in the database upgrade step:

[27761] [Wed Jul 29 20:48:01 2020] [critical]: DBD::Pg::st execute failed: ERROR: column “hotlist” of relation “classes” does not exist at /opt/rt-5.0.0/sbin/…/lib/RT/Handle.pm line 548. (/opt/rt-5.0.0/sbin/…/lib/RT.pm:409)
DBD::Pg::st execute failed: ERROR: column “hotlist” of relation “classes” does not exist at /opt/rt-5.0.0/sbin/…/lib/RT/Handle.pm line 548.
Makefile:393: recipe for target ‘upgrade-database’ failed
make: *** [upgrade-database] Error 255

All the previous steps are good. Any ideas?

1 Like

I am receiving the same exact error attempting the same upgrade. Using Postgres 9.5 on Ubuntu 18.04.

Out of curiosity do you have a backup before starting the upgrade process? I wonder if the hotlist table exists before upgrading and some other step removed it

No automated backups on my end - just running the ‘make upgrade-database’ command.

Thanks,

Peter

It’s a bit late for you now Peter but in case others read this in the future, please make a backup of your existing RT database before starting the upgrade process. RT’s upgrade is usually pretty robust but its much safer having a backup to hand Just In Case™.

Absolutely good advice. The only reason I did not do so manually is I took a snapshot image of the entire server. Unfortunately, even after running back up, I still get the same errors.

Best,

Peter

Is there a way to check (or clear) this hotlist table manually? I tried just doing a pg_dump as per the to see if that did the trick, but nothing changed.

You can just skip the upgrade step that is suppose to drop the hotlist column, upgrade step 4.5.0.

The other option is to make the hotlist column in the Classes table manually and then run the upgrade steps

Attempting to start the upgrade process by specifying a starting version of 4.5.0 failed. However starting at 4.5.1 appears to have succeeded and moved on. (But then my server ran out of disk space, so I need to address that issue now.)