Install RT Problem with FixDeps

I’m running into a problem trying to install RT5. The problem is with make fixdeps. It updates various Perl packages until it gets to trying to start

I’m using Fedora 32 in a VMWare machine. I’ve updated the machine software and CPAN. I have installed MariaDB. Apache is on the platform by default.

I did have install problems until I found a topic in this forum that said to set the following env variable:

RT_FIX_DEPS_CMD=’/usr/bin/perl -MCPAN -e"install %s"’

I put that in my local .bashrc because I was trying to get this thing going for several days now :frowning:

I changed to the /tmp directory per the README, extracted the rt package and ran ./configure followed by make fixdeps.

It runs for a while updating packages, but ultimately, generates the following error:

Can’t exec “”: No such file or directory at /home/myusername/perl5/lib/perl5/Server/ line 286.

It enters a continuous loop and can’t proceed from there.

Any help would be appreciated.

If you want to use that value for “RT_FIX_DEPS_CMD” you want this in your bashrc:

export RT_FIX_DEPS_CMD=’/usr/bin/perl -MCPAN -e"install %s"’

You can confirm its set in your shell with:


Can you confirm that you are able to install modules with that command? Try:

/usr/bin/perl -MCPAN -e"install Data::GUID"

I re-wrote the export statement per your suggestion and it did display on the echo command. I executed the test command line you suggest, and my Data::GUID was up to date, so I tried Data::Flow (a small pkg) and it installed.

It still gives the same result. It looks like it is trying to build Plack. And it enters the loop trying to start an empty string.

I forgot to mention that I configured CPAN with the default settings and then put a couple of more items in it’s config the I got off the CPAN site.

They are just helpful things like auto_commit and setting up sudo to execute the make stuff.

Thanks for the help. Do you have any other suggestions?

You could see my post here about installing a standalone Perl and cpanm

I followed your notes and it worked! I was having too many problems, first with Fedora 32 and Ubuntu 20, so I decided to go with Ubuntu 16.04 per your notes, and had much better luck.

The only omission is when you get the tar file for cpanm. You don’t specify un-tarring the file. But otherwise, everything worked like a champ.

Thanks for the help