Writing extensions for an old version

Hi,

I’m starting to learn RT development. And I was designated to create a RT
extension, but our RT version is too old (3.8). I couldn’t find any
documentation about how to do it for this version.

I tried follow the current documentation but when I tried to run:

perl Makefile.PL

I got this error:

**** Error: This extension requires RT 4.0.0. Your installed version
of RT (3.8.8) is too old.

Is it possible write and run a Extension for this version? If so, how can I
achieve that.

Vinícius Fagundes

Hi,

If you look in the Makefile.PL you will find somethink like this

requires_rt ‘4.0.0’;

modify as required.

Can I suggest that you upgrade as v3.8 reached end of life in 2014.

Best Regards

MartinOn 2017-02-13 17:02, Vinicius Fagundes wrote:

Hi,

I’m starting to learn RT development. And I was designated to create a
RT extension, but our RT version is too old (3.8). I couldn’t find any
documentation about how to do it for this version.

I tried follow the current documentation but when I tried to run:

perl Makefile.PL

I got this error:

**** Error: This extension requires RT 4.0.0. Your installed version
of RT (3.8.8) is too old.

Is it possible write and run a Extension for this version? If so, how
can I achieve that.

Vinícius Fagundes

Hello,

I tried this but the error remaining the same.

requires_rt ‘3.8.8’;

Or

requires (RT=>‘3.8.8’);

Is there any other place that I also need to update?

About the upgrade we working to do that soon.

Thanks,

Vinicius Fagundes

Hi,

If you look in the Makefile.PL you will find somethink like this

requires_rt ‘4.0.0’;

modify as required.

Can I suggest that you upgrade as v3.8 reached end of life in 2014.

Best Regards

MartinOn 2017-02-13 17:02, Vinicius Fagundes wrote:

Hi,

I’m starting to learn RT development. And I was designated to create a
RT extension, but our RT version is too old (3.8). I couldn’t find any
documentation about how to do it for this version.

I tried follow the current documentation but when I tried to run:

perl Makefile.PL

I got this error:

**** Error: This extension requires RT 4.0.0. Your installed version
of RT (3.8.8) is too old.

Is it possible write and run a Extension for this version? If so, how
can I achieve that.

Vinícius Fagundes

I have found. For anyone else who may have the same problem, to create a
extension for any deprecated version (RT <4.0)
it’s necessary allow deprecated RT:

RTx (‘RT-Extension-Example’, {deprecated_rt=>1});

More About:
http://search.cpan.org/~alexmv/Module-Install-RTx-0.38/lib/Module/Install/RTx.pm

Vinícius Fagundes2017-02-14 11:36 GMT-02:00 Vinicius Fagundes mvlacerda@gmail.com:

Hello,

I tried this but the error remaining the same.

requires_rt ‘3.8.8’;

Or

requires (RT=>‘3.8.8’);

Is there any other place that I also need to update?

About the upgrade we working to do that soon.

Thanks,

Vinicius Fagundes

Em 13 de fev de 2017 15:18, “Martin Wheldon” < martin.wheldon@greenhills-it.co.uk> escreveu:

Hi,

If you look in the Makefile.PL you will find somethink like this

requires_rt ‘4.0.0’;

modify as required.

Can I suggest that you upgrade as v3.8 reached end of life in 2014.

Best Regards

Martin

On 2017-02-13 17:02, Vinicius Fagundes wrote:

Hi,

I’m starting to learn RT development. And I was designated to create a
RT extension, but our RT version is too old (3.8). I couldn’t find any
documentation about how to do it for this version.

I tried follow the current documentation but when I tried to run:

perl Makefile.PL

I got this error:

**** Error: This extension requires RT 4.0.0. Your installed version
of RT (3.8.8) is too old.

Is it possible write and run a Extension for this version? If so, how
can I achieve that.

Vinícius Fagundes