Where do I put "FastCgiServer /opt/rt4/sbin/rt-server.fcgi -processes 5 -idle-timeout 300"

My mod_perl no longer works so I am trying to configure fastcgi per: https://docs.bestpractical.com/rt/4.4.4/web_deployment.html

Do I put FastCgiServer /opt/rt4/sbin/rt-server.fcgi -processes 5 -idle-timeout 300 in the virtual host file or is it a command I run or do I put it somewhere else.

I don’t have a lot of experience with this.


On Ubuntu I have mine in /etc/apache2/mods-enabled/fcgid.conf

Thanks you I have put it in fastcgi.conf and it reads;

AddHandler fastcgi-script .fcgi
#FastCgiWrapper /usr/lib/apache2/suexec
FastCgiIpcDir /var/lib/apache2/fastcgi
FastCgiServer /opt/rt4/sbin/rt-server.fcgi -processes 5 -idle-timeout 300

Hope that is correct

I’m sorry I misread your original config line, is ide-timeout an RT setting? I don’t think rt-server accepts those args