When replying to a new ticket a new ticket get created

Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

[cid:A93F8E95-F3FC-464A-AF04-402618F91147@uanet.local]
http://www.uanet.se/
http://www.uanet.se/

My first thought is that you’ve modified your $EmailSubjectTagRegex
setting. If you have, there may be a mistake in that which is causing a
problem. If you have changed it, can you give us its current value? Or
disable the change and see if replies start working correctly, then debug
the regexp?On Sat, Jan 14, 2017 at 5:10 PM, Martin Petersson martin@uanet.se wrote:

Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

http://www.uanet.se/
http://www.uanet.se/

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Yes, the regexp would be in there if you’ve modified it. Can you just post
your entire RT_SiteConfig.pm file (or files if you’re using files inside
RT_SiteConfig.d)? That might be the best way for us to see what you’re
working with.On Mon, Jan 16, 2017 at 9:14 AM, Martin Petersson martin@uanet.se wrote:

Hello,

Thank you for your answer.
Should $EmailSubjectTagRegex be in RT_SiteConfig.pm?

I have renamed the RT site, could that cause anything?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:00 skrev Alex Hall ahall@autodist.com:

My first thought is that you’ve modified your $EmailSubjectTagRegex
setting. If you have, there may be a mistake in that which is causing a
problem. If you have changed it, can you give us its current value? Or
disable the change and see if replies start working correctly, then debug
the regexp?

On Sat, Jan 14, 2017 at 5:10 PM, Martin Petersson martin@uanet.se wrote:

Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/


Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Yes here it is:
I have no files in RT_SiteConfig.d/

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

If this file includes non-ASCII characters, it must be encoded in

UTF-8.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this command:

perl -c /path/to/your/etc/RT_SiteConfig.pm

You must restart your webserver after making changes to this file.

You may also split settings into separate files under the etc/RT_SiteConfig.d/

directory. All files ending in “.pm” will be parsed, in alphabetical order,

after this file is loaded.

Set( $rtname, ‘uanet.sehttp://uanet.se’);
Set( $Organization, ‘uanet.sehttp://uanet.se’);
Set( $Timezone, ‘Europe/Stockholm’);
Set( $WebDomain, ‘help.uanet.sehttp://help.uanet.se’);
Set( $WebPort, 443);
Set( $WebPath, ‘’);
Set( $DatabasePassword, ’secret’);
Set($CorrespondAddress , ’support@uanet.semailto:support@uanet.se’);
Set($CommentAddress , ‘support-comment@uanet.semailto:support-comment@uanet.se’);
Set(@ReferrerWhitelist, qw(helpdesk.uanet.se:443http://helpdesk.uanet.se:443 helpdesk.uanet.se:80http://helpdesk.uanet.se:80));

You must install Plugins on your own, this is only an example

of the correct syntax to use when activating them:

Plugin( “RT::Authen::ExternalAuth” );

#Plugin(‘RT::Extension::SLA’);
#Plugin(‘RT::Extension::CommandByMail’);
#Set(@MailPlugins, qw(Auth::MailFrom Action::CommandByMail));
1;

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

[cid:A93F8E95-F3FC-464A-AF04-402618F91147@uanet.local]
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:19 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

Yes, the regexp would be in there if you’ve modified it. Can you just post your entire RT_SiteConfig.pm file (or files if you’re using files inside RT_SiteConfig.d)? That might be the best way for us to see what you’re working with.On Mon, Jan 16, 2017 at 9:14 AM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Hello,

Thank you for your answer.
Should $EmailSubjectTagRegex be in RT_SiteConfig.pm?

I have renamed the RT site, could that cause anything?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:00 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

My first thought is that you’ve modified your $EmailSubjectTagRegex setting. If you have, there may be a mistake in that which is causing a problem. If you have changed it, can you give us its current value? Or disable the change and see if replies start working correctly, then debug the regexp?

On Sat, Jan 14, 2017 at 5:10 PM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com

That looks fine to me, though I’m no expert. I definitely don’t see
anything that would cause email replies to turn into new tickets. My only
other idea is a rights problem, but I don’t know RT well enough to know if
it’s even possible.

My thought is that the users emailing replies don’t have permission to
comment or correspond on the tickets in question, so RT is making new
tickets instead. But again, I don’t know RT enough to say whether it would
do that or not. It’s just a thought. Still, it might be worth checking the
rights, unless and until someone with more experience can help.On Mon, Jan 16, 2017 at 9:25 AM, Martin Petersson martin@uanet.se wrote:

Yes here it is:
I have no files in RT_SiteConfig.d/

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

If this file includes non-ASCII characters, it must be encoded in

UTF-8.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this command:

perl -c /path/to/your/etc/RT_SiteConfig.pm

You must restart your webserver after making changes to this file.

You may also split settings into separate files under the

etc/RT_SiteConfig.d/

directory. All files ending in “.pm” will be parsed, in alphabetical

order,

after this file is loaded.

Set( $rtname, ‘uanet.se’);
Set( $Organization, ‘uanet.se’);
Set( $Timezone, ‘Europe/Stockholm’);
Set( $WebDomain, ‘help.uanet.se’);
Set( $WebPort, 443);
Set( $WebPath, ‘’);
Set( $DatabasePassword, ’secret’);
Set($CorrespondAddress , ’support@uanet.se’);
Set($CommentAddress , ‘support-comment@uanet.se’);
Set(@ReferrerWhitelist, qw(helpdesk.uanet.se:443 helpdesk.uanet.se:80));

You must install Plugins on your own, this is only an example

of the correct syntax to use when activating them:

Plugin( “RT::Authen::ExternalAuth” );

#Plugin(‘RT::Extension::SLA’);
#Plugin(‘RT::Extension::CommandByMail’);
#Set(@MailPlugins, qw(Auth::MailFrom Action::CommandByMail));
1;

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:19 skrev Alex Hall ahall@autodist.com:

Yes, the regexp would be in there if you’ve modified it. Can you just post
your entire RT_SiteConfig.pm file (or files if you’re using files inside
RT_SiteConfig.d)? That might be the best way for us to see what you’re
working with.

On Mon, Jan 16, 2017 at 9:14 AM, Martin Petersson martin@uanet.se wrote:

Hello,

Thank you for your answer.
Should $EmailSubjectTagRegex be in RT_SiteConfig.pm?

I have renamed the RT site, could that cause anything?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:00 skrev Alex Hall ahall@autodist.com:

My first thought is that you’ve modified your $EmailSubjectTagRegex
setting. If you have, there may be a mistake in that which is causing a
problem. If you have changed it, can you give us its current value? Or
disable the change and see if replies start working correctly, then debug
the regexp?

On Sat, Jan 14, 2017 at 5:10 PM, Martin Petersson martin@uanet.se wrote:

Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/


Alex Hall
Automatic Distributors, IT department
ahall@autodist.com


Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Hello Kenneth

Thank you so much for sending me your eBooks, i didn’t expect that, but thank you :slight_smile:
I don’t think the problem is the reply all from email. We always use reply and not reply all when replying from an email.

When i reply to a new ticket from email it looks like this: Re: [Uanet ärende nr. #34] Test 2
It adds Re: at the beginning but thats ok, right.

And when i receive my answer from RT it looks like this:
[Uanet ärende nr. #35] AutoReply: Re: [Uanet ärende nr. #34] Test 2

Never seen autoreply in the subject?

And here is how it look in RT GUI
[cid:A1F056B1-EB54-4096-8BE5-A6CC5339F925@uanet.local]

This is the second Request Tracker i setup on our firm. The old one has almost the same settings and it works perfectly on that.

Thankful for your help!

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

[cid:A93F8E95-F3FC-464A-AF04-402618F91147@uanet.local]
http://www.uanet.se/
http://www.uanet.se/

15 jan. 2017 kl. 21:45 skrev Kenneth Crocker <kenn.crocker@gmail.commailto:kenn.crocker@gmail.com>:

Martin,

You probably used the “Reply All” option , which will do that.

I’m attaching a document I created years ago to help me understand notifications, etc. I’m also including a TOC for an eBook I wrote entitled “Request Tracker for Beginners - A Topical Guide”. It’s on Amazon for only $9.99.

Once you’ve read it, I’d be more than happy to answert any questions.

Good Luck.

KennOn Sat, Jan 14, 2017 at 2:10 PM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

Hello,

Thank you for your answer.
Should $EmailSubjectTagRegex be in RT_SiteConfig.pm?

I have renamed the RT site, could that cause anything?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

[cid:A93F8E95-F3FC-464A-AF04-402618F91147@uanet.local]
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:00 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

My first thought is that you’ve modified your $EmailSubjectTagRegex setting. If you have, there may be a mistake in that which is causing a problem. If you have changed it, can you give us its current value? Or disable the change and see if replies start working correctly, then debug the regexp?On Sat, Jan 14, 2017 at 5:10 PM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com

Well i have looked at the rights. I have created a group called support and gave all the necessary access and for the group All in general rights i gave them access to everything, comment, register new tickets, create tickets and so on.

Really strange, anyone have any more ideas?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

[cid:A93F8E95-F3FC-464A-AF04-402618F91147@uanet.local]
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 16:03 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

That looks fine to me, though I’m no expert. I definitely don’t see anything that would cause email replies to turn into new tickets. My only other idea is a rights problem, but I don’t know RT well enough to know if it’s even possible.

My thought is that the users emailing replies don’t have permission to comment or correspond on the tickets in question, so RT is making new tickets instead. But again, I don’t know RT enough to say whether it would do that or not. It’s just a thought. Still, it might be worth checking the rights, unless and until someone with more experience can help.On Mon, Jan 16, 2017 at 9:25 AM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Yes here it is:
I have no files in RT_SiteConfig.d/

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

If this file includes non-ASCII characters, it must be encoded in

UTF-8.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this command:

perl -c /path/to/your/etc/RT_SiteConfig.pm

You must restart your webserver after making changes to this file.

You may also split settings into separate files under the etc/RT_SiteConfig.d/

directory. All files ending in “.pm” will be parsed, in alphabetical order,

after this file is loaded.

Set( $rtname, ‘uanet.sehttp://uanet.se/’);
Set( $Organization, ‘uanet.sehttp://uanet.se/’);
Set( $Timezone, ‘Europe/Stockholm’);
Set( $WebDomain, ‘help.uanet.sehttp://help.uanet.se/’);
Set( $WebPort, 443);
Set( $WebPath, ‘’);
Set( $DatabasePassword, ’secret’);
Set($CorrespondAddress , ’support@uanet.semailto:support@uanet.se’);
Set($CommentAddress , ‘support-comment@uanet.semailto:support-comment@uanet.se’);
Set(@ReferrerWhitelist, qw(helpdesk.uanet.se:443http://helpdesk.uanet.se:443/ helpdesk.uanet.se:80http://helpdesk.uanet.se/));

You must install Plugins on your own, this is only an example

of the correct syntax to use when activating them:

Plugin( “RT::Authen::ExternalAuth” );

#Plugin(‘RT::Extension::SLA’);
#Plugin(‘RT::Extension::CommandByMail’);
#Set(@MailPlugins, qw(Auth::MailFrom Action::CommandByMail));
1;

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:19 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

Yes, the regexp would be in there if you’ve modified it. Can you just post your entire RT_SiteConfig.pm file (or files if you’re using files inside RT_SiteConfig.d)? That might be the best way for us to see what you’re working with.

On Mon, Jan 16, 2017 at 9:14 AM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Hello,

Thank you for your answer.
Should $EmailSubjectTagRegex be in RT_SiteConfig.pm?

I have renamed the RT site, could that cause anything?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:00 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

My first thought is that you’ve modified your $EmailSubjectTagRegex setting. If you have, there may be a mistake in that which is causing a problem. If you have changed it, can you give us its current value? Or disable the change and see if replies start working correctly, then debug the regexp?

On Sat, Jan 14, 2017 at 5:10 PM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com

Hi Martin

I think the problem might be that you are using non-English characters in
the ticket identifier. In New Zealand, Maori words have some special
characters called macrons. They are used with vowels to specify the length
of the vowel sound.

Our service is called “Kotui” but there is meant to be a macron over the
"o" so it is spelled like: Kōtui.

When I first set up our queues, I used the correct, macron-using spelling
in the ticket identifier (e.g. [Kōtui Support ID #12345]), but this results
in all replies generating new tickets instead of being added to existing
tickets. The problem went away when I reverted to using the standard "o"
without a macron.

Regards,
ChrisOn Wed, 18 Jan 2017 at 05:25 Martin Petersson martin@uanet.se wrote:

Well i have looked at the rights. I have created a group called support
and gave all the necessary access and for the group All in general rights i
gave them access to everything, comment, register new tickets, create
tickets and so on.

Really strange, anyone have any more ideas?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

[image: logo-uanet-email.jpg]
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 16:03 skrev Alex Hall ahall@autodist.com:

That looks fine to me, though I’m no expert. I definitely don’t see
anything that would cause email replies to turn into new tickets. My only
other idea is a rights problem, but I don’t know RT well enough to know if
it’s even possible.

My thought is that the users emailing replies don’t have permission to
comment or correspond on the tickets in question, so RT is making new
tickets instead. But again, I don’t know RT enough to say whether it would
do that or not. It’s just a thought. Still, it might be worth checking the
rights, unless and until someone with more experience can help.

On Mon, Jan 16, 2017 at 9:25 AM, Martin Petersson martin@uanet.se wrote:

Yes here it is:
I have no files in RT_SiteConfig.d/

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

If this file includes non-ASCII characters, it must be encoded in

UTF-8.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this command:

perl -c /path/to/your/etc/RT_SiteConfig.pm

You must restart your webserver after making changes to this file.

You may also split settings into separate files under the

etc/RT_SiteConfig.d/

directory. All files ending in “.pm” will be parsed, in alphabetical

order,

after this file is loaded.

Set( $rtname, ‘uanet.se’);
Set( $Organization, ‘uanet.se’);
Set( $Timezone, ‘Europe/Stockholm’);
Set( $WebDomain, ‘help.uanet.se’);
Set( $WebPort, 443);
Set( $WebPath, ‘’);
Set( $DatabasePassword, ’secret’);
Set($CorrespondAddress , ’support@uanet.se’);
Set($CommentAddress , ‘support-comment@uanet.se’);
Set(@ReferrerWhitelist, qw(helpdesk.uanet.se:443 helpdesk.uanet.se:80
http://helpdesk.uanet.se/));

You must install Plugins on your own, this is only an example

of the correct syntax to use when activating them:

Plugin( “RT::Authen::ExternalAuth” );

#Plugin(‘RT::Extension::SLA’);
#Plugin(‘RT::Extension::CommandByMail’);
#Set(@MailPlugins, qw(Auth::MailFrom Action::CommandByMail));
1;

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:19 skrev Alex Hall ahall@autodist.com:

Yes, the regexp would be in there if you’ve modified it. Can you just post
your entire RT_SiteConfig.pm file (or files if you’re using files inside
RT_SiteConfig.d)? That might be the best way for us to see what you’re
working with.

On Mon, Jan 16, 2017 at 9:14 AM, Martin Petersson martin@uanet.se wrote:

Hello,

Thank you for your answer.
Should $EmailSubjectTagRegex be in RT_SiteConfig.pm?

I have renamed the RT site, could that cause anything?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:00 skrev Alex Hall ahall@autodist.com:

My first thought is that you’ve modified your $EmailSubjectTagRegex
setting. If you have, there may be a mistake in that which is causing a
problem. If you have changed it, can you give us its current value? Or
disable the change and see if replies start working correctly, then debug
the regexp?

On Sat, Jan 14, 2017 at 5:10 PM, Martin Petersson martin@uanet.se wrote:

Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.se, www.uanet.se
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/


Alex Hall
Automatic Distributors, IT department
ahall@autodist.com


Alex Hall
Automatic Distributors, IT department
ahall@autodist.com


Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Hello Chris

Thank you so much for answering. Yes we have åäö in Sweden. I reverted back to english on the templates if you mean thats where i should change?
Because it was the only place where i changed from english to swedish but then i noticed that i had this in the subject tag on the queue [Uanet Ärende ID #34]
So i removed the Ä and now it works :slight_smile:

Thank you very much!!

But how do i set it to use åäö, it works in our old RT 4.0.4

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

[cid:A93F8E95-F3FC-464A-AF04-402618F91147@uanet.local]
http://www.uanet.se/
http://www.uanet.se/

30 jan. 2017 kl. 22:08 skrev Chris McClement <chrisis@bosberaad.commailto:chrisis@bosberaad.com>:

Hi Martin

I think the problem might be that you are using non-English characters in the ticket identifier. In New Zealand, Maori words have some special characters called macrons. They are used with vowels to specify the length of the vowel sound.

Our service is called “Kotui” but there is meant to be a macron over the “o” so it is spelled like: Kōtui.

When I first set up our queues, I used the correct, macron-using spelling in the ticket identifier (e.g. [Kōtui Support ID #12345]), but this results in all replies generating new tickets instead of being added to existing tickets. The problem went away when I reverted to using the standard “o” without a macron.

Regards,
ChrisOn Wed, 18 Jan 2017 at 05:25 Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Well i have looked at the rights. I have created a group called support and gave all the necessary access and for the group All in general rights i gave them access to everything, comment, register new tickets, create tickets and so on.

Really strange, anyone have any more ideas?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 16:03 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

That looks fine to me, though I’m no expert. I definitely don’t see anything that would cause email replies to turn into new tickets. My only other idea is a rights problem, but I don’t know RT well enough to know if it’s even possible.

My thought is that the users emailing replies don’t have permission to comment or correspond on the tickets in question, so RT is making new tickets instead. But again, I don’t know RT enough to say whether it would do that or not. It’s just a thought. Still, it might be worth checking the rights, unless and until someone with more experience can help.
On Mon, Jan 16, 2017 at 9:25 AM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Yes here it is:
I have no files in RT_SiteConfig.d/

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

If this file includes non-ASCII characters, it must be encoded in

UTF-8.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this command:

perl -c /path/to/your/etc/RT_SiteConfig.pm

You must restart your webserver after making changes to this file.

You may also split settings into separate files under the etc/RT_SiteConfig.d/

directory. All files ending in “.pm” will be parsed, in alphabetical order,

after this file is loaded.

Set( $rtname, ‘uanet.sehttp://uanet.se/’);
Set( $Organization, ‘uanet.sehttp://uanet.se/’);
Set( $Timezone, ‘Europe/Stockholm’);
Set( $WebDomain, ‘help.uanet.sehttp://help.uanet.se/’);
Set( $WebPort, 443);
Set( $WebPath, ‘’);
Set( $DatabasePassword, ’secret’);
Set($CorrespondAddress , ’support@uanet.semailto:support@uanet.se’);
Set($CommentAddress , ‘support-comment@uanet.semailto:support-comment@uanet.se’);
Set(@ReferrerWhitelist, qw(helpdesk.uanet.se:443http://helpdesk.uanet.se:443/ helpdesk.uanet.se:80http://helpdesk.uanet.se/));

You must install Plugins on your own, this is only an example

of the correct syntax to use when activating them:

Plugin( “RT::Authen::ExternalAuth” );

#Plugin(‘RT::Extension::SLA’);
#Plugin(‘RT::Extension::CommandByMail’);
#Set(@MailPlugins, qw(Auth::MailFrom Action::CommandByMail));
1;

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:19 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

Yes, the regexp would be in there if you’ve modified it. Can you just post your entire RT_SiteConfig.pm file (or files if you’re using files inside RT_SiteConfig.d)? That might be the best way for us to see what you’re working with.

On Mon, Jan 16, 2017 at 9:14 AM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Hello,

Thank you for your answer.
Should $EmailSubjectTagRegex be in RT_SiteConfig.pm?

I have renamed the RT site, could that cause anything?

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

16 jan. 2017 kl. 15:00 skrev Alex Hall <ahall@autodist.commailto:ahall@autodist.com>:

My first thought is that you’ve modified your $EmailSubjectTagRegex setting. If you have, there may be a mistake in that which is causing a problem. If you have changed it, can you give us its current value? Or disable the change and see if replies start working correctly, then debug the regexp?

On Sat, Jan 14, 2017 at 5:10 PM, Martin Petersson <martin@uanet.semailto:martin@uanet.se> wrote:
Hello,

Somehow i get the auto reply ticket that the customer receive.
And then when i reply to the ticket it creates a new ticket, whats wrong?

I have Ubuntu latest OS and RT 4.4.1

Martin Petersson
IT-Konsult

+46 (0)522 980 28, martin@uanet.semailto:martin@uanet.se, www.uanet.sehttp://www.uanet.se/
Gustaf Mattssons Väg 2, 451 50 Uddevalla, Orgnr: 556702-4095

<logo-uanet-email.jpg>
http://www.uanet.se/
http://www.uanet.se/

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.commailto:ahall@autodist.com