Weird installation problem, RT3, not in the manual as far as I could see

I tried installing RT3, after fulfilling all the dependencies… and I get

make initialize-database

/usr/local/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init --dba root --prompt-for-dba-password
In order to create a new database and grant RT access to that database,
this script needs to connect to your mysql instance on sql-server as root.
Please specify that user’s database password below. If the user has no database
password, just press return.

Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
schema sucessfully inserted
Now inserting database ACLs
Now inserting RT core system objects
Checking for existing system user…not found. This appears to be a new
Creating system user…[Fri Mar 28 08:44:32 2003] [crit]: Couldn’t create
a Principal on new user create. Strange things are afoot at the circle K
Could not create user
make: *** [initialize-database] Error 1

remember: sbin/rt-test… | grep MISSING returns nothing. (in other words, i have all deps)
do also note: i tried dropdb and that from the begining… no luck

Enviroment: Apache 1.3.27, perl 5.8.0 (installed two days ago), modperl, mysql 4.0.11-gamma

can anyone help ?

  • shimi