Web interface kicks me out repeatedly


#1

I’ve got a problem I’ve seen mentioned in the FAQ and in the rt-users
archive, but I’m having trouble. I can log in via the web interface,
but when I try to do anything (namely create a request in the queue),
I’m kicked back out to the login screen with 'You are not logged in’
at the top.

I’ve done these things:

Gone into the database and confirmed that I'm using the correct
username and password.  My only concern from doing this is that 
the database shows root's password as the default, when I distinctly
remember setting it to the same thing as my password.  But I was tired.

Confirmed that cookies are on in my browser (Netscape Communicator 4.75)

Confirmed that I'm not using MSIE, so it can't be that bug.  :-)

The password is 8 characters – is that too short? How can I change my
password if I can’t get into the web interface?

We are using nonroutable addresses behind a NAT server/firewall, but there
should be no proxies between the machine I’m running the browser on
and the machine I’m running RT on.

Any ideas for how to debug this would be much appreciated.

Jill Lundquist jill@chezns.org
O, wonder! How many goodly creatures are there here!
How beauteous mankind is! O brave new world, that has such people in’t!


#2

There are a couple of things that can cause that:
1. Having your web traffic originate from multiple IPs.

            Fix: take out a line of code in auth.pm. Ping me if you want it
    2. Having a browser that swallows cookies.
            Fix: Turn on "notify me of all cookies" and make sure things look ok
            or make sure that RT is set to "send cookies to all scripts" aka the IE bug.

     If neither of those are it, we should do some off-list debugging.On Thu, Oct 12, 2000 at 08:00:39PM -0600, Jill Lundquist wrote:

I’ve got a problem I’ve seen mentioned in the FAQ and in the rt-users
archive, but I’m having trouble. I can log in via the web interface,
but when I try to do anything (namely create a request in the queue),
I’m kicked back out to the login screen with 'You are not logged in’
at the top.

I’ve done these things:

Gone into the database and confirmed that I'm using the correct
username and password.  My only concern from doing this is that 
the database shows root's password as the default, when I distinctly
remember setting it to the same thing as my password.  But I was tired.

Confirmed that cookies are on in my browser (Netscape Communicator 4.75)

Confirmed that I'm not using MSIE, so it can't be that bug.  :-)

The password is 8 characters – is that too short? How can I change my
password if I can’t get into the web interface?

We are using nonroutable addresses behind a NAT server/firewall, but there
should be no proxies between the machine I’m running the browser on
and the machine I’m running RT on.

Any ideas for how to debug this would be much appreciated.

Jill Lundquist jill@chezns.org
O, wonder! How many goodly creatures are there here!
How beauteous mankind is! O brave new world, that has such people in’t!


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent — root@eruditorum.orgjesse@fsck.com
pgp keyprint: 50 41 9C 03 D0 BC BC C8 2C B9 77 26 6F E1 EB 91
Pelcgb-serrqbz abj!


#3

Jesse wrote:

There are a couple of things that can cause that:
1. Having your web traffic originate from multiple IPs.

            Fix: take out a line of code in auth.pm. Ping me if you want it
    2. Having a browser that swallows cookies.
            Fix: Turn on "notify me of all cookies" and make sure things look ok
            or make sure that RT is set to "send cookies to all scripts" aka the IE bug.

     If neither of those are it, we should do some off-list debugging.

I have the same issue – also behind a NAT, but again, no NAT between me
and the host.
Constantly logs me out – only way around it (discovered by accident) is
to use a proxy – specifically Squid, but any proxy may work (I use
squid both @ home and @ work).

Love to see that hack to auth.pm

GW


#4

And your password should be 10 characters min.
Don’t know if this will affect it.
Are you running a 'nix version of Netscape? One or two people in my office had
that problem too, but it cleared up again… could be what Jesse mentioned.


#5

hmmm. we have the same problem. happened a few months ago, but
everyone just uses the command line interface. password length
doesn’t seem to be the problem.

the first time you log in, you get a cookie set:

www.mydomain.org FALSE /rt/webrt.cgi FALSE 986986817 RT_USERNAME user

any action after that sets a cookie with null USERNAME and PASSWORD
fields (deleting the cookie) and WebRT bounces you out and says you
are not logged in.

anyway, i havn’t bothered to take it any farther because, as i said,
everyone uses the command line interface.

michael

X-BeenThere: rt-users@lists.fsck.com
X-Mailman-Version: 2.0beta5
List-Id: For users of RT: Request Tracker <rt-users.lists.fsck.com>

And your password should be 10 characters min.
Don’t know if this will affect it.
Are you running a 'nix version of Netscape? One or two people in my office had
that problem too, but it cleared up again… could be what Jesse mentioned.

There are a couple of things that can cause that:
1. Having your web traffic originate from multiple IPs.

            Fix: take out a line of code in auth.pm. Ping me if you want it
    2. Having a browser that swallows cookies.
            Fix: Turn on "notify me of all cookies" and make sure things look ok
            or make sure that RT is set to "send cookies to all scripts" aka the IE bug.

     If neither of those are it, we should do some off-list debugging.

I’ve got a problem I’ve seen mentioned in the FAQ and in the rt-users
archive, but I’m having trouble. I can log in via the web interface,
but when I try to do anything (namely create a request in the queue),
I’m kicked back out to the login screen with 'You are not logged in’
at the top.

I’ve done these things:

Gone into the database and confirmed that I'm using the correct
username and password.  My only concern from doing this is that 
the database shows root's password as the default, when I distinctly
remember setting it to the same thing as my password.  But I was tired.

Confirmed that cookies are on in my browser (Netscape Communicator 4.75)

Confirmed that I'm not using MSIE, so it can't be that bug.  :-)

The password is 8 characters – is that too short? How can I change my
password if I can’t get into the web interface?

We are using nonroutable addresses behind a NAT server/firewall, but there
should be no proxies between the machine I’m running the browser on
and the machine I’m running RT on.

Any ideas for how to debug this would be much appreciated.

Jill Lundquist jill@chezns.org
O, wonder! How many goodly creatures are there here!
How beauteous mankind is! O brave new world, that has such people in’t!


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


jesse reed vincent — root@eruditorum.orgjesse@fsck.com
pgp keyprint: 50 41 9C 03 D0 BC BC C8 2C B9 77 26 6F E1 EB 91

Pelcgb-serrqbz abj!


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


#6

Update on the “kicked out when doing anything” problem:

I changed both passwords in the user table (mind and root’s) to be
ten characters rather than the eight they were before, since Feargal
suggested that. I did that via mysql. It didn’t make any difference.

There are a couple of things that can cause that:
1. Having your web traffic originate from multiple IPs.

           Fix: take out a line of code in auth.pm. Ping me if you want it

Both the machine I’m running RT on and the machine I’m running netscape
on have only one IP address, and there is no NAT between them (they’re
both on the same side of our NAT server). However, I’d like to try
the auth.pm fix – would you mind sending it?

   2. Having a browser that swallows cookies.
           Fix: Turn on "notify me of all cookies" and make sure things look ok
           or make sure that RT is set to "send cookies to all scripts" aka the IE bug.

Now this is odd – my browser (Netscape Communicator 4.75, running on a
redhat 6.2 machine) already had “Accept all cookies” on. I turned
on “Warn me before accepting a cookie”, and when I reload the page
and log in, I don’t see any cookie notifications at all. Hmmm. Anyone
think this might be significant? :slight_smile:

I quit and restarted netscape, wondering if it had become wedged in some
way, but the same thing happens.

    If neither of those are it, we should do some off-list debugging.

I’d be happy to, and grateful for your time. Thanks. I hope we
can work it out, since it seems to be such a common glitch, and I
really like the RT design (I liked req’s simplicity and flexibility,
and it seems that RT has the best parts of req).

Jill Lundquist jill@chezns.org
"The first butcher I saw as a child had a wooden leg, and to this
day I have an unreasonable feeling that butchers with two genuine
legs are impostors." -Robertson Davies


#7

Update on the “kicked out when doing anything” problem:

Ahem. It works when I stop using our home-grown web proxy (which I
didn’t realize I had configured on this machine). Good call, Jesse.

“Are you running a web proxy?” might be another thing to add to the
list of “things that might be wrong if the web interface doesn’t
work” in the FAQ. Perhaps as a comment on the "must accept cookies"
part.

Many thanks to all who made suggestions. The first thing I’m going
to put in this queue when it’s set up is “our proxy needs to work
with RT”. :slight_smile:

Jill Lundquist jill@chezns.org
"The first butcher I saw as a child had a wooden leg, and to this
day I have an unreasonable feeling that butchers with two genuine
legs are impostors." -Robertson Davies


#8

Jill Lundquist wrote:

Update on the “kicked out when doing anything” problem:

Ahem. It works when I stop using our home-grown web proxy (which I
didn’t realize I had configured on this machine). Good call, Jesse.

“Are you running a web proxy?” might be another thing to add to the
list of “things that might be wrong if the web interface doesn’t
work” in the FAQ. Perhaps as a comment on the "must accept cookies"
part.

SNIP

Just wanting to chime in, here – when I don’t use the proxy (squid), it
kicks
me out. When I do, it doesn’t. Opposite behaviour of the OP… Any
thoughts?

GW


#9

Does it set cookies in your browser and still kick you out or not set
cookies at all?On Sun, Oct 15, 2000 at 08:10:38PM -0700, Greg White wrote:

Jill Lundquist wrote:

Update on the “kicked out when doing anything” problem:

Ahem. It works when I stop using our home-grown web proxy (which I
didn’t realize I had configured on this machine). Good call, Jesse.

“Are you running a web proxy?” might be another thing to add to the
list of “things that might be wrong if the web interface doesn’t
work” in the FAQ. Perhaps as a comment on the "must accept cookies"
part.

SNIP

Just wanting to chime in, here – when I don’t use the proxy (squid), it
kicks
me out. When I do, it doesn’t. Opposite behaviour of the OP… Any
thoughts?

GW


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent — root@eruditorum.orgjesse@fsck.com
pgp keyprint: 50 41 9C 03 D0 BC BC C8 2C B9 77 26 6F E1 EB 91
I have images of Marc in well worn combat fatigues, covered in mud,
sweat and blood, knife in one hand and PSION int he other, being
restrained by several other people, screaming “Let me at it!
Just let me at it!” Eichin standing calmly by with something
automated, milspec, and likely recoilless.
-xiphmont on opensource peer review


#10

I just installed the RT 1.0.4 and Apache 1.3.14 on a Solaris 7 machine.
The rt command line interface is working fine for me, but the web interface
keeps kicking me out when I try to select anything. I went through the all
the
suggested fix on this login issue, but still couldn’t get it to work. I am
really
appreciated for any help.

Fai
fai@pbc.com