Web Interface displays as code

Hi There,

Can anyone help with this little problem. I am sure it is something simple, maybe permissions problem, but, when I go to the RT url it displays the page below as code. I have compiled in mod_perl to apache 1.3.26 and all went well, all module deps were also met with make fixdeps and make testdeps reports nothing out of place.

See Beow:----

<& /Elements/Header, Title=>“Start page”, Refresh => $session{‘home_refresh_interval’} &> <& /Elements/Tabs, current_toptab => ‘’ &> <& /Elements/CustomHomepageHeader, %ARGS &> <& /Elements/MyTickets &>
<& /Elements/MyRequests &> <& /Elements/Quicksearch &>

  <& /Elements/Refresh, Name => 'HomeRefreshInterval', Default => $session {'home_refresh_interval'} &> 

<%init> if ($ARGS{‘HomeRefreshInterval’}) { $session{‘home_refresh_interval’} = $ARGS{‘HomeRefreshInterval’}; }

Advice greatly appreciated.

Jamie Crookes

At 04:49 PM 11/26/2002 +0000, Jamie Crookes wrote:

Hi There,

Can anyone help with this little problem. I am sure it is something
simple, maybe permissions problem, but, when I go to the RT url it
displays the page below as code. I have compiled in mod_perl to apache
1.3.26 and all went well, all module deps were also met with make fixdeps
and make testdeps reports nothing out of place.

See Beow:----

<& /Elements/Header, Title=>“Start page”, Refresh =>
$session{‘home_refresh_interval’} &> <& /Elements/Tabs, current_toptab =>
’’ &>
<& /Elements/CustomHomepageHeader, %ARGS &> <& /Elements/MyTickets &>
<& /Elements/MyRequests &> <& /Elements/Quicksearch &>
<& /Elements/Refresh, Name => ‘HomeRefreshInterval’, Default => $session
{‘home_refresh_interval’} &>
<%init> if ($ARGS{‘HomeRefreshInterval’}) {
$session{‘home_refresh_interval’} = $ARGS{‘HomeRefreshInterval’}; }

Advice greatly appreciated.

Jamie Crookes

I believe that your HTML-Mason is not working correctly. It should be
parsing your HTML for you. I had this same problem. CPAN upgrades your
PERL, but leaves the old version on the system. (I had 5.6.0 and it
upgraded to 5.8.0) Because of this, any dependency that was installed
before the CPAN usage (HTML-Mason and a couple others) were installed to
Perl 5.6.0, while everything after the installation was installed to 5.8.0.
Check to see if that is your problem.