Web interface configuration

Hi all !

I�m a new user of RT and having some problems setting up RT.

Well, after some hours spending on installing RT, I finally made it.

I`m using Redhat 5.2 and with apache with mod_perl, mysql and php.
RT version 2.0.9. Path: /opt/rt2

I want to run RT with other content so I put these lines in the httpd.conf:

Alias /rt2/ “/opt/rt2/WebRT/html/”

<Directory “/opt/rt2/WebRT/html”>
AllowOverride None
Options None ExecCGI FollowSymLinks
Order allow,deny
Allow from all
PerlRequire /opt/rt2/bin/webmux.pl
PerlModule Apache::DBI
SetHandler perl-script
PerlHandler RT::Mason
Options ExecCGI

In config.pm: $WebPath = “/opt/rt2/WebRT/html”;
The permissions:

/opt/rt2
drwxr-xr-x 5 root root 4096 Dez 22 19:03 WebRT
drwxr-xr-x 2 root root 4096 Dez 28 13:53 bin
drwxr-xr-x 2 root rt 4096 Dez 28 14:02 etc
drwxr-xr-x 4 root bin 4096 Dez 28 13:26 lib
drwxr-xr-x 3 root root 4096 Dez 22 19:03 local
drwxr-xr-x 3 root root 4096 Dez 28 13:26 man

/opt/rt2/WebRT
drwxrwx— 7 apache apache 4096 Jan 3 11:40 data
drwxr-xr-x 10 root bin 4096 Jan 3 14:27 html
drwxrwx— 2 apache apache 4096 Jan 4 09:33 sessiondata

/opt/rt2/WebRT/html
drwxr-xr-x 10 root bin 4096 Nov 14 20:29 Admin
drwxr-xr-x 2 root bin 4096 Nov 14 20:29 CVS
drwxr-xr-x 3 root bin 4096 Nov 14 20:29 Elements
drwxr-xr-x 4 root bin 4096 Nov 14 20:29 NoAuth
drwxr-xr-x 3 root bin 4096 Nov 14 20:29 Search
drwxr-xr-x 5 root bin 4096 Nov 14 20:29 SelfService
drwxr-xr-x 5 root bin 4096 Nov 14 20:29 Ticket
drwxr-xr-x 3 root bin 4096 Nov 14 20:29 User
-rwxr-xr-x 1 root bin 1918 Nov 7 00:06 autohandler
-rwxr-xr-x 1 root bin 684 Jan 3 14:19 index.html

When opening the URL of the server a page with three links appear. One is
for RT with the target
ticker

So, after following the link to RT, I come to the login page of RT, I can
login as root, I can log in and then
I come the start page. Fine
But when choosing any link like search, home or configuration I get a HTTP
404 Error: Can`t locate file.
the apache error_log:
[Fri Jan 4 04:55:29 2002] [error] [client 192.168.200.61] File does not
exist: /var/www/html/opt/rt2/WebRT/html/
[Fri Jan 4 04:55:30 2002] [error] [client 192.168.200.61] File does not
exist: /var/www/html/opt/rt2/WebRT/html/NoAuth/w
ebrt.css
[Fri Jan 4 04:55:31 2002] [error] [client 192.168.200.61] File does not
exist: /var/www/html/opt/rt2/WebRT/html/Search/L
isting.html
[Fri Jan 4 04:55:35 2002] [error] [client 192.168.200.61] File does not
exist: /var/www/html/opt/rt2/WebRT/html/NoAuth/w
ebrt.css
[Fri Jan 4 04:55:36 2002] [error] [client 192.168.200.61] File does not
exist: /var/www/html/opt/rt2/WebRT/html/Admin/
[Fri Jan 4 04:55:37 2002] [error] [client 192.168.200.61] File does not
exist: /var/www/html/opt/rt2/WebRT/html/NoAuth/w
ebrt.css

I searched in the RT archives but I couldn`t find an appropriate
answer/solving of that problem.
I hope anyone can help me. I�m stuck to long now.

Greetings,

Heiko Zang

Hi,

Looking at the error logs, it appears Apache is looking in the Red
Hat’s default docroot (/var/www/html) for RT:

[Fri Jan 4 04:55:29 2002] [error] [client 192.168.200.61] File does not exist: /var/www/html/opt/rt2/WebRT/html/

Here’s my setup (under Apache 1.3.19 under SuSE 7.2):

config.pm:
$WebPath = “/rt2”;

This is the Scheme, server and port for constructing urls to webrt

$WebBaseURL doesn’t need a trailing /

$WebBaseURL = “http://www.cynistar.net”;
$WebURL = $WebBaseURL . $WebPath . “/”;

httpd.conf:

# Set up Mason
PerlSetVar MasonCompRoot /www/docs/www.cynistar.net/html
PerlSetVar MasonDataDir /www/docs/www.cynistar.net/mason
PerlModule HTML::Mason::ApacheHandler

# Set up RT2
Alias /rt2 /usr/local/rt2/WebRT/html
PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /usr/local/rt2/bin/webmux.pl

<Location /rt2/>
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

Your setup:

httpd.conf
Alias /rt2/ “/opt/rt2/WebRT/html/”

<Directory “/opt/rt2/WebRT/html”>

PerlRequire /opt/rt2/bin/webmux.pl
PerlModule Apache::DBI
SetHandler perl-script
PerlHandler RT::Mason

config.pm:
$WebPath = “/opt/rt2/WebRT/html”;

Suggestions:

  • Change $WebPath to “/rt2” in config.pm and restart the
    webserver. Note that web path is the path part of the URI (scheme
    :// user : password @ host : port / path ? querystring # fragment),
    not the filesystem path.

  • Check the Apache docs to see the difference between
    Alias /rt2/ "/opt/rt2/WebRT/html/"
    and
    Alias /rt2 “/opt/rt2/WebRT/html”

IIRC, I’ve been burned by the subtle differences between the two.

  • Check if there’s a substantial difference between
    <Location /rt2/>
    and
    <Directory “/opt/rt2/WebRT/html”>

I think these are equivalent in your case but I’m not sure (I lent out
my Apache book earlier this week and I’m too lazy to check the
docs at apache.org…)

hth,

– BobOn 4 Jan 2002, at 11:07, Heiko Zang | FutureData wrote:

Hi all !

I´m a new user of RT and having some problems setting up RT.

Well, after some hours spending on installing RT, I finally made it.

I`m using Redhat 5.2 and with apache with mod_perl, mysql and php. RT
version 2.0.9. Path: /opt/rt2

I want to run RT with other content so I put these lines in the
httpd.conf:

Alias /rt2/ “/opt/rt2/WebRT/html/”

<Directory “/opt/rt2/WebRT/html”>
AllowOverride None
Options None ExecCGI FollowSymLinks
Order allow,deny
Allow from all
PerlRequire /opt/rt2/bin/webmux.pl
PerlModule Apache::DBI
SetHandler perl-script
PerlHandler RT::Mason
Options ExecCGI

In config.pm: $WebPath = “/opt/rt2/WebRT/html”;
The permissions:

/opt/rt2
drwxr-xr-x 5 root root 4096 Dez 22 19:03 WebRT
drwxr-xr-x 2 root root 4096 Dez 28 13:53 bin
drwxr-xr-x 2 root rt 4096 Dez 28 14:02 etc
drwxr-xr-x 4 root bin 4096 Dez 28 13:26 lib
drwxr-xr-x 3 root root 4096 Dez 22 19:03 local
drwxr-xr-x 3 root root 4096 Dez 28 13:26 man

/opt/rt2/WebRT
drwxrwx— 7 apache apache 4096 Jan 3 11:40 data
drwxr-xr-x 10 root bin 4096 Jan 3 14:27 html
drwxrwx— 2 apache apache 4096 Jan 4 09:33 sessiondata

/opt/rt2/WebRT/html
drwxr-xr-x 10 root bin 4096 Nov 14 20:29 Admin
drwxr-xr-x 2 root bin 4096 Nov 14 20:29 CVS
drwxr-xr-x 3 root bin 4096 Nov 14 20:29 Elements
drwxr-xr-x 4 root bin 4096 Nov 14 20:29 NoAuth
drwxr-xr-x 3 root bin 4096 Nov 14 20:29 Search
drwxr-xr-x 5 root bin 4096 Nov 14 20:29 SelfService
drwxr-xr-x 5 root bin 4096 Nov 14 20:29 Ticket
drwxr-xr-x 3 root bin 4096 Nov 14 20:29 User
-rwxr-xr-x 1 root bin 1918 Nov 7 00:06 autohandler
-rwxr-xr-x 1 root bin 684 Jan 3 14:19 index.html

When opening the URL of the server a page with three links appear. One
is for RT with the target ticker

So, after following the link to RT, I come to the login page of RT, I
can login as root, I can log in and then I come the start page. Fine
But when choosing any link like search, home or configuration I get a
HTTP 404 Error: Can`t locate file. the apache error_log: [Fri Jan 4
04:55:29 2002] [error] [client 192.168.200.61] File does not exist:
/var/www/html/opt/rt2/WebRT/html/ [Fri Jan 4 04:55:30 2002] [error]
[client 192.168.200.61] File does not exist:
/var/www/html/opt/rt2/WebRT/html/NoAuth/w ebrt.css [Fri Jan 4
04:55:31 2002] [error] [client 192.168.200.61] File does not exist:
/var/www/html/opt/rt2/WebRT/html/Search/L isting.html [Fri Jan 4
04:55:35 2002] [error] [client 192.168.200.61] File does not exist:
/var/www/html/opt/rt2/WebRT/html/NoAuth/w ebrt.css [Fri Jan 4
04:55:36 2002] [error] [client 192.168.200.61] File does not exist:
/var/www/html/opt/rt2/WebRT/html/Admin/ [Fri Jan 4 04:55:37 2002]
[error] [client 192.168.200.61] File does not exist:
/var/www/html/opt/rt2/WebRT/html/NoAuth/w ebrt.css

I searched in the RT archives but I couldn`t find an appropriate
answer/solving of that problem.
I hope anyone can help me. I´m stuck to long now.

Greetings,

Heiko Zang


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Hi!

Yes, the $WebPath was set wrong. I took Bobs setup of RT2 in the httpd.conf and adjusted it to my file path. But I didnt have the time to check the <location< and things yet.
Now RT is almost running. Some probs with the the reply function but that`s
another topic.

Thanx very much for the help.

Best Regards,

Heiko

At 10:43 04.01.2002 -0600, you wrote: