Web interface configuration question

Bennett, Bevan (IS) wrote:

RT Stuff

Alias /rt/ "/opt/rt3/share/html/"
Alias /rt "/opt/rt3/share/html/"
Alias /helpdesk/ "/opt/rt3/share/html/"
Alias /helpdesk “/opt/rt3/share/html/”

NameVirtualHost *:80 # Tried 443, no-go
<VirtualHost *:80> # Ditto
ServerAdmin Certified_Today[at]Easyrider.com
ServerName backup.easyrider.com
DocumentRoot /opt/rt3/share/html/
AddDefaultCharset UTF-8

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script .fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

Hey, my mailing-list membership isn’t up yet, but I think I can help you.
This is a close translation of what we have to enable what you’re
looking for.

What you want is something like this:

Allow access to the RT html area

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

Keep your core system core

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

Now add the handlers and aliases for RT, to the RT location

Alias /rt /opt/rt3/share/html/
<Location /rt>
SetHandler perl-script
PerlResponseHandler RT::Mason

<Location /rt/NoAuth/images>
SetHandler default


Thanks VERY much for the concise instructions Bevan! Just what I was
hoping for. Unfortunately, your example didn’t work :frowning:

I think you are on the right track and I have previously tried
combinations very close to yours based on various threads I’ve read on
this topic. I think it’s the section that’s causing
problems. If I comment it out, I get the BP “almost there” page. With
it in there, I get an internal server error.

The server name is not yet registered in DNS… don’t know if that’s a
factor. I toggle the WebPath and WebBaseURL settings for each test
iteration with no change in results. Doing an httpd restart each time,
of course. I changed httpd.conf to look EXACTLY like your example and
when it didn’t work I tried various combinations so as to not bother the
list without fully trying to fix this on my own.

/opt/rt3/etc/RT_SiteConfig.pm:

----- START -----------------------

#Set($WebPath , “”);
Set($WebPath , “/rt”);

Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));

#Set($WebBaseURL , “http://backup.easyrider.com:$WebPort”);
Set($WebBaseURL , “http://localhost:$WebPort”);

Set($WebURL , $WebBaseURL . $WebPath . “/”);

#------ END -----------------------

/etc/httpd/conf/httpd.conf:

----- START ---------

Allow access to the RT html area

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

Keep your core system core

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

Now add the handlers and aliases for RT, to the RT location

Alias /rt /opt/rt3/share/html/

Enabling the following produces an internal server error page

Commenting it out gives a BP almost there page

<Location /rt>

SetHandler perl-script

PerlResponseHandler RT::Mason

<Location /rt/NoAuth/images>
SetHandler default

Experiment end

----- END ----------

When you get the internal server error, what shows up in your webserver
error_log?

The big difference I see between your original and mine is that you
have a ScriptAlias instead of a SetHandler.
It looks like you’re configured to use fastCGI (via the scriptAlias)
rather than mod_perl (like I am), which would indeed lead to internal
server errors.

Looking at the fastcgi config docs, you probably want something closer
to this:
That, along with your Webpath “/rt”, may do the trick.

Allow access to the RT html area

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

Keep your core system core

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

Now add the handlers and aliases for RT, to the RT location

ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/
AddHandler fastcgi-script fcgi

<Location /rt>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

Yep! Any improvement is a good thing :slight_smile: And all of the credit goes to
you since I have been pretty much spinning my wheels for 48 hours before
you came along.

Getting very close here… already logged on accounts now work
correctly on /rt and not http://backup.easyrider.com as they should. So
that seems to be at least somewhat fixed.

However, new log in attempts go directly to
http://backup.easyrider.com/index.html.com after you enter the username
and password. Screwy… there must be a path setting somewhere that’s
still wrong perhaps?

Also, a small issue but likely related to all of the above is that my
logo is not being displayed (although I’ve had this working when RT ran
out of the web root). You get no gif and the alt text instead but for
Best Practical even though I have long since changed it to my URL. It’s
like reload isn’t reloading all of RT_siteconfig.pm or something. It’s
like the Set WebPath value isn’t taking although reload does seem to be
reading the pm file…

Rather than experiment with a million combinations to see if I can solve
this, I thought it would be wiser to just get back to you since you
actually seem to understand this stuff. No errors in the Apache log
file (anymore).

/opt/rt3/etc/RT_SiteConfig.pm:

----- START -----------------------

#Set($WebPath , “”);
Set($WebPath , “/rt”);

Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));

#Set($WebBaseURL , “http://backup.easyrider.com:$WebPort”);
Set($WebBaseURL , “http://localhost:$WebPort”);

Set($WebURL , $WebBaseURL . $WebPath . “/”);

Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

Set($LogoURL , $WebImagesURL . “bplogo.gif”); # bplogo.gif was
overwritten to be my logo
Set($LogoLinkURL, ‘http://security.nocdesigns.com’);
Set($LogoAltText, “Easyrider LAN Pro”);

WebNoAuthRegex - What portion of RT’s URLspace should not require

authentication.

Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

#------ END -----------------------

/etc/httpd/conf/httpd.conf:

Latest RT config experiment BEGIN

----- START ---------

Allow access to the RT html area

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

Keep your core system core

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

Now add the handlers and aliases for RT, to the RT location

ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/
AddHandler fastcgi-script fcgi

<Location /rt>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

Experiment end

----- END ----------

The images are because we didn’t deal with NoAuth yet.

Now that we’ve gotten this far, try adding a second location directive
right after the first with:
<Location /rt/NoAuth/images>
SetHandler default

That should turn off the FastCGI for the image directory (as per
http://wiki.bestpractical.com/view/ManualInstallation).

I’m not sure why your logins would still be going awry, as that should
all be dealt with from $WebURL. Maybe check the access-log and see
what page is requesting index.html to start narrowing things down.

Also, make sure you don’t have any extraneous /rt related aliases or
redirects hanging around from earlier testing.
On a new browser session, http://backup.easyrider.com/rt gives the login
window. Once you enter the username/pw. it immediately goes to
/var/www/html/index.html. Log snippet follows:
Still not displaying the logo and URL that’s in RT_siteconfig.pm which
may be related or a separate issue. Otherwise the graphics seem fine
now. I did a grep and a careful inspection and I don’t see any
spurious, unwanted references to rt hanging around. I “think” (fingers
crossed) that you now have httpd.conf 100%.

A reload does recognize changes to $WebPath but is not honoring $WebLogo
so focusing on $WebURL makes sense. Again, backup.easyrider.com is not
yet registered in DNS so I am using localhost in RT_siteconfig.pm. The
web server is dual homed and is accessible vi an ISP-assigned IP address
(through my DMZ) as well as an internal NAT address. Accessing RT via
either NIC seems to always give the same results.

[root@security frankie]# perl -c /opt/rt3/etc/RT_SiteConfig.pm
/opt/rt3/etc/RT_SiteConfig.pm syntax OK

192.168.1.104 - - [05/Oct/2009:15:24:45 -0700] “GET /rt HTTP/1.1” 200
4830 “-” "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)"
192.168.1.104 - - [05/Oct/2009:15:24:56 -0700] “POST /index.html
HTTP/1.1” 200 19739 “http://192.168.1.50/rt” "Mozilla/4.0 (compatible;
MSIE 8.0; Windows NT 5.1; Trident/4.0)"
192.168.1.104 - - [05/Oct/2009:15:24:56 -0700] “GET /_graphics/sky.jpg
HTTP/1.1” 304 - “http://192.168.1.50/index.html” “Mozilla/4.0
(compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)”

----- START -----------------------

Set($WebPath , “/rt”);

Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));

#Set($WebBaseURL , “http://backup.easyrider.com:$WebPort”);
Set($WebBaseURL , “http://localhost:$WebPort”);

Set($WebURL , $WebBaseURL . $WebPath . “/”);

Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

Set($LogoURL , $WebImagesURL . “bplogo.gif”);
Set($LogoLinkURL, ‘http://security.nocdesigns.com’);
Set($LogoAltText, “Easyrider LAN Pro”);

WebNoAuthRegex - What portion of RT’s URLspace should not require

authentication.

Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

#------ END -----------------------

Bennett, Bevan (IS) wrote:

So adding the SetHandler directive for the images directory didn’t fix
your logo? That’s what did it for me.
I’d help more explicitly, but I don’t have fastCGI and don’t want to
figure out how to install it. (mod_perl came in a handy package for my
distro).

The difference between sessions logged in prior and subsequent sounds
like there’s some server still running that hasn’t gotten the memo.
Did you reload httpd, or fully stop and start it? Is there a separate
fastCGI service that needs to have it’s head/cache examined?
I had major graphics displaying issues previously. I think the NOAUTH
location section fixed that. The Logo is coming out of settings in
RT_siteconfig.pm which I think still has problems being loaded correctly.

I stopped everything RT related, checked for orphans and started back up
again. I don’t understand any of this cgi stuff but is ExecCGI in your
directory example correct?

I think this is VERY close to working correctly. Just a matter of
finding the right httpd.conf combination

The following works perfectly except that it runs out of the root
Shows correct WebLogo
Requires $WebPath = ‘’";

----- START --------

NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

------ END -------

The following runs perfectly out of /helpdesk IF you are already
logged in. Otherwise you get sent immediately to
/var/www/html/index.html as soon as you hit the login button:
WebLogo does not display and the alt text displays best practical which
is no longer in RT_siteconfig.pm
Requires $WebPath = ‘/helpdesk’;

----- START --------

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/
AddHandler fastcgi-script fcgi

<Location /helpdesk>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

<Location /helpdesk/NoAuth/images>
SetHandler default

------ END ------

For what its worth, I couldn’t get the logo to work until I replaced local/html/NoAuth/images/bplogo.gif with my own (IE named mine bplogo.gif) and, make sure it is no larger then the original size…From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Easyrider Inquiry
Sent: Monday, October 05, 2009 9:58 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Web interface configuration question

Bennett, Bevan (IS) wrote:

So adding the SetHandler directive for the images directory didn’t fix
your logo? That’s what did it for me.
I’d help more explicitly, but I don’t have fastCGI and don’t want to
figure out how to install it. (mod_perl came in a handy package for my
distro).

The difference between sessions logged in prior and subsequent sounds
like there’s some server still running that hasn’t gotten the memo.
Did you reload httpd, or fully stop and start it? Is there a separate
fastCGI service that needs to have it’s head/cache examined?
I had major graphics displaying issues previously. I think the NOAUTH location section fixed that. The Logo is coming out of settings in RT_siteconfig.pm which I think still has problems being loaded correctly.

I stopped everything RT related, checked for orphans and started back up again. I don’t understand any of this cgi stuff but is ExecCGI in your directory example correct?

I think this is VERY close to working correctly. Just a matter of finding the right httpd.conf combination

The following works perfectly except that it runs out of the root Shows correct WebLogo Requires $WebPath = ‘’";

----- START --------

NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

------ END -------

The following runs perfectly out of /helpdesk IF you are already logged in. Otherwise you get sent immediately to /var/www/html/index.html as soon as you hit the login button:
WebLogo does not display and the alt text displays best practical which is no longer in RT_siteconfig.pm Requires $WebPath = ‘/helpdesk’;

----- START --------

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/
AddHandler fastcgi-script fcgi

<Location /helpdesk>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

<Location /helpdesk/NoAuth/images>
SetHandler default

------ END ------

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com
This e-mail message is intended only for the personal use of the recipient(s) named above. If you are not an intended recipient, you may not review, copy or distribute this message. If you have received this communication in error, please notify the Hearst Service Center (cadmin@hearstsc.com) immediately by email and delete the original message.

Lander, Scott wrote:

For what its worth, I couldn’t get the logo to work until I replaced local/html/NoAuth/images/bplogo.gif with my own (IE named mine bplogo.gif) and, make sure it is no larger then the original size…

I think this is VERY close to working correctly. Just a matter of finding the right httpd.conf combination

The following works perfectly except that it runs out of the root Shows correct WebLogo Requires $WebPath = ‘’";

----- START --------

NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

------ END -------

The following runs perfectly out of /helpdesk IF you are already logged in. Otherwise you get sent immediately to /var/www/html/index.html as soon as you hit the login button:
WebLogo does not display and the alt text displays best practical which is no longer in RT_siteconfig.pm Requires $WebPath = ‘/helpdesk’;

----- START --------

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/
AddHandler fastcgi-script fcgi

<Location /helpdesk>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

<Location /helpdesk/NoAuth/images>
SetHandler default

------ END ------


Yep, I knew that :slight_smile:
The logo does work but only with the first httpd.conf settings. It’s a
small issue that does not concern me except that it’s another symptom
that might help me get RT properly configured to run out of
backup.easyrider.com/helpdesk and not backup.easyrider.com

What a hassle :frowning:

I think this is now VERY close to working correctly. Just a matter of
finding the right httpd.conf combination

The following works perfectly except that it runs out of the root. Shows
correct WebLogo. Requires RT_siteconfig.pm: $WebPath = ‘’";

What I want is to access RT via http//backup.easyrider.com/helpdesk

I’m guessing example 2 has just one missing or incorrect entry

----- START example 1 --------

<NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

------ END 1 -------

The following immediately sends the browser to /var/www/html/index.html
as soon as you hit the login button:

WebLogo does not display on the login screen and the alt text displays
best practical which is no longer in RT_siteconfig.pm
Requires $WebPath = ‘/helpdesk’;
I mention the logo problem only as a symptom that makes me suspicious
that there are problems loading RT_siteconfig.pm

----- START example 2--------

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/
AddHandler fastcgi-script fcgi

<Location /helpdesk>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

<Location /helpdesk/NoAuth/images>
SetHandler default

------ END 2 ------

I could REALLY use some help here. Please? Seriously. I could really
use some help getting httpd.conf set correctly.

I’ve been fighting a losing battle with this for well over a week. I’ve
tried a gazillion combinations based on various threads that I’ve read
and various comments I have received. What I REALLY need is for some
kindly soul who REALLY understands this stuff to just tell me what lines
I need to change/add/delete.

The short of it is that RT is just not usable if I can’t get it to quit
capturing the root URL.

I think I have this is VERY close to working correctly. Just a matter
of finding the right httpd.conf combination and finding someone who is
willing to share their expertise.

I need to run RT out of http://backup.easyrider.com/helpdesk not
http://backup.easyrider.com (it’s stomping everything else that runs out
of /var/www/html!)

The following works perfectly except that it runs out of the root (where
I don’t want it). Shows correct WebLogo. Requires RT_siteconfig.pm:
$WebPath = ‘’";

What I want is to access RT via http//backup.easyrider.com/helpdesk

I’m assuming that somewhere on the Planet, someone has RT working like
this. I just don’t have the luxury of dedicating an entire server to
doing nothing but RT. Additionally, people around me are becoming
impatient. RT (as set up below) responds no matter what URL is entered
including user public_html web pages.

I’m guessing example 2 has just one missing or incorrect entry

----- START example 1 works great but RT runs from root URL --------

<NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

------ END 1 -------

The following immediately sends the browser to /var/www/html/index.html
as soon as you hit the login button:

WebLogo does not display on the login screen and the alt text displays
best practical which is no longer in RT_siteconfig.pm
Requires $WebPath = ‘/helpdesk’;
I mention the logo problem only as a symptom that makes me suspicious
that there are problems loading RT_siteconfig.pm

----- START example 2 works from /helpdesk (sort of) --------

----- but immediately sends you to the root when you click login —

----- logo in RT_Siteconfig.pm does not display ------

<Directory /opt/rt3/share/html">
Options FollowSymLinks ExecCGI
AllowOverride None

<VirtualHost *:80>
ServerName backup.easyrider.com
DocumentRoot /var/www/html

ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/
AddHandler fastcgi-script fcgi

<Location /helpdesk>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

<Location /helpdesk/NoAuth/images>
SetHandler default

------ END 2 ------

Various mod attempts to /opt/rt3/etc/RT_SiteConfig.pm

----- START -----------------------

Next uncommented to run RT in root

Set($WebPath , “”);

Try this for helpdesk (doesn’t work)

#Set($WebPath , ‘/opt/rt3/share/html/’);

ditto

Next uncommented to run RT out of helpdesk

#Set($WebPath , “/helpdesk”);

Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));

Set($WebBaseURL , “http://backup.easyrider.com:$WebPort”);
#Set($WebBaseURL , “http://localhost:$WebPort”);

Set($WebURL , $WebBaseURL . $WebPath . “/”);

Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

Displays my logo (which was renamed bplogo.gif

Displays best practical URL, not the one below

Set($LogoURL , $WebImagesURL . “bplogo.gif”);
Set($LogoLinkURL, ‘http://security.nocdesigns.com’);
Set($LogoAltText, “Easyrider LAN Pro”);

WebNoAuthRegex - What portion of RT’s URLspace should not require

authentication.

Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

#------ END -----------------------

What I want is to access RT via http//backup.easyrider.com/helpdesk

<NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

Think about it. How does the above configuration tell Apache how to handle
a /helpdesk request?

You need to change the Alias and ScriptAlias lines to:

Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/

The RT_SiteConfig.pm should have the following:

Set($WebPath , “/helpdesk”);
Set($WebBaseURL ,
http://backup.easyrider.comhttp://backup.easyrider.com/helpdesk
”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

I’d get rid of all the other Set($Web syntax…

The above should allow you to properly run RT at:

http://backup.easyrider.com/helpdesk

Depending on your exact Apache config (and mod_perl vs. mod_fastcgi), you
may need to put a trailing / at the end of the URL in order for things to
properly work:

http://backup.easyrider.com/helpdesk/

James Moseley

James Moseley wrote:> On Sun, Oct 11, 2009 at 6:13 PM, Easyrider Inquiry <Inquiry@easyrider.com mailto:Inquiry@easyrider.com> wrote:

What I want is to access RT via
http//backup.easyrider.com/helpdesk
<http://backup.easyrider.com/helpdesk>

<NameVirtualHost *:80
  <VirtualHost *:80>
   ServerName backup.easyrider.com <http://backup.easyrider.com>
   AddDefaultCharset UTF-8
   AddHandler fastcgi-script .fcgi
   Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
   ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
 </VirtualHost>

Think about it. How does the above configuration tell Apache how to
handle a /helpdesk request?

You need to change the Alias and ScriptAlias lines to:

Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/

The RT_SiteConfig.pm should have the following:

Set($WebPath , “/helpdesk”);
Set($WebBaseURL , “http://backup.easyrider.com
http://backup.easyrider.com/helpdesk”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

I’d get rid of all the other Set($Web syntax…

The above should allow you to properly run RT at:

http://backup.easyrider.com/helpdesk

Depending on your exact Apache config (and mod_perl vs. mod_fastcgi),
you may need to put a trailing / at the end of the URL in order for
things to properly work:

http://backup.easyrider.com/helpdesk/


James Moseley
Hello James. Thanks VERY much for responding.

Unfortunately, no luck :frowning:

Rather than experiment with a million more combinations before replying,
I’ll just post the current configuration (which I believe are teh
settings you advised) and say that I am now getting an internal server
error: The server encountered an internal error or misconfiguration and
was unable to complete your request.

/opt/rt3/etc/RT_SiteConfig.pm:

---- Latest advice START ---------

Set($WebPath , “/helpdesk”);
Set($WebBaseURL , “http://backup.easyrider.com”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($LogoURL , $WebImagesURL . “bplogo.gif”);
Set($LogoLinkURL, ‘http://security.nocdesigns.com’);
Set($LogoAltText, “Easyrider LAN Pro”);
Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

---- Latest advice END -----------

/etc/httpd/conf/httpd.conf:

Latest RT config experiment give internal server error

----- Latest advice START ---------

  <VirtualHost *:80>
   ServerName backup.easyrider.com
   AddDefaultCharset UTF-8
   AddHandler fastcgi-script .fcgi
   Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
   ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/
 </VirtualHost>

---- Latest advice END -----------

Hello James. Thanks VERY much for responding.

Unfortunately, no luck :frowning:

Rather than experiment with a million more combinations before replying,
I’ll just post the current configuration (which I believe are teh settings
you advised) and say that I am now getting an internal server error: The
server encountered an internal error or misconfiguration and was unable to
complete your request.

/opt/rt3/etc/RT_SiteConfig.pm:

---- Latest advice START ---------

Set($WebPath , “/helpdesk”);
Set($WebBaseURL , "http://backup.easyrider.com"http://backup.easyrider.com
);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($LogoURL , $WebImagesURL . “bplogo.gif”);
Set($LogoLinkURL, ‘http://security.nocdesigns.com’);
Set($LogoAltText, “Easyrider LAN Pro”);
Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

In my previous post, I said get rid rid of the other Set($Web* syntax. They
are only confusing troubleshooting the issue and probably aren’t needed. If
you do need specific web port and web regex overrides due to your specific
configuration, add them back in later once you’ve gotten the basic install
working.

---- Latest advice END -----------

/etc/httpd/conf/httpd.conf:

Latest RT config experiment give internal server error

----- Latest advice START ---------

  <VirtualHost *:80>
   ServerName backup.easyrider.com
   AddDefaultCharset UTF-8
   AddHandler fastcgi-script .fcgi
   Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
   ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/
 </VirtualHost>

And what did the Apache error log state? More than likely, the problematic
syntax in RT_SiteConfig.pm caused the error. You also claim everything was
working with just the server name. What I don’t see in the above Apache
config is where you load the FastCgi module, amongst other things. What
module are you using, mod_fastcgi?

Lastly, mail sent directly to you bounced because your server rejected it.
You must have received my reply via the cc to the general list. Please look
at the mail server logs to see why it is/was rejecting mail.

James Moseley

James Moseley wrote:> On Sun, Oct 11, 2009 at 8:14 PM, Easyrider Inquiry <Inquiry@easyrider.com mailto:Inquiry@easyrider.com> wrote:

Hello James.  Thanks VERY much for responding.

Unfortunately, no luck :(

Rather than experiment with a million more combinations before
replying, I'll just post the current configuration (which I
believe are teh settings you advised) and say that I am now
getting an internal server error: The server encountered an
internal error or misconfiguration and was unable to complete your
request.

/opt/rt3/etc/RT_SiteConfig.pm:

# ---- Latest advice START ---------

Set($WebPath , "/helpdesk");
Set($WebBaseURL , "http://backup.easyrider.com"
<http://backup.easyrider.com>);
Set($WebImagesURL , $WebPath . "/NoAuth/images/");

Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));
Set($WebURL , $WebBaseURL . $WebPath . "/");
Set($LogoURL , $WebImagesURL . "bplogo.gif");
Set($LogoLinkURL, 'http://security.nocdesigns.com');
Set($LogoAltText, "Easyrider LAN Pro");
Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
                            /+REST/\d+\.\d+/NoAuth/)!x );

In my previous post, I said get rid rid of the other Set($Web*
syntax. They are only confusing troubleshooting the issue and
probably aren’t needed. If you do need specific web port and web
regex overrides due to your specific configuration, add them back in
later once you’ve gotten the basic install working.

# ---- Latest advice END -----------

/etc/httpd/conf/httpd.conf:

# Latest RT config experiment give internal server error

# ----- Latest advice START ---------

      <VirtualHost *:80>
       ServerName backup.easyrider.com <http://backup.easyrider.com>
       AddDefaultCharset UTF-8
       AddHandler fastcgi-script .fcgi
       Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
       ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/
     </VirtualHost>

And what did the Apache error log state? More than likely, the
problematic syntax in RT_SiteConfig.pm caused the error. You also
claim everything was working with just the server name. What I don’t
see in the above Apache config is where you load the FastCgi module,
amongst other things. What module are you using, mod_fastcgi?

Lastly, mail sent directly to you bounced because your server rejected
it. You must have received my reply via the cc to the general list.
Please look at the mail server logs to see why it is/was rejecting mail.


James Moseley

Thanks for getting back to me James. Previously, when someone gave me
some advice I would spend a great many hours troubleshooting further
when their suggestions didn’t pan out. To be honest, my failure to get
RT running has been very humbling so if I follow someone’s instructions
and they don’t solve the problem (or make things worse) I just respond
with the results and hope for more guidance.

I cannot fix this problem on my own. I feel extremely stupid because of
this. I’m an idiot. I cannot do this without some help. 'Nuff said?

I removed all of the other Web stuff as you instructed. No difference.

Error log follows.

I don’t know how to answer your mod_fastcgi question except to say that
I followed the installation instructions religiously, that I have no
clue what fastcgi is and that below I have included two examples… the
first, which is based on your suggestions, which does not work. The
second, following the installation procedure instructions, which does
work but as I said, using the root URL. As you can see, the
configurations are nearly identical. Imagine my frustration, if you
can, that I have spent around ten days [unsuccessfully] troubleshooting
a problem that I isolated to two or three lines of code a week ago. I
have nearly 45 years of computer systems engineering experience and at
one time I actually was smart.

Mail from SKYNETWEBBLACKHOLES is blacklisted on our mail server due to
them hosting spammer sites I presume. I added both of your e-mail
addresses to my whitelist. It’s probably best to keep this thread
intact on the forum though. The first thing I did, before asking anyone
for help, was to search the database for similar threads and found
nothing helpful. Hopefully, if/when this gets solved, I will put a
clean configuration update for those who follow to use as a model.

RT is most likely [temporarily] accessible from the Internet. If so,
you can see that http://backup.easyrider.com brings up RT nicely. All
attempts to run RT from http://backup.easyrider.com/helpdesk have so far
failed.

[root@security webalizer-2.21-02]# tail /var/log/httpd/error_log
[Sun Oct 11 19:21:32 2009] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 18020) terminated by calling exit
with status ‘9’
[Sun Oct 11 19:21:32 2009] [notice] Apache/2.0.53 (Fedora) configured –
resuming normal operations
[Sun Oct 11 19:21:33 2009] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18029)
Couldn’t load RT config file RT_SiteConfig.pm:

Quantifier follows nothing in regex; marked by <-- HERE in m/+ <-- HERE
REST/ at /opt/rt3/etc/RT_SiteConfig.pm line 393.
Compilation failed in require at /opt/rt3/bin/…/lib/RT/Config.pm line 516.
BEGIN failed–compilation aborted at /opt/rt3/bin/webmux.pl line 102.
Compilation failed in require at /opt/rt3/bin/mason_handler.fcgi line 55.
[Sun Oct 11 19:21:33 2009] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 18029) terminated by calling exit
with status ‘9’
[root@security webalizer-2.21-02]#

/opt/rt3/etc/RT_SiteConfig.pm:

---- Latest advice START ---------

Gives internal server error message

Set($WebPath , “/helpdesk”);
Set($WebBaseURL , “http://backup.easyrider.com”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

#Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));
#Set($WebURL , $WebBaseURL . $WebPath . “/”);
#Set($LogoURL , $WebImagesURL . “bplogo.gif”);
#Set($LogoLinkURL, ‘http://security.nocdesigns.com’);
#Set($LogoAltText, “Easyrider LAN Pro”);
#Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

---- Latest advice END -----------

/etc/httpd/conf/httpd.conf:

----- START ---------

NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/

---- END -----------

This works but as http://backup.easyrider.com

----- START -----------------------

Set($WebPath , “”);
Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));
Set($WebBaseURL , “http://backup.easyrider.com:$WebPort”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);
Set($LogoURL , $WebImagesURL . “bplogo.gif”);
Set($LogoLinkURL, ‘http://security.nocdesigns.com’);
Set($LogoAltText, “Easyrider LAN Pro”);
Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

#------ END -----------------------

----- START --------

NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

------ END -------

Quantifier follows nothing in regex; marked by <-- HERE in m/+ <-- HERE
REST/ at /opt/rt3/etc/RT_SiteConfig.pm line 393.

The above line in the error log tells you exactly where and what the problem
is. The problem is with a regex expression on line 393.

Sure enough, look at this below:

[root@security webalizer-2.21-02]#

/opt/rt3/etc/RT_SiteConfig.pm:

#Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

The problem is that the second line above (the one with REST in it) was
supposed to be part of the line above it, but more than likely when you
pasted it in, your text editor didn’t wrap the line and instead put in a
line break. You need to comment out that second line as well - that’s what
is causing the error.

As far as your Apache configuration, you have RT setup to use mod_fastcgi.
In those instructions, you must also have the following somewhere in your
config:

FastCgiIpcDir /tmp

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120

These are outside the virtual host stanza and since you claim RT works for
you at the root level, your Apache configuration obviously has those
necessary lines and is otherwise setup correctly. All you need now to get
http://backup.easyrider.com/helpdesk/ working is to use the following Alias
and ScriptAlias lines:

Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/

James Moseley

James Moseley wrote:> On Sun, Oct 11, 2009 at 10:09 PM, Easyrider Inquiry <Inquiry@easyrider.com mailto:Inquiry@easyrider.com> wrote:

Quantifier follows nothing in regex; marked by <-- HERE in m/+ <--
HERE REST/ at /opt/rt3/etc/RT_SiteConfig.pm line 393.

The above line in the error log tells you exactly where and what the
problem is. The problem is with a regex expression on line 393.

Sure enough, look at this below:

[root@security webalizer-2.21-02]#

/opt/rt3/etc/RT_SiteConfig.pm:

#Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
                            /+REST/\d+\.\d+/NoAuth/)!x );

The problem is that the second line above (the one with REST in it)
was supposed to be part of the line above it, but more than likely
when you pasted it in, your text editor didn’t wrap the line and
instead put in a line break. You need to comment out that second line
as well - that’s what is causing the error.

As far as your Apache configuration, you have RT setup to use
mod_fastcgi. In those instructions, you must also have the following
somewhere in your config:

FastCgiIpcDir /tmp

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120

These are outside the virtual host stanza and since you claim RT works
for you at the root level, your Apache configuration obviously has
those necessary lines and is otherwise setup correctly. All you need
now to get http://backup.easyrider.com/helpdesk/ working is to use the
following Alias and ScriptAlias lines:

Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/


James Moseley
Thanks James and you are correct. After editing these same two files
for many hundreds of times I am getting sloppy/tired. I missed the pipe
symbol that caused the following incomplete line to be read in.

I am now at essentially the same problem I had a week ago where someone
was able to help me get /helpdesk to bring up the login page but as soon
as you hit “login” the browser goes directly to the site web page at
/var/www/html. I believe you can verify this from the Internet as well.

I did a grep for FastCgiIpcDir /tmp and FastCgiServer
/opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 in httpd.conf and
found nothing but as you say, it seems likely that they are there
somewhere since the root URL RT works just fine. The difference between
the configuration that works and the configuration that almost works is
literally less than a half dozen lines of code.

I did spend several days trying various combinations of entries in the
examples listed in
http://wiki.bestpractical.com/view/FedoraCore4InstallGuide to get around
my current problem. Each change either had no effect or made things
worse. The fellow who was helping me last week eventually gave up which
is probably what I would do too if quitting was an option.

This shouldn’t matter, but I’m running a RHEL4 server and Apache 2.0.53.

Nothing interesting in httpd error_log

You can see the failure when a POST /index.html is issued and a get to
the _graphics directory in /var/www/html

http access_log:

192.168.1.1 - - [11/Oct/2009:21:18:58 -0700] “GET
/helpdesk/NoAuth/js/scriptaculous/effect
s.js HTTP/1.1” 200 38745 “http://backup.easyrider.com/helpdesk
"Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET
CLR 3.5.30729)"
192.168.1.1 - - [11/Oct/2009:21:18:58 -0700] “GET
/helpdesk/NoAuth/js/scriptaculous/contro
ls.js HTTP/1.1” 200 35048 “http://backup.easyrider.com/helpdesk
"Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET
CLR 3.5.30729)"
192.168.1.1 - - [11/Oct/2009:21:19:00 -0700] "POST /index.html HTTP/1.1"
200 19739 “http:/
/backup.easyrider.com/helpdesk” "Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.9.1.
3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)"
192.168.1.1 - - [11/Oct/2009:21:19:01 -0700] “GET /_graphics/sky.jpg
HTTP/1.1” 200 3862 “h
ttp://backup.easyrider.com/index.html” “Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv
:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)”

---- Latest advice START ---------

Set($WebPath , “/helpdesk”);
Set($WebBaseURL , “http://backup.easyrider.com”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

---- Latest advice END -----------

----- START ---------

NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/

---- END -----------

I am now at essentially the same problem I had a week ago where someone was
able to help me get /helpdesk to bring up the login page but as soon as you
hit “login” the browser goes directly to the site web page at
/var/www/html. I believe you can verify this from the Internet as well.

Remember in a previous email I told you about that trailing /?

Try: http://backup.easyrider.com/helpdesk/

and see if that works… It does for me…

I did a grep for FastCgiIpcDir /tmp and FastCgiServer
/opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 in httpd.conf and found
nothing but as you say, it seems likely that they are there somewhere since
the root URL RT works just fine. The difference between the configuration
that works and the configuration that almost works is literally less than a
half dozen lines of code.

I did spend several days trying various combinations of entries in the
examples listed in
http://wiki.bestpractical.com/view/FedoraCore4InstallGuide to get around
my current problem. Each change either had no effect or made things worse.
The fellow who was helping me last week eventually gave up which is probably
what I would do too if quitting was an option.

Well, if you claim everything works the other way around, you must have
those lines someplace… Look in the config files in /etc/httpd/conf.d/*

James Moseley

James Moseley wrote:

I am now at essentially the same problem I had a week ago where
someone was able to help me get /helpdesk to bring up the login
page but as soon as you hit "login" the browser goes directly to
the site web page at /var/www/html.  I believe you can verify this
from the Internet as well.

Remember in a previous email I told you about that trailing /?

Try: http://backup.easyrider.com/helpdesk/

and see if that works… It does for me…

I did a grep for FastCgiIpcDir /tmp and FastCgiServer
/opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 in httpd.conf
and found nothing but as you say, it seems likely that they are
there somewhere since the root URL RT works just fine.  The
difference between the configuration that works and the
configuration that almost works is literally less than a half
dozen lines of code.

I did spend several days trying various combinations of entries in
the examples listed in
http://wiki.bestpractical.com/view/FedoraCore4InstallGuide to get
around my current problem.  Each change either had no effect or
made things worse.  The fellow who was helping me last week
eventually gave up which is probably what I would do too if
quitting was an option.

Well, if you claim everything works the other way around, you must
have those lines someplace… Look in the config files in
/etc/httpd/conf.d/*


James Moseley
Oh Brother! I’ve sacrificed a week out of what’s left of my life over a
trailing slash??? Holy cow. This is why I am not a programmer…

I REALLY appreciate your patience and your willingness to stick with
this to a final solution. VERY much appreciated! Now I need to do a
good deed for someone to keep the chain going.

So just for fun, what do I need to do to get /helpdesk to work without
the trailing slash when someone complains about it and I’ve long since
forgotten about last week’s pain?

Also, a tiny thing that I wouldn’t even care about except that it’s one
of those things I’d rather fix while I am in there and everything is
fresh in my mind. There’s still things in RT_siteconfig.pm that aren’t
being honored, such as LogoLinkURL. If it’s an easy fix I’d prefer to
do it since I’m guessing there’s still something in that pm file that
isn’t quite right. My previous experience with RT is that it is
bullet-proof once you get it up and running. Once I get these few tiny
things resolved I don’t expect to have to mess around with it again for
a very long time.

Just for those who come along with the same problem and read this thread:

[root@security webalizer-2.21-02]# grep -i fastcgi /etc/httpd/conf.d/*
/etc/httpd/conf.d/FastCGI.conf:LoadModule fastcgi_module
modules/mod_fastcgi.so
/etc/httpd/conf.d/FastCGI.conf: FastCgiIpcDir /tmp
/etc/httpd/conf.d/FastCGI.conf: FastCgiServer
/opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 -processes 8
/etc/httpd/conf.d/FastCGI.conf: FastCgiConfig -restart
[root@security webalizer-2.21-02]#

This is a configuration that works for http://backup.easyrider.com/helpdesk/

----- START ---------

NameVirtualHost *:80
<VirtualHost *:80>
ServerName backup.easyrider.com
ServerAdmin nospam_2009@Easyrider.com
AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
Alias /helpdesk/NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias /helpdesk /opt/rt3/bin/mason_handler.fcgi/

---- END -----------

---- START ---------

Set($WebPath , “/helpdesk”);
Set($WebBaseURL , “http://backup.easyrider.com”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

---- END -----------

Things further down the file that may/may not be working correctly

Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($LogoURL , $WebImagesURL . “bplogo.gif”);

The following directives are not being honored

Set($LogoLinkURL, ‘http://security.nocdesigns.com’); # Still displays
bestpractical
Set($LogoAltText, “Easyrider LAN Pro”);

Set($WebNoAuthRegex, qr!^(?:/+NoAuth/| /+REST/\d+.\d+/NoAuth/)!x );

Oh Brother! I’ve sacrificed a week out of what’s left of my life over a
trailing slash??? Holy cow. This is why I am not a programmer…

I REALLY appreciate your patience and your willingness to stick with this
to a final solution. VERY much appreciated! Now I need to do a good deed
for someone to keep the chain going.

So just for fun, what do I need to do to get /helpdesk to work without the
trailing slash when someone complains about it and I’ve long since forgotten
about last week’s pain?

Also, a tiny thing that I wouldn’t even care about except that it’s one of
those things I’d rather fix while I am in there and everything is fresh in
my mind. There’s still things in RT_siteconfig.pm that aren’t being
honored, such as LogoLinkURL. If it’s an easy fix I’d prefer to do it since
I’m guessing there’s still something in that pm file that isn’t quite
right. My previous experience with RT is that it is bullet-proof once you
get it up and running. Once I get these few tiny things resolved I don’t
expect to have to mess around with it again for a very long time.

That trailing slash has nothing to do with RT and is an Apache/FastCGI
deal. I’ve never bothered with figuring out why it works that way.

You might be able to fix that with a redirect or editing the
Script/ScriptAlias lines. Google it.

James Moseley

That trailing slash has nothing to do with RT and is an Apache/FastCGI
deal. I’ve never bothered with figuring out why it works that way.

You might be able to fix that with a redirect or editing the
Script/ScriptAlias lines. Google it.

Doing a little research, the trailing slash is required due to how Apache
rewrites URL’s. There are ways to manipulate that behavior. Mod_dir is one
such method…

James Moseley

So just for fun, what do I need to do to get /helpdesk to work
without the trailing slash when someone complains about it and
I've long since forgotten about last week's pain?

The quick, dirty, and lame solution is to simply put a helpdesk.html
with a redirect.

(not tested, but I use a similar method in other cases where I wanted a
quick/lame solution)

Robert

James Moseley wrote:> On Mon, Oct 12, 2009 at 12:19 AM, James Moseley <jmoseley@corp.xanadoo.com mailto:jmoseley@corp.xanadoo.com> wrote:

That trailing slash has nothing to do with RT and is an
Apache/FastCGI deal.  I've never bothered with figuring out why it
works that way.

You might be able to fix that with a redirect or editing the
Script/ScriptAlias lines. Google it.

Doing a little research, the trailing slash is required due to how
Apache rewrites URL’s. There are ways to manipulate that behavior.
Mod_dir is one such method…


James Moseley

OK, thanks for the follow-up James. Sounds like it’s more work than
it’s worth. You used to be able to just set an Alias in httpd.conf for
/rt and /rt/ and everything worked great. But of course that was many
revs back on RT. I ran 3.0.1 for many, many years with zero problems
until the server finally dropped dead of old age.

Hey, this is mostly working just swell so I think I’ll quit while I’m
finally ahead. Many thanks again for all your help!