Web browser just shows Index of/

So i’ve been at this for awhile now, I’m trying to do a install of RT 4.4.2 on Ubuntu 14.04 with this guide and when I get to the moment of truth to find out if you install was successful I get this.

index2

If i click on html it takes me to the default Apache page.

Any help is greatly appreciated, thank you in advance.

You did not configure your web server. Without seeing the configuration it’s difficult to tell what is missing…

Gerald do you know which .conf file it is? Would it be this file?
/etc/apache2/sites-available/rt.conf

It depends on whether that site file is enabled or not.

ls -laR /etc/apache2/sites-*

shows all sites you have available and those actually enabled…

drwxr-xr-x 2 root root 4096 May 28 19:15 .
drwxr-xr-x 8 root root 4096 May 28 17:49 …
-rw-r–r-- 1 root root 1385 May 29 05:10 000-default.conf
-rw-r–r-- 1 root root 6437 Jan 7 2014 default-ssl.conf
-rw-r–r-- 1 root root 7038 May 29 05:12 rt.conf

/etc/apache2/sites-enabled:
total 8
drwxr-xr-x 2 root root 4096 May 28 19:19 .
drwxr-xr-x 8 root root 4096 May 28 17:49 …
lrwxrwxrwx 1 root root 35 May 28 17:49 000-default.conf -> …/sites-available/000-default.conf
lrwxrwxrwx 1 root root 26 May 28 19:19 rt.conf -> …/sites-available/rt.conf

Here is my /etc/apache2/site-available/000-default.conf

<VirtualHost *:80>
# The ServerName directive sets the request scheme, hostname an$
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the Server$
# specifies what hostname must appear in the request’s Host: he$
# match this virtual host. For the default virtual host (this f$
# value is not decisive as it is used as a last resort host reg$
# However, you must set it for any further virtual host explici$
ServerName ****:80
Redirect / https://

    #ServerAdmin webmaster@localhost
    #DocumentRoot /var/www/html

    # Available loglevels: trace8, ..., trace1, debug, info, notice$
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For exam$
    # following line enables the CGI configuration for this host on$
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf

vim: syntax=apache ts=4 sw=4 sts=4 sr noet

I also realized that my ssl setting were wrong so now I have this displayed.

Here is my rt.conf file

# Request Tracker ServerName *************:443 AddDefaultCharset UTF-8 DocumentRoot /opt/rt4/share/html Alias /NoAuth/images/ /opt/rt4/share/html/NoAuth/images/ ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/ ## Apache version < 2.4 (e.g. Debian 7.2) #Order allow,deny #Allow from all ## Apache 2.4 Require all granted SSLOptions +StdEnvVars
            # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
            # error, crit, alert, emerg.
            # It is also possible to configure the loglevel for particular
            # modules, e.g.
            #LogLevel info ssl:warn

            ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined

            # For most configuration files from conf-available/, which are
            # enabled or disabled at a global level, it is possible to
            # include a line for only one particular virtual host. For example the
            # following line enables the CGI configuration for this host only
            # after it has been globally disabled with "a2disconf".
            #Include conf-available/serve-cgi-bin.conf

            #   SSL Engine Switch:
            #   Enable/Disable SSL for this virtual host.
            SSLEngine on

            #   A self-signed (snakeoil) certificate can be created by installing
            #   the ssl-cert package. See
            #   /usr/share/doc/apache2/README.Debian.gz for more info.
            #   If both key and certificate are stored in the same file, only the
            #   SSLCertificateFile directive is needed.
            SSLCertificateFile      /etc/ssl/certs/ssl-cert-snakeoil.pem
            SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

            #   Server Certificate Chain:
            #   Point SSLCertificateChainFile at a file containing the
            #   concatenation of PEM encoded CA certificates which form the
            #   certificate chain for the server certificate. Alternatively
            #   the referenced file can be the same as SSLCertificateFile
            #   when the CA certificates are directly appended to the server
            #   certificate for convinience.
            #SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt

            #   Certificate Authority (CA):
            #   Set the CA certificate verification path where to find CA
            #   certificates for client authentication or alternatively one
            #   huge file containing all of them (file must be PEM encoded)
            #   Note: Inside SSLCACertificatePath you need hash symlinks
            #                to point to the certificate files. Use the provided
            #                Makefile to update the hash symlinks after changes.
            #SSLCACertificatePath /etc/ssl/certs/
            #SSLCACertificateFile /etc/apache2/ssl.crt/ca-bundle.crt

            #   Certificate Revocation Lists (CRL):
            #   Set the CA revocation path where to find CA CRLs for client
            #   authentication or alternatively one huge file containing all
            #   of them (file must be PEM encoded)
            #   Note: Inside SSLCARevocationPath you need hash symlinks
            #                to point to the certificate files. Use the provided
            #                Makefile to update the hash symlinks after changes.
            #SSLCARevocationPath /etc/apache2/ssl.crl/
            #SSLCARevocationFile /etc/apache2/ssl.crl/ca-bundle.crl

            #   Client Authentication (Type):
            #   Client certificate verification type and depth.  Types are
            #   none, optional, require and optional_no_ca.  Depth is a
            #   number which specifies how deeply to verify the certificate
            #   issuer chain before deciding the certificate is not valid.
            #SSLVerifyClient require
            #SSLVerifyDepth  10

            #   SSL Engine Options:
            #   Set various options for the SSL engine.
            #   o FakeBasicAuth:
            #        Translate the client X.509 into a Basic Authorisation.  This means that
            #        the standard Auth/DBMAuth methods can be used for access control.  The
            #        user name is the `one line' version of the client's X.509 certificate.
            #        Note that no password is obtained from the user. Every entry in the user
            #        file needs this password: `xxj31ZMTZzkVA'.
            #   o ExportCertData:
            #        This exports two additional environment variables: SSL_CLIENT_CERT and
            #        SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
            #        server (always existing) and the client (only existing when client
            #        authentication is used). This can be used to import the certificates
            #        into CGI scripts.
            #   o StdEnvVars:
            #        This exports the standard SSL/TLS related `SSL_*' environment variables.
            #        Per default this exportation is switched off for performance reasons,
            #        because the extraction step is an expensive operation and is usually
            #        useless for serving static content. So one usually enables the
            #        exportation for CGI and SSI requests only.
            #   o OptRenegotiate:
            #        This enables optimized SSL connection renegotiation handling when SSL
            #        directives are used in per-directory context.
            #SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
            <FilesMatch "\.(cgi|shtml|phtml|php)$">
                            SSLOptions +StdEnvVars
            </FilesMatch>
            <Directory /usr/lib/cgi-bin>
                            SSLOptions +StdEnvVars
            </Directory>

            #   SSL Protocol Adjustments:
            #   The safe and default but still SSL/TLS standard compliant shutdown
            #   approach is that mod_ssl sends the close notify alert but doesn't wait for
            #   the close notify alert from client. When you need a different shutdown
            #   approach you can use one of the following variables:
            #   o ssl-unclean-shutdown:
            #        This forces an unclean shutdown when the connection is closed, i.e. no
            #        SSL close notify alert is send or allowed to received.  This violates
            #        the SSL/TLS standard but is needed for some brain-dead browsers. Use
            #        this when you receive I/O errors because of the standard approach where
            #        mod_ssl sends the close notify alert.
            #   o ssl-accurate-shutdown:
            #        This forces an accurate shutdown when the connection is closed, i.e. a
            #        SSL close notify alert is send and mod_ssl waits for the close notify
            #        alert of the client. This is 100% SSL/TLS standard compliant, but in
            #        practice often causes hanging connections with brain-dead browsers. Use
            #        this only for browsers where you know that their SSL implementation
            #        works correctly.
            #   Notice: Most problems of broken clients are also related to the HTTP
            #   keep-alive facility, so you usually additionally want to disable
            #   keep-alive for those clients, too. Use variable "nokeepalive" for this.
            #   Similarly, one has to force some clients to use HTTP/1.0 to workaround
            #   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
            #   "force-response-1.0" for this.
            BrowserMatch "MSIE [2-6]" \
                            nokeepalive ssl-unclean-shutdown \
                            downgrade-1.0 force-response-1.0
            # MSIE 7 and newer should be able to use keepalive
            BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

    </VirtualHost>

vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Hi Jaibers

What are the permissions on /opt/rt4/(local | share)/static

regards
Garry

This is what I got from doing ls -la on /opt/rt4

drwxr-xr-x 10 root root 4096 May 28 19:00 .
drwxr-xr-x 3 root root 4096 May 28 19:00 …
drwxr-xr-x 2 root root 4096 May 28 19:00 bin
drwxr-xr-x 7 root root 4096 May 28 19:00 docs
drwxr-xr-x 4 root rt 4096 May 28 19:00 etc
drwxr-xr-x 3 root bin 4096 May 28 19:00 lib
drwxr-xr-x 8 root root 4096 May 28 19:00 local
drwxr-xr-x 2 root root 4096 May 28 19:00 sbin
drwxr-xr-x 6 root root 4096 May 28 19:00 share
drwxr-xr-x 5 root root 4096 May 28 19:00 var

do you have a static directory in local with css and js in? if so what are the permissions and ownership of that folder

So Gary I have a /opt/rt4/local/static directory but there is nothing in it.

Gary its looks like all my css files are in /opt/rt4/share/static/css or /opt/rt-4.4.2/share/static/css.

thats where they should be unless you’ve made local modifications. Im wondering if the local static folder is overriding the share static folder

Right, so you’re back to more or less where you were before. Can you take a look at the web server logs to see if you’re getting 302 redirects for the CSS still?

If you are, can you use your web browser’s inspection/developer tools to look at the network requests being sent so that you can see what URL the 302 response from the web server is suggesting? The browser developer tools may give some idea as well if it’s a misdirected URL or something else (such as a loop).

1 Like

So bare with me Jim, /var/log/apache2 has these logs; access.log error.log other_vhosts_access.log. Which log file am I looking through? I don’t think this matters but that last post that I had the exact same problem was Centos 6 and this is Ubuntu 14.04.

I found this while viewing the page source.

inspect error

Try commenting out the above line from your port 80 virtual machine and restart the web server to see if that stops the redirection loops if you got straight to the https:// URL for your RT instance. If not, you must have something else in either your config or the network between your browser and the server (eg a proxy server, load balancer, etc) that is rewriting URLs and/or issuing redirects

Incidentally it is a bit tricky to read your configs as the formatting is a bit messed up. If you post any more, check the formatting in the preview pane to ensure it matches up with what you have in the file.

Jim I do apologize for my poor formatting, I commented out the Redirect / https:// and it didn’t change the lack of java and css.

I inspected it again on chrome and I did find this;
bad syntax

This is the .(index):39

So from what I can understand its looking for a Stylesheet but a javascript file is what is being found.

Any comments will be greatly appreciated, thank you all again.