Want to have /rt instead of /rt/

I configured RT 3.4.4 with Apache httpd 2.0.54 and FastCGI 2.4.2.

If I type http://hostname/rt in my Browser I get the Login Form. After
logging in I’m redirected to http://hostname/index.html instead of
http://hostname/rt/index.html

If I type http://hostname/rt/ everything works, but our customer don’t
want to have the trailing ‘/’.

How can I do this?

httpd.conf:
AddHandler fastcgi-script fcgi
ScriptAlias /rt /apps/opt/rt/current/bin/mason_handler.fcgi
Alias /NoAuth/ /apps/opt/rt/current/share/html/NoAuth/
<Directory “/apps/opt/rt/current/share/html”>
DirectoryIndex index.html
Options FollowSymLinks ExecCGI
AllowOverride None

FastCgiIpcDir /tmp
FastCgiServer /apps/opt/rt/current/bin/mason_handler.fcgi -idle-timeout
120 -processes 4

RT_SiteConfig.pm:
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://hostname:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Regards,

Tobias Warth

Usually Apache rewrite rule will help to add the trailing slash. Check your
config files.----- Original Message -----
From: Tobias.Warth@hp.com
To: rt-users@lists.bestpractical.com
Sent: Tuesday, September 20, 2005 2:02 PM
Subject: [rt-users] Want to have /rt instead of /rt/

I configured RT 3.4.4 with Apache httpd 2.0.54 and FastCGI 2.4.2.

If I type http://hostname/rt in my Browser I get the Login Form. After
logging in I’m redirected to http://hostname/index.html instead of
http://hostname/rt/index.html

If I type http://hostname/rt/ everything works, but our customer don’t
want to have the trailing ‘/’.

How can I do this?

httpd.conf:
AddHandler fastcgi-script fcgi
ScriptAlias /rt /apps/opt/rt/current/bin/mason_handler.fcgi
Alias /NoAuth/ /apps/opt/rt/current/share/html/NoAuth/
<Directory “/apps/opt/rt/current/share/html”>
DirectoryIndex index.html
Options FollowSymLinks ExecCGI
AllowOverride None

FastCgiIpcDir /tmp
FastCgiServer /apps/opt/rt/current/bin/mason_handler.fcgi -idle-timeout
120 -processes 4

RT_SiteConfig.pm:
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://hostname:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Regards,

Tobias Warth


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Redirect /rt http://hostname/rt/index.html

results in
http://hostname/rt/index.html/index.html/index.html/index.html/index.htm
l/index.html/index.html/index.html/index.html/index.html

Redirect /rt http://hostname/rt/

results in http://hostname/rt//////////////////////

RewriteEngine on
RewriteRule ^/rt$ /rt/ [R]

results in http://hostname/rt

Doesn’t work, in my configuration :-(From: Ricky Tang Siu Hong [mailto:shtang@clustertech.com]
Sent: Dienstag, 20. September 2005 11:12
To: Warth, Tobias; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Want to have /rt instead of /rt/

Usually Apache rewrite rule will help to add the trailing slash. Check
your config files.

From: Tobias.Warth@hp.com
To: rt-users@lists.bestpractical.com
Sent: Tuesday, September 20, 2005 2:02 PM
Subject: [rt-users] Want to have /rt instead of /rt/

I configured RT 3.4.4 with Apache httpd 2.0.54 and FastCGI 2.4.2.

If I type http://hostname/rt in my Browser I get the Login Form. After
logging in I’m redirected to http://hostname/index.html instead of
http://hostname/rt/index.html

If I type http://hostname/rt/ everything works, but our customer don’t
want to have the trailing ‘/’.

How can I do this?

httpd.conf:
AddHandler fastcgi-script fcgi
ScriptAlias /rt /apps/opt/rt/current/bin/mason_handler.fcgi
Alias /NoAuth/ /apps/opt/rt/current/share/html/NoAuth/
<Directory “/apps/opt/rt/current/share/html”>
DirectoryIndex index.html
Options FollowSymLinks ExecCGI
AllowOverride None

FastCgiIpcDir /tmp
FastCgiServer /apps/opt/rt/current/bin/mason_handler.fcgi
-idle-timeout
120 -processes 4

RT_SiteConfig.pm:
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://hostname:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Regards,

Tobias Warth


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Redirect /rt http://hostname/rt/index.html

results in
http://hostname/rt/index.html/index.html/index.html/index.html/index.htm
l/index.html/index.html/index.html/index.html/index.html

Redirect /rt http://hostname/rt/

results in http://hostname/rt//////////////////////

RewriteEngine on
RewriteRule ^/rt$ /rt/ [R]

results in http://hostname/rt

Doesn’t work, in my configuration :frowning:

-----Original Message-----
From: Ricky Tang Siu Hong [mailto:shtang@clustertech.com]
Sent: Dienstag, 20. September 2005 11:12
To: Warth, Tobias; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Want to have /rt instead of /rt/

Usually Apache rewrite rule will help to add the trailing slash. Check
your config files.

----- Original Message -----
From: Tobias.Warth@hp.com
To: rt-users@lists.bestpractical.com
Sent: Tuesday, September 20, 2005 2:02 PM
Subject: [rt-users] Want to have /rt instead of /rt/

I configured RT 3.4.4 with Apache httpd 2.0.54 and FastCGI 2.4.2.

If I type http://hostname/rt in my Browser I get the Login Form. After
logging in I’m redirected to http://hostname/index.html instead of
http://hostname/rt/index.html

If I type http://hostname/rt/ everything works, but our customer don’t
want to have the trailing ‘/’.

How can I do this?

httpd.conf:
AddHandler fastcgi-script fcgi
ScriptAlias /rt /apps/opt/rt/current/bin/mason_handler.fcgi
Alias /NoAuth/ /apps/opt/rt/current/share/html/NoAuth/
<Directory “/apps/opt/rt/current/share/html”>
DirectoryIndex index.html
Options FollowSymLinks ExecCGI
AllowOverride None

FastCgiIpcDir /tmp
FastCgiServer /apps/opt/rt/current/bin/mason_handler.fcgi

-idle-timeout

120 -processes 4

RT_SiteConfig.pm:
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://hostname:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Regards,

Tobias Warth


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

Thanks it works :-)From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Drew
Barnes
Sent: Dienstag, 20. September 2005 15:10
To: Warth, Tobias
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Want to have /rt instead of /rt/

Redirect /rt http://hostname/rt/index.html

results in
http://hostname/rt/index.html/index.html/index.html/index.html/index.ht
m l/index.html/index.html/index.html/index.html/index.html

Redirect /rt http://hostname/rt/

results in http://hostname/rt//////////////////////

RewriteEngine on
RewriteRule ^/rt$ /rt/ [R]

results in http://hostname/rt

Doesn’t work, in my configuration :frowning:

-----Original Message-----
From: Ricky Tang Siu Hong [mailto:shtang@clustertech.com]
Sent: Dienstag, 20. September 2005 11:12
To: Warth, Tobias; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Want to have /rt instead of /rt/

Usually Apache rewrite rule will help to add the trailing slash. Check

your config files.

----- Original Message -----
From: Tobias.Warth@hp.com
To: rt-users@lists.bestpractical.com
Sent: Tuesday, September 20, 2005 2:02 PM
Subject: [rt-users] Want to have /rt instead of /rt/

I configured RT 3.4.4 with Apache httpd 2.0.54 and FastCGI 2.4.2.

If I type http://hostname/rt in my Browser I get the Login Form. After

logging in I’m redirected to http://hostname/index.html instead of
http://hostname/rt/index.html

If I type http://hostname/rt/ everything works, but our customer don’t

want to have the trailing ‘/’.

How can I do this?

httpd.conf:
AddHandler fastcgi-script fcgi
ScriptAlias /rt /apps/opt/rt/current/bin/mason_handler.fcgi
Alias /NoAuth/ /apps/opt/rt/current/share/html/NoAuth/
<Directory “/apps/opt/rt/current/share/html”>
DirectoryIndex index.html
Options FollowSymLinks ExecCGI
AllowOverride None

FastCgiIpcDir /tmp
FastCgiServer /apps/opt/rt/current/bin/mason_handler.fcgi

-idle-timeout

120 -processes 4

RT_SiteConfig.pm:
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://hostname:80”); Set($WebURL , $WebBaseURL .
$WebPath . “/”);

Regards,

Tobias Warth


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

I configured RT 3.4.4 with Apache httpd 2.0.54 and FastCGI 2.4.2.

If I type http://hostname/rt in my Browser I get the Login Form. After
logging in I’m redirected to http://hostname/index.html instead of
http://hostname/rt/index.html

If I type http://hostname/rt/ everything works, but our customer don’t
want to have the trailing ‘/’.

How can I do this?

httpd.conf:
AddHandler fastcgi-script fcgi
ScriptAlias /rt /apps/opt/rt/current/bin/mason_handler.fcgi
Alias /NoAuth/ /apps/opt/rt/current/share/html/NoAuth/
<Directory “/apps/opt/rt/current/share/html”>
DirectoryIndex index.html
Options FollowSymLinks ExecCGI
AllowOverride None

Right thing would be to use:
<Directory “/apps/opt/rt/current/share/html”>

note: DirectorySlash disables DirectoryIndex directive

DirectorySlash On

RT should handle directory indexes itself

but if it doesn’t work(IMHO in this case RT bug) uncomment next string

RewriteRule ^(.*)/$ $1/index.html

Options FollowSymLinks ExecCGI
AllowOverride None

Tobias, could you test this? RT should work without mod_rewrite.

FastCgiIpcDir /tmp
FastCgiServer /apps/opt/rt/current/bin/mason_handler.fcgi -idle-timeout
120 -processes 4

RT_SiteConfig.pm:
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://hostname:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Regards,

Tobias Warth


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Best regards, Ruslan.