Viewing Ticket with relationships

Hello all,

	Im sending this email in the hope that someone can help


     We have recently set up an installation of rt3-0-4 on RH 9, and

have problems viewing tickets that have any relationships setup.

     The following occurs when trying to view the ticket


Can’t call method “URI” on an undefined value at
/opt/rt3/lib/RT/URI/ line 238.

return $self->loc(“ticket #[_1]”, $self->Object->Id);

else {
return $self->Object->URI;

eval “require RT::URI::fsck_com_rt_Vendor”;

code stack:

Does anyone know how to stop this from happening?

Kind Regards,
David Ford.

-----Original Message-----
From: David Ford []
Sent: Sunday, August 17, 2003 6:05 PM
Subject: [rt-users] Viewing Ticket with relationships

     We have recently set up an installation of rt3-0-4 

on RH 9, and have problems viewing tickets that have any
relationships setup.

I’m interested to hear how this works out for you… I tried RT-3-0-4 on
RH9, and found that, at the time, perl was so broke, I couldn’t get it
to work the way I wanted it to without rebuilding Perl & Apache. This
was even after I set the LANG setting to a non-unicode value (tried
en_US, C and a few others). Rebuilding perl & apache, on RH, for me,
became a really daunting task, which I gave up on (the number in
dependent packages, the non-standard installation settings and directory

I decided to use Debian because I figured they’re much less likely to
feel the pressure of market driven release dates (RedHat is about making
money, after all). RT now works like a charm, minus some bugs, which are
fixable or manageable.

Don’t get me wrong, I LOVE RedHat for a desktop, I’m just not crazy
about the apparently free hand they’ve played with their perl distros,
as they seem to have been some sort of broken out-of-the-box at each
release since 7.2.

I also don’t have enough experience to be able to use RPM to build,
which I understand to be a really powerful way to deal with some of the
things I’ve mentioned, so you might look into that.

I think this is the fix:
Good luck. Ruslan.

Thanks, but that doesn’t appear to fix the problem, we still get an
identical result after swapping the for the one in the
tar.gz provided at this page.

If it makes any difference we also get the error below when trying to
perform a search:

error: Assertion flags == 0 failed: file “Storable.xs”, line 2336 at
…/…/lib/ (autosplit into
…/…/lib/auto/Storable/ line 282.

[…/…/lib/ (autosplit into
[…/…/lib/ (autosplit into
[/usr/lib/perl5/site_perl/5.8.0/HTML/Mason/], at
/usr/lib/perl5/site_perl/5.8.0/Apache/Session/Serialize/ line

context: …
187: # whether they should generate a full stack trace (confess() and
188: # or simply report the caller’s package (croak() and carp()),
189: # confess() and croak() die, carp() and cluck() warn.
191: sub croak { die shortmess @_ }
192: sub confess { die longmess @_ }
193: sub carp { warn shortmess @_ }
194: sub cluck { warn longmess @_ }

code stack: /usr/lib/perl5/5.8.0/
…/…/lib/ (autosplit into
…/…/lib/ (autosplit into
…/…/lib/ (autosplit into

Im thinking were going to have to blow away the default perl install and
start again…

It’s known bug with perl 5.8.0 that only take effect on RH9.
There is fix for it that would be included in perl 5.8.1 and I think would release new version with workaround soon.
You also could google archives for this problem.
David Ford wrote:

Could you send cofiguration for this options? You could change real
names with abstract, but please save equality of parts.
Set($rtname , “”);
Set($Organization , “”);
And simple mysql request results.
select * from Links where LocalTarget = <problem_ticket_id> or LocalBase
= <problem_ticket_id>;
You also could change results.
Best regards. Ruslan.

David Ford wrote: