V4.4.4 - Adding it as a 'Requestor' would create a mail loop

Good afternoon,

I am using RT version 4.4.4

I am a relativity new user to RT (I used it about 10 years ago). Having set up a new instance for Asset tracking I am looking to extend it’s capability to replacing our ticketing system.

I have created myself as a user with privileges, though if I go to ‘Quick Create’ (on any of my new queues) it complains with the following message:

That's an address where RT receives mail. Adding it as a 'Requestor' would create a mail loop

The error seems logical, though I have not set RT is not set to receive email yet (knowingly).
If I change my email address it works fine. I have had a look through the settings and the database and have not specified my email address anywhere except under my user. I have not played with any regex that I am aware of.

Where should I look, can you point me in the right direction please as to where it may be specified?

Many Thanks

Id have a look in RT_SiteConfig.pm, see if youve set $CommentAddress, $CorrespondAddress or $OwnerEmail. What does the interface say the default address is for Comment or Correspond if you look at the queue setting?

Thanks for your reply.

They are set but as different email address.

Sorry, I’m not sure where to find the interface? My email address is not listed in RT_SiteConfig.pm and RT_Config.pm has never been edited.

RT is designed such that any mail which already has a ticket-id
associated with it will get to the right place automatically.

C<$CorrespondAddress> and C<$CommentAddress> are the default addresses
that will be listed in From: and Reply-To: headers of correspondence
and comment mail tracked by RT, unless overridden by a queue-specific
address.  They should be set to email addresses which have been
configured as aliases for F<rt-mailgate>.

=cut

Set($CorrespondAddress, '');

Set($CommentAddress, '');

My RT_SiteConfig.pm looks like this (domain name changed for some animosity)

Set($Organization, "rt.test.co.uk");
Set($Timezone, 'UTC');
Set($WebBaseURL, "https://rt.test.co.uk");
Set($WebURL, "https://rt.test.co.uk/");
Set($WebPort, 443);
Set($WebPath, "");
Set($WebDomain, "rt.test.co.uk");
Set($CorrespondAddress, 'support@rt.test.co.uk');
Set($CommentAddress, 'comment@rt.test.co.uk');
Set($SendmailPath, "/usr/lib/sendmail");
Set($LogToSyslog, '');
Set($LogToFile, 'debug');
Set($LogDir, '/var/log');
Set($LogToFileNamed, "rt.log");
Set($OwnerEmail, 'oss@test.co.uk');
Set($MyTicketsLength, 20);
Set($LogoURL, RT->Config->Get('WebImagesURL') . "test.png");
Set($LogoLinkURL, "https://www.test.co.uk");

My email address format is: user.name@test.co.uk

The browser interface. Login as an administrator and go to Admin->Queues->Select. Find the queue QuickCreate creates tickets in and see what it has set (if anything)

1 Like

I don’t have a Quick Create Queue, though I do see the problem where my email address is assigned to a disabled queue, all the others are blank. I have removed the email addresses and it appears to have fixed the problem.

This has been driving me mad for the last two weeks, so thank you very much and Happy New Year from Yorkshire.

Proper county, appen!

1 Like