/usr/lib/rt stuff

I installed RT on a new Debian system using apt, and the .deb put the
webrt.cgi and other files in the default Apache location; /usr/lib/cgi-bin

I moved these files to my actual Apache docroot, as well as the webrt
directory with the various gifs. RT seems to work fine now; I can create and
manage tickets, I receive email updates as an issue is processed, etc.

However, there are some files in /usr/lib/rt that I’m not sure if I need to
move. Can anyone tell me what the purpose of these files is and if I should
locate them somewhere that is accessible to the webrt.cgi and
admin-webrt.cgi scripts? Thanks in advance.

root@athena /usr/lib/rt) ls -lR
.:
total 8
drwxr-xr-x 2 root root 4096 Nov 12 10:11 bin
drwxr-xr-x 5 root root 4096 Nov 12 10:11 lib

./bin:
total 12
-rwxr-xr-x 1 root root 2088 Mar 11 2002 rtmux.pl
-rwsr-xr-x 3 www-data www-data 4920 Mar 11 2002 suid_wrapper

./lib:
total 12
drwxr-xr-x 2 root root 4096 Nov 12 10:11 generic_templates
drwxr-xr-x 2 root root 4096 Nov 12 10:11 images
drwxr-xr-x 5 root root 4096 Nov 12 10:11 rt

./lib/generic_templates:
total 32
-rw-r–r-- 1 root root 620 Dec 23 1999 autoreply
-rw-r–r-- 1 root root 230 Dec 23 1999 comment
-rw-r–r-- 1 root root 16 Dec 9 1997 correspondence
-rw-r–r-- 1 root root 10 Dec 9 1997 error
-rw-r–r-- 1 root root 94 Dec 23 1999 give
-rw-r–r-- 1 root root 17 Dec 9 1997 respond
-rw-r–r-- 1 root root 96 Dec 23 1999 steal
-rw-r–r-- 1 root root 362 Jan 27 1998 transaction
-rw-r–r-- 1 root root 0 Dec 9 1997 web_create

./lib/images:
total 60
-rw-r–r-- 1 root root 988 Apr 19 1998 comment.gif
-rw-r–r-- 1 root root 891 Apr 19 1998 down.gif
-rw-r–r-- 1 root root 977 Apr 1 1998 endcap.gif
-rw-r–r-- 1 root root 511 Dec 9 1997 give.gif
-rw-r–r-- 1 root root 35 Apr 8 1999 pixel_black.gif
-rw-r–r-- 1 root root 574 Dec 9 1997 resolve.gif
-rw-r–r-- 1 root root 974 Apr 19 1998 respond.gif
-rw-r–r-- 1 root root 7575 Apr 8 1999 rt.jpeg
-rw-r–r-- 1 root root 153 Apr 17 1998 sbc.gif
-rw-r–r-- 1 root root 149 Apr 17 1998 sbs.gif
-rw-r–r-- 1 root root 138 Apr 17 1998 slc.gif
-rw-r–r-- 1 root root 147 Apr 17 1998 srs.gif
-rw-r–r-- 1 root root 448 Dec 9 1997 take.gif
-rw-r–r-- 1 root root 889 Apr 19 1998 up.gif

./lib/rt:
total 32
drwxr-xr-x 2 root root 4096 Nov 12 10:11 database
-rw-r–r-- 1 root root 18184 Sep 30 1999 database.pm
drwxr-xr-x 2 root root 4096 Nov 12 10:11 support
drwxr-xr-x 5 root root 4096 Nov 12 10:11 ui

./lib/rt/database:
total 52
-rw-r–r-- 1 root root 15729 Jul 7 1999 admin.pm
-rw-r–r-- 1 root root 4726 Jul 8 1999 config.pm
-rw-r–r-- 1 root root 2528 Sep 30 1999 content.pm
-rw-r–r-- 1 root root 21774 Nov 6 2000 manipulate.pm

./lib/rt/support:
total 20
-rw-r–r-- 1 root root 4277 Nov 8 2000 mail.pm
-rw-r–r-- 1 root root 8860 Nov 14 2000 utils.pm

./lib/rt/ui:
total 12
drwxr-xr-x 2 root root 4096 Nov 12 10:11 cli
drwxr-xr-x 2 root root 4096 Nov 12 10:11 mail
drwxr-xr-x 2 root root 4096 Nov 12 10:11 web

./lib/rt/ui/cli:
total 44
-rw-r–r-- 1 root root 10669 Jun 1 2000 admin.pm
-rw-r–r-- 1 root root 11345 Oct 9 2000 manipulate.pm
-rw-r–r-- 1 root root 13282 Feb 28 2000 query.pm
-rw-r–r-- 1 root root 1395 Jan 2 1998 support.pm

./lib/rt/ui/mail:
total 20
-rw-r–r-- 1 root root 19120 Jan 18 2001 manipulate.pm

./lib/rt/ui/web:
total 88
-rw-r–r-- 1 root root 16858 Feb 28 2000 admin.pm
-rw-r–r-- 1 root root 7205 Jun 29 1999 auth.pm
-rw-r–r-- 1 root root 17912 Jun 1 2000 forms.pm
-rw-r–r-- 1 root root 29316 Jan 8 2001 manipulate.pm
-rw-r–r-- 1 root root 6912 Dec 1 2000 support.pm

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
Award

Owen B. Mehegan wrote:

I installed RT on a new Debian system using apt, and the .deb put the
webrt.cgi and other files in the default Apache location;
/usr/lib/cgi-bin

However, there are some files in /usr/lib/rt

Which version of the ‘RT’ package did you use (and what is its name).
There have at times been (I think) webrt, request-tracker, and
request-tracker2 packages.

The msot recent one is simply called request-tracker and is maintained
by Jesse Vincent himself. There is no script called webrt.cgi in that
package, and no /usr/lib/rt/ directory is used.

(/usr/share/request-tracker/ is where most of the stuff goes. A recent
version also used /usr/lib/request-tracker/, but that’s gone now.)

I’d strongly recommend using this latest version:

Package: request-tracker
Priority: optional
Section: main
Maintainer: Jesse Vincent jesse@bestpractical.com
Version: 2.0.15-pre1-1

Smylers
GBdirect

Owen B. Mehegan wrote:

./bin:
total 12
-rwxr-xr-x 1 root root 2088 Mar 11 2002 rtmux.pl
-rwsr-xr-x 3 www-data www-data 4920 Mar 11 2002 suid_wrapper

As Smylers might have suspected, you’ve managed to install RT 1.x.
Make it go away and install Jesse’s package. You’ll be much happier.
Phil Homewood, Systems Janitor, www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances

Phil Homewood schrieb:

Owen B. Mehegan wrote:

./bin:
total 12
-rwxr-xr-x 1 root root 2088 Mar 11 2002 rtmux.pl
-rwsr-xr-x 3 www-data www-data 4920 Mar 11 2002 suid_wrapper

As Smylers might have suspected, you’ve managed to install RT 1.x.
Make it go away and install Jesse’s package. You’ll be much happier.

Phil,
Only if you have a tiny number of tickets.
With more tickets (> 100000) the 1.x version has acceptable performance,
rt2 not.

Owen, why move?
there was a reason for this change.
under the apache docroot rt1 is completely insecure.
Reini Urban - Programmer - http://inode.at

Phil Homewood schrieb:

As Smylers might have suspected, you’ve managed to install RT 1.x.
Make it go away and install Jesse’s package. You’ll be much happier.

Phil,
Only if you have a tiny number of tickets.
With more tickets (> 100000) the 1.x version has acceptable performance,
rt2 not.

How so?

(as in, various changes have been made to make rt2 faster, and some have
made it into the official release, so I don’t think the old adage about
rt2 being much slower is still completely true)

                         Bruce Campbell                            RIPE
               Systems/Network Engineer                             NCC
             www.ripe.net - PGP562C8B1B             Operations/Security

I won’t have many tickets in my system I don’t think. I’m hoping to set it
up as a way for my 30-some users to send up requests for upgrades, installs,
and troubleshooting, because I’m incapable of managing my own time :slight_smile:

I tried installing the RT2 Debian package and had zero success. I also tried
installing from source and met with the same fate. I gave up in disgust last
week with plans to try again this week. Hopefully I’ll have time later
today.

If anyone knows of any pitfalls or can direct me to some “after you install
the package you’ll need to follow these steps to make it work” instructions,
that would be helpful.

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
AwardFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Reini Urban
Sent: Monday, November 18, 2002 12:02 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] /usr/lib/rt stuff

Phil Homewood schrieb:

Owen B. Mehegan wrote:

./bin:
total 12
-rwxr-xr-x 1 root root 2088 Mar 11 2002 rtmux.pl
-rwsr-xr-x 3 www-data www-data 4920 Mar 11 2002 suid_wrapper

As Smylers might have suspected, you’ve managed to install RT 1.x.
Make it go away and install Jesse’s package. You’ll be much happier.

Phil,
Only if you have a tiny number of tickets.
With more tickets (> 100000) the 1.x version has acceptable performance,
rt2 not.

Owen, why move?
there was a reason for this change.
under the apache docroot rt1 is completely insecure.
Reini Urban - Programmer - http://inode.at

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

OK, I’ve gone back to attempting to use the request-tracker (version 2)
Debian package, and I’m still having no luck. Having read the README.Debian
file, I decided to go with a Postgresql database instead of MySQL as I had
been before, since that’s what the instructions seem most specific about.
I’m still having no luck though.

Postgresql is installed, and I created a www-data user for it and an rt
database. I’m trying to use the initdb script, and it keeps failing. I’ve
tried all manner of options with it, but it always spits back this error:

Use of uninitialized value in concatenation (.) or string at ./tools/initdb
line 29.
Use of uninitialized value in string eq at ./tools/initdb line 42.
Use of uninitialized value in string eq at ./tools/initdb line 42.
Use of uninitialized value in string eq at ./tools/initdb line 42.
Use of uninitialized value in string eq at ./tools/initdb line 42.
Use of uninitialized value in concatenation (.) or string at ./tools/initdb
line 66.
$ACTION unspecified. Makefile error. It was

No idea why it cuts off the “It was” part. What am I doing wrong? This is
driving me crazy!

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
AwardFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Owen B. Mehegan
Sent: Monday, November 18, 2002 3:13 PM
To: rt-users@lists.fsck.com
Subject: RE: [rt-users] /usr/lib/rt stuff

I won’t have many tickets in my system I don’t think. I’m hoping to set it
up as a way for my 30-some users to send up requests for upgrades, installs,
and troubleshooting, because I’m incapable of managing my own time :slight_smile:

I tried installing the RT2 Debian package and had zero success. I also tried
installing from source and met with the same fate. I gave up in disgust last
week with plans to try again this week. Hopefully I’ll have time later
today.

If anyone knows of any pitfalls or can direct me to some “after you install
the package you’ll need to follow these steps to make it work” instructions,
that would be helpful.

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
Award

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Reini Urban
Sent: Monday, November 18, 2002 12:02 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] /usr/lib/rt stuff

Phil Homewood schrieb:

Owen B. Mehegan wrote:

./bin:
total 12
-rwxr-xr-x 1 root root 2088 Mar 11 2002 rtmux.pl
-rwsr-xr-x 3 www-data www-data 4920 Mar 11 2002 suid_wrapper

As Smylers might have suspected, you’ve managed to install RT 1.x.
Make it go away and install Jesse’s package. You’ll be much happier.

Phil,
Only if you have a tiny number of tickets.
With more tickets (> 100000) the 1.x version has acceptable performance,
rt2 not.

Owen, why move?
there was a reason for this change.
under the apache docroot rt1 is completely insecure.
Reini Urban - Programmer - http://inode.at

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I made some more progress on this; I got initdb create and insert to work
(the syntax is a little weird…), but now I can’t get insertdata to work.
It keeps giving me this error:

DBI->connect(dbname=rt;host=localhost) failed: FATAL 1: IDENT
authentication failed for user “www-data” at
/usr/share/perl5/DBIx/SearchBuilder/Handle.pm line 117
Connect Failed FATAL 1: IDENT authentication failed for user "www-data"
at tools/insertdata line 27

I don’t get prompted for a password for www-data, and I can’t figure out
what it’s set to by default; null doesn’t work…

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
AwardFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Owen B. Mehegan
Sent: Monday, November 18, 2002 4:31 PM
To: rt-users@lists.fsck.com
Subject: RE: [rt-users] /usr/lib/rt stuff

OK, I’ve gone back to attempting to use the request-tracker (version 2)
Debian package, and I’m still having no luck. Having read the README.Debian
file, I decided to go with a Postgresql database instead of MySQL as I had
been before, since that’s what the instructions seem most specific about.
I’m still having no luck though.

Postgresql is installed, and I created a www-data user for it and an rt
database. I’m trying to use the initdb script, and it keeps failing. I’ve
tried all manner of options with it, but it always spits back this error:

Use of uninitialized value in concatenation (.) or string at ./tools/initdb
line 29.
Use of uninitialized value in string eq at ./tools/initdb line 42.
Use of uninitialized value in string eq at ./tools/initdb line 42.
Use of uninitialized value in string eq at ./tools/initdb line 42.
Use of uninitialized value in string eq at ./tools/initdb line 42.
Use of uninitialized value in concatenation (.) or string at ./tools/initdb
line 66.
$ACTION unspecified. Makefile error. It was

No idea why it cuts off the “It was” part. What am I doing wrong? This is
driving me crazy!

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
Award

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Owen B. Mehegan
Sent: Monday, November 18, 2002 3:13 PM
To: rt-users@lists.fsck.com
Subject: RE: [rt-users] /usr/lib/rt stuff

I won’t have many tickets in my system I don’t think. I’m hoping to set it
up as a way for my 30-some users to send up requests for upgrades, installs,
and troubleshooting, because I’m incapable of managing my own time :slight_smile:

I tried installing the RT2 Debian package and had zero success. I also tried
installing from source and met with the same fate. I gave up in disgust last
week with plans to try again this week. Hopefully I’ll have time later
today.

If anyone knows of any pitfalls or can direct me to some “after you install
the package you’ll need to follow these steps to make it work” instructions,
that would be helpful.

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
Award

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Reini Urban
Sent: Monday, November 18, 2002 12:02 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] /usr/lib/rt stuff

Phil Homewood schrieb:

Owen B. Mehegan wrote:

./bin:
total 12
-rwxr-xr-x 1 root root 2088 Mar 11 2002 rtmux.pl
-rwsr-xr-x 3 www-data www-data 4920 Mar 11 2002 suid_wrapper

As Smylers might have suspected, you’ve managed to install RT 1.x.
Make it go away and install Jesse’s package. You’ll be much happier.

Phil,
Only if you have a tiny number of tickets.
With more tickets (> 100000) the 1.x version has acceptable performance,
rt2 not.

Owen, why move?
there was a reason for this change.
under the apache docroot rt1 is completely insecure.
Reini Urban - Programmer - http://inode.at

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Owen B. Mehegan wrote:

If anyone knows of any pitfalls or can direct me to some “after you install
the package you’ll need to follow these steps to make it work” instructions,
that would be helpful.

http://fsck.com/rtfm/
Phil Homewood, Systems Janitor, www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances

Those were the instructions I tried to follow previously, specifically the
ones that refer to installing on Debian, but I seemed to get nowhere on that
front. I think I’m pretty close to getting RT working by using the Debian
package, if I can just resolve this error with “insertdata:”

DBI->connect(dbname=rt;host=localhost) failed: FATAL 1: IDENT
authentication failed for user “www-data” at
/usr/share/perl5/DBIx/SearchBuilder/Handle.pm line 117
Connect Failed FATAL 1: IDENT authentication failed for user "www-data"
at tools/insertdata line 27

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
AwardFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Phil Homewood
Sent: Monday, November 18, 2002 7:44 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] /usr/lib/rt stuff

Owen B. Mehegan wrote:

If anyone knows of any pitfalls or can direct me to some "after you
install
the package you’ll need to follow these steps to make it work"
instructions,
that would be helpful.

http://fsck.com/rtfm/
Phil Homewood, Systems Janitor, www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Those were the instructions I tried to follow previously, specifically the
ones that refer to installing on Debian, but I seemed to get nowhere on that
front. I think I’m pretty close to getting RT working by using the Debian
package, if I can just resolve this error with “insertdata:”

Debian’s postgres is configured to use “ident” authentication by
default, instead of password authentication. It won’t work without
manual reconfiguration.

»|« http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Hi, Owen.

DBI->connect(dbname=rt;host=localhost) failed: FATAL 1: IDENT
authentication failed for user “www-data” at
/usr/share/perl5/DBIx/SearchBuilder/Handle.pm line 117
Connect Failed FATAL 1: IDENT authentication failed for user "www-data"
at tools/insertdata line 27

Oh, crazy identd. Turn that off, first of all, and make sure you can
connect to the database, using the username and password you set up
using the Makefile. Also pay attention to the hostname; connecting to
localhost is not (necessarily) the same as connecting to the same
machine using another DNS name.

(darren)

Reisner’s Rule of Conceptual Inertia:
If you think big enough, you’ll never have to do it.

Ugh. Now I just get this error:

DBI->connect(dbname=rt;host=localhost) failed: FATAL 1: Password
authentication failed for user “www-data” at
/usr/share/perl5/DBIx/SearchBuilder/Handle.pm line 117
Connect Failed FATAL 1: Password authentication failed for user "www-data"
at tools/insertdata line 27

Kill me.

Best regards,

Owen B. Mehegan
MIS Manager, Perseus Development Corp.
Landline: (781) 848-8100 x263
Mobile: (617) 285-1701
SurveySolutions for the Web: Winner of the PC Magazine Editors’ Choice
AwardFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of darren chamberlain
Sent: Tuesday, November 19, 2002 12:34 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] /usr/lib/rt stuff

Hi, Owen.

DBI->connect(dbname=rt;host=localhost) failed: FATAL 1: IDENT
authentication failed for user “www-data” at
/usr/share/perl5/DBIx/SearchBuilder/Handle.pm line 117
Connect Failed FATAL 1: IDENT authentication failed for user "www-data"
at tools/insertdata line 27

Oh, crazy identd. Turn that off, first of all, and make sure you can
connect to the database, using the username and password you set up
using the Makefile. Also pay attention to the hostname; connecting to
localhost is not (necessarily) the same as connecting to the same
machine using another DNS name.

(darren)

Reisner’s Rule of Conceptual Inertia:
If you think big enough, you’ll never have to do it.
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Ugh. Now I just get this error:

DBI->connect(dbname=rt;host=localhost) failed: FATAL 1: Password
authentication failed for user “www-data” at
/usr/share/perl5/DBIx/SearchBuilder/Handle.pm line 117
Connect Failed FATAL 1: Password authentication failed for user "www-data"
at tools/insertdata line 27

Just to make life extremely interesting, the password it’s looking for
is not the one associated with the www-data unix user, but the www-data
postgresql user.

If you can get into psql as the admin user (typically “postgres”) do
this:

select * from pg_user;

and see if you have actually created a www-data user. If so, try setting
the password back to something you know (see the postgres manual for how
to do this.)

If you can’t get in, put this in your pg_hba.conf:

local all trust

run ‘psql -U postgres template1’, fix your passwords in the db, and then
take the above major security hole back out of your pg_hba.conf.

Kill me.

DB user management is invariably complicated and poorly documented. Or
maybe I’m just too dumb to deal with it.

Steve

“Outlook not so good.” That magic 8-ball knows everything! I’ll ask
about Exchange Server next.
– (Stolen from the net)