Using RT 4.2.12 with example.com/rt (vs.) example.com

hey,

regarding ‘static’ files in RT we had problem with a reverse proxy setup:

example.com/rt/static/css/mobile.css for instance wasn’t found. this
holds true for all other files in /rt/static/* and files from the
rt-extension’s static folder weren’t found either.

we assume a glitch in RT’s router.

=== config ===
https://gist.github.com/qknight/3191bc7f0274f5e70c32

=== daemon start ===
rm -Rf /tmp/rt4/opt/rt4/var/mason_data/obj/*;
/tmp/rt4/opt/rt4/sbin/standalone_httpd

note:

  • please don’t advice this is incorrect deployment method, we know that.
  • we fixed this by adding an “Alias”:
    Alias “/rt/static/” “/www/static/”
    <Directory “/rt/static/”>
    Options Indexes
    AllowOverride None
    Order allow,deny
    Allow from all

our goal is to find out why ‘static’ wasn’t served by PSGI. we have seen:

Set( @StaticRoots,

{

path => qr{^/static/},

root => ‘/tmp/rt4/opt/rt4/share’,

},

);

and we used it, but seemd to not have any effect.

note: if we:

  • removed Set( $WebPath, “/rt” );
  • added Set( $WebsocketPort , “5000”);

we were able to get the static files from:
http://localhost:8080 without any problems

so this really seems to be a router problem of some kind?

please advice.

thanks in advance,
joachim & paul

We have some documentation on running from /rt (or some other path). Did
you follow that configuration and it still didn’t work as expected?

https://docs.bestpractical.com/rt/4.2.12/web_deployment.html#Running-RT-at-rt-rather-thanOn 3/8/16 11:05 AM, Joachim Schiele wrote:

hey,

regarding ‘static’ files in RT we had problem with a reverse proxy setup:

example.com/rt/static/css/mobile.css for instance wasn’t found. this
holds true for all other files in /rt/static/* and files from the
rt-extension’s static folder weren’t found either.

we assume a glitch in RT’s router.

=== config ===
https://gist.github.com/qknight/3191bc7f0274f5e70c32

=== daemon start ===
rm -Rf /tmp/rt4/opt/rt4/var/mason_data/obj/*;
/tmp/rt4/opt/rt4/sbin/standalone_httpd

note:

  • please don’t advice this is incorrect deployment method, we know that.
  • we fixed this by adding an “Alias”:
    Alias “/rt/static/” “/www/static/”
    <Directory “/rt/static/”>
    Options Indexes
    AllowOverride None
    Order allow,deny
    Allow from all

our goal is to find out why ‘static’ wasn’t served by PSGI. we have seen:

Set( @StaticRoots,

{

path => qr{^/static/},

root => ‘/tmp/rt4/opt/rt4/share’,

},

);

and we used it, but seemd to not have any effect.

note: if we:

  • removed Set( $WebPath, “/rt” );
  • added Set( $WebsocketPort , “5000”);

we were able to get the static files from:
http://localhost:8080 without any problems

so this really seems to be a router problem of some kind?

please advice.

thanks in advance,
joachim & paul


RT 4.4 and RTIR Training Sessions (http://bestpractical.com/services/training.html)

  • Hamburg Germany - March 14 & 15, 2016
  • Washington DC - May 23 & 24, 2016

i’m not using fcgi/psgi or apache. maybe RT just honors the /rt subdir
if started from there. i might try that later.

/tmp/rt4/opt/rt4/sbin/standalone_httpd seems to honor it except for the
static files.On 11.03.2016 14:54, Jim Brandt wrote:

We have some documentation on running from /rt (or some other path). Did
you follow that configuration and it still didn’t work as expected?

https://docs.bestpractical.com/rt/4.2.12/web_deployment.html#Running-RT-at-rt-rather-than

On 3/8/16 11:05 AM, Joachim Schiele wrote:

hey,

regarding ‘static’ files in RT we had problem with a reverse proxy setup:

example.com/rt/static/css/mobile.css for instance wasn’t found. this
holds true for all other files in /rt/static/* and files from the
rt-extension’s static folder weren’t found either.

we assume a glitch in RT’s router.

=== config ===
https://gist.github.com/qknight/3191bc7f0274f5e70c32

=== daemon start ===
rm -Rf /tmp/rt4/opt/rt4/var/mason_data/obj/*;
/tmp/rt4/opt/rt4/sbin/standalone_httpd

note:

  • please don’t advice this is incorrect deployment method, we know that.
  • we fixed this by adding an “Alias”:
    Alias “/rt/static/” “/www/static/”
    <Directory “/rt/static/”>
    Options Indexes
    AllowOverride None
    Order allow,deny
    Allow from all

our goal is to find out why ‘static’ wasn’t served by PSGI. we have seen:

Set( @StaticRoots,

{

path => qr{^/static/},

root => ‘/tmp/rt4/opt/rt4/share’,

},

);

and we used it, but seemd to not have any effect.

note: if we:

  • removed Set( $WebPath, “/rt” );
  • added Set( $WebsocketPort , “5000”);

we were able to get the static files from:
http://localhost:8080 without any problems

so this really seems to be a router problem of some kind?

please advice.

thanks in advance,
joachim & paul


RT 4.4 and RTIR Training Sessions
(http://bestpractical.com/services/training.html)

  • Hamburg Germany - March 14 & 15, 2016
  • Washington DC - May 23 & 24, 2016

RT 4.4 and RTIR Training Sessions
(http://bestpractical.com/services/training.html)

  • Hamburg Germany - March 14 & 15, 2016
  • Washington DC - May 23 & 24, 2016