Uploading big Files using CGI.pm

Greetings,

This may be more of a mod_perl or Mason question, but I’m not sure at this
point.

I am using cgi.pm to upload attachments when creating a ticket in RT.
Everything is fine unlesss I try to upload a file large than 1 MB. This
generates an immediate server error and
on checking the Apache logs says ‘Malformed Multipart Post’.

I’ve read messages about Mason and CGI.pm problems, and tried in Webmux.pl
to fix it by adding this line after the ‘use CGI’ line:

$CGI::POST_MAX=1024 * 100000;

I thought that this would likely do the trick, but no go.

Is it possible that RT is limiting the size, or adding some other config
variable somewhere that I’m missing?

I’d appreciate any hints that anyone might have on this.

Thanks and cheers,

Brian Houston
Austar
http://www.austar.com.au

This email and any files transmitted with it, are confidential and is intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error, please notify the system manager.

This footnote also confirms that this email message has been scanned by AUSTAR Communications content and virus scanning applications
for the presence of computer viruses.

I’ve read messages about Mason and CGI.pm problems, and tried in Webmux.pl
to fix it by adding this line after the ‘use CGI’ line:

$CGI::POST_MAX=1024 * 100000;

I thought that this would likely do the trick, but no go.

Maybe this is a silly question, but did you restart httpd? Changes like
that only take effect with a restart.

(darren)

A large number of installed systems work by fiat. That is, they work
by being declared to work.
– Anatol Holt

Thanks Darren,

I did restart Apache, but that is a good guess.

I did finally solve the problem after three days of pulling my hair out.
Maybe my solution will save someone else from doing the same.

Our companny has an Internet Explorer only policy for Intranet
applications, of which RT is one. I kept getting a ‘Malformed Multipart
Attachment’ error in the Apache logs whenever I tried to upload a
file larger than 1 megabyte. I tried a million different things, and
finally in desparation got out the old copy of Netscape and tried it. It
failed as well, but instead of giving me the standard ‘500 Internal Server
Error’ I got an error from our Squid Web Proxy server. It turns out we
have a 1 megabyte limit on transfers in Squid.

I have no idea why Internet Explorer was not returning the error from
Squid, that would have saved me a lot of grief if it had.

Cheers,

Brian Houston

|---------±---------------------------->
| | darren chamberlain|
| | <darren@boston.com|
| | > |
| | Sent by: |
| | rt-users-admin@lis|
| | ts.fsck.com |
| | |
| | |
| | 28/02/2003 00:05 |
| | |
|---------±---------------------------->

------------------------------------------------------------------------------------------------------------------------------|
| |
| To: rt-users@lists.fsck.com |
| cc: |
| Subject: Re: [rt-users] Uploading big Files using CGI.pm |
------------------------------------------------------------------------------------------------------------------------------|

I’ve read messages about Mason and CGI.pm problems, and tried in
Webmux.pl
to fix it by adding this line after the ‘use CGI’ line:

$CGI::POST_MAX=1024 * 100000;

I thought that this would likely do the trick, but no go.

Maybe this is a silly question, but did you restart httpd? Changes like
that only take effect with a restart.

(darren)

A large number of installed systems work by fiat. That is, they work
by being declared to work.
– Anatol Holt
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

This message has been scanned for viruses by AUSTAR Communication’s
antivirus and content checking applications.

Austar Communications

This email and any files transmitted with it, are confidential and is intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error, please notify the system manager.

This footnote also confirms that this email message has been scanned by AUSTAR Communications content and virus scanning applications
for the presence of computer viruses.

I do :wink: Tools -> Options, cancel the stupid thing called “Display friendly
HTTP Error messages”.

Of course, from time to time, it will display them too, regardless of your
choice, but hey, it is a M$ product…On Fri, 28 Feb 2003, Brian Houston/NCO/CEtv wrote:

Thanks Darren,

I did restart Apache, but that is a good guess.

I did finally solve the problem after three days of pulling my hair out.
Maybe my solution will save someone else from doing the same.

Our companny has an Internet Explorer only policy for Intranet
applications, of which RT is one. I kept getting a ‘Malformed Multipart
Attachment’ error in the Apache logs whenever I tried to upload a
file larger than 1 megabyte. I tried a million different things, and
finally in desparation got out the old copy of Netscape and tried it. It
failed as well, but instead of giving me the standard ‘500 Internal Server
Error’ I got an error from our Squid Web Proxy server. It turns out we
have a 1 megabyte limit on transfers in Squid.

I have no idea why Internet Explorer was not returning the error from
Squid, that would have saved me a lot of grief if it had.

Cheers,

Brian Houston

|---------±---------------------------->
| | darren chamberlain|
| | <darren@boston.com|
| | > |
| | Sent by: |
| | rt-users-admin@lis|
| | ts.fsck.com |
| | |
| | |
| | 28/02/2003 00:05 |
| | |
|---------±---------------------------->

------------------------------------------------------------------------------------------------------------------------------|
| |
| To: rt-users@lists.fsck.com |
| cc: |
| Subject: Re: [rt-users] Uploading big Files using CGI.pm |
------------------------------------------------------------------------------------------------------------------------------|

I’ve read messages about Mason and CGI.pm problems, and tried in
Webmux.pl
to fix it by adding this line after the ‘use CGI’ line:

$CGI::POST_MAX=1024 * 100000;

I thought that this would likely do the trick, but no go.

Maybe this is a silly question, but did you restart httpd? Changes like
that only take effect with a restart.

(darren)


A large number of installed systems work by fiat. That is, they work
by being declared to work.
– Anatol Holt


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

=========================================================
This message has been scanned for viruses by AUSTAR Communication’s
antivirus and content checking applications.

Austar Communications


This email and any files transmitted with it, are confidential and is intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error, please notify the system manager.

This footnote also confirms that this email message has been scanned by AUSTAR Communications content and virus scanning applications
for the presence of computer viruses.



rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Best regards,
Shimi

“Outlook is a massive flaming horrid blatant security violation, which
also happens to be a mail reader.”

“Sure UNIX is user friendly; it’s just picky about who its friends are.”