Upgrading from RT 4.4.3 to RT 4.4.4 broke msmtp


#1

Hi all,

I had RT 4.4.3 working fine in a test environment, also I used the guide lines used here rt-wiki/bestpractical/com/wiki/Msmtp for the configuration.

However when I upgraded RT to 4.4.4 it msmtp is no longer working, and when I activate the debug option in RT I get this information:

From: “Xxxxx Xxxx via RT” <@> (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:708)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: Got user mail preference ‘Individual messages’ for user helpdesk@xxxxxxxxx.xx (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:722)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: Removing deferred recipients from Bcc: line (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:731)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: Setting deferred recipients for attribute creation (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:740)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: No recipients found for deferred delivery on transaction #724 (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:753)
[24457] [Wed Apr 3 16:50:54 2019] [info]: <rt-4.4.4-24457-1554310254-1856.9-4-0(at)xxxxx.xxxxxx.xx> #9/724 - Scrip 4 On Correspond Notify Other Recipients (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:285)
[24457] [Wed Apr 3 16:50:54 2019] [critical]: <rt-4.4.4-24457-1554310254-1856.9-4-0(at)xxxxx.xxxxxx.xx>: Could not send mail with command /opt/rt4/etc/msmtp_wrapper -oi -t: program unexpectedly closed pipe at /opt/rt4/sbin/…/lib/RT/Interface/Email.pm line 930, line 1.

Stack:
[/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:930]
[/usr/local/share/perl5/MIME/Decoder/NBit.pm:153]
[/usr/local/share/perl5/MIME/Decoder.pm:259]
[/usr/local/share/perl5/MIME/Entity.pm:1903]
[/usr/local/share/perl5/MIME/Entity.pm:1873]
[/usr/local/share/perl5/MIME/Entity.pm:1785]
[/usr/local/share/perl5/MIME/Entity.pm:1846]
[/usr/local/share/perl5/MIME/Entity.pm:1785]
[/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:937]
[/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:292]
[/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:115]
[/opt/rt4/sbin/…/lib/RT/ScripAction.pm:201]
[/opt/rt4/sbin/…/lib/RT/Scrip.pm:664]
[/opt/rt4/sbin/…/lib/RT/Scrips.pm:296]
[/opt/rt4/sbin/…/lib/RT/Transaction.pm:213]
[/opt/rt4/sbin/…/lib/RT/Record.pm:1666]
[/opt/rt4/sbin/…/lib/RT/Ticket.pm:1717]
[/opt/rt4/sbin/…/lib/RT/Ticket.pm:1603]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:2420]
[/opt/rt4/share/html/Ticket/Display.html:183]
[/opt/rt4/share/html/Ticket/Display.html:196]
[/opt/rt4/share/html/Ticket/Update.html:360]
[/opt/rt4/share/html/Ticket/autohandler:66]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:697]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:376]
[/opt/rt4/share/html/autohandler:53] (/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:951)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: Skipping scrips for transaction #726 (/opt/rt4/sbin/…/lib/RT/Transaction.pm:181)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: Committing scrip #5 on txn #724 of ticket #9 (/opt/rt4/sbin/…/lib/RT/Scrips.pm:290)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: Calling SetRecipientDigests for transaction RT::Transaction=HASH(0x93b54f0), id 724 (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:685)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: Working on mailfield To; recipients are (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:701)
[24457] [Wed Apr 3 16:50:54 2019] [debug]: X-RT-Originator: xxxxxx.xxxxxx@xxxxxxxxx.xx
Subject: =?UTF-8?B?W3NhbnRvc2V2YWxlLnB0ICM5XSBGVzogRmFsaGEgbmEgYXRpdmHDp8OjbyAt?= =?UTF-8?B?IFBURU1QUkVTQVM=?=
In-Reply-To: <056e01d4e00a$f2be4e80$d83aeb80$(at)xxxxxxx.xx>
X-Managed-BY: RT 4.4.4 ()

Any help would be much appreciated!

Thanks in advanced!