Upgrading from 3.4.3 to 3.4.4 - mod_perl2 on FC4 issues

All,

I’m attempting to upgrade RT from 3.4.3 to 3.4.4 and am having problems
with the mod_perl2 requirements. I’m running RT on a Fedora Core 4 box
that’s running Apache/2.0.53 (httpd-2.0.53-3.3) but with mod_perl1
(mod_perl-1.99_16-3).

I have looked around for rpms to upgrade to mod_perl2, but I can’t find
any. What have other FC4 users done?? Any advice?!

-Stevo

I’m attempting to upgrade RT from 3.4.3 to 3.4.4 and am having problems
with the mod_perl2 requirements. I’m running RT on a Fedora Core 4 box
that’s running Apache/2.0.53 (httpd-2.0.53-3.3) but with mod_perl1
(mod_perl-1.99_16-3).

The problem with mod_perl2 is that its API semantics changed along the
way. I thought 3.4.2 was the first one that required the new
semantics, and I thought that _16 was new enough. mod_perl 1.99 is
mod_perl 2, except that it still has the old mp1 lookalike API.

IE: I wouldn’t have expected you’d have problems (at least that
problem), given that combination. Though I might be misremembering
where the fences are. You might check the ML archive for mod_perl, and
I think the wiki page on this has been re-re-updated to properly
reflect current reality.

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

"NPR has a lot in common with Nascar... we both turn to the left."
	- Peter Sagal, on Wait Wait, Don't Tell Me!

Jay R. Ashworth wrote:

The problem with mod_perl2 is that its API semantics changed along the
way. I thought 3.4.2 was the first one that required the new
semantics, and I thought that _16 was new enough. mod_perl 1.99 is
mod_perl 2, except that it still has the old mp1 lookalike API.

IE: I wouldn’t have expected you’d have problems (at least that
problem), given that combination. Though I might be misremembering
where the fences are. You might check the ML archive for mod_perl, and
I think the wiki page on this has been re-re-updated to properly
reflect current reality.

Here is the error I get after attempting the upgrade:

[Thu Oct 06 12:48:07 2005] [error] RT does not support mod_perl 1.99.
Please upgrade to mod_perl 2.0 at /usr/local/rt3/bin/webmux.pl line
59.\nBEGIN failed–compilation aborted at /usr/local/rt3/bin/webmux.pl
line 63.\nCompilation failed in require at (eval 2) line 1.\n

[Thu Oct 06 12:48:07 2005] [error] Can’t load Perl file:
/usr/local/rt3/bin/webmux.pl for server itsupport.omneon.local:0, exiting…

I had a look around on the wiki site but couldn’t find anything right
away! I’ll keep digging.

Stevo

mod_perl-1.99 is not mod_perl, it is mod_perl2. The 1.99 series was the
beta for 2.0xxxx. You need to upgrade mod_perl or switch to mod_fastcgi.

Stevo wrote:

Jay R. Ashworth wrote:

The problem with mod_perl2 is that its API semantics changed along the
way. I thought 3.4.2 was the first one that required the new
semantics, and I thought that _16 was new enough. mod_perl 1.99 is
mod_perl 2, except that it still has the old mp1 lookalike API.

IE: I wouldn’t have expected you’d have problems (at least that
problem), given that combination. Though I might be misremembering
where the fences are. You might check the ML archive for mod_perl, and
I think the wiki page on this has been re-re-updated to properly
reflect current reality.

Here is the error I get after attempting the upgrade:

[Thu Oct 06 12:48:07 2005] [error] RT does not support mod_perl 1.99.
Please upgrade to mod_perl 2.0 at /usr/local/rt3/bin/webmux.pl line
59.\nBEGIN failed–compilation aborted at /usr/local/rt3/bin/webmux.pl
line 63.\nCompilation failed in require at (eval 2) line 1.\n

[Thu Oct 06 12:48:07 2005] [error] Can’t load Perl file:
/usr/local/rt3/bin/webmux.pl for server itsupport.omneon.local:0,
exiting…

I had a look around on the wiki site but couldn’t find anything right
away! I’ll keep digging.

Stevo


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!
Download a free sample chapter from http://rtbook.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

Jay R. Ashworth wrote:

The problem with mod_perl2 is that its API semantics changed along the
way. I thought 3.4.2 was the first one that required the new
semantics, and I thought that _16 was new enough. mod_perl 1.99 is
mod_perl 2, except that it still has the old mp1 lookalike API.

IE: I wouldn’t have expected you’d have problems (at least that
problem), given that combination. Though I might be misremembering
where the fences are. You might check the ML archive for mod_perl, and
I think the wiki page on this has been re-re-updated to properly
reflect current reality.

Here is the error I get after attempting the upgrade:

[Thu Oct 06 12:48:07 2005] [error] RT does not support mod_perl 1.99.
Please upgrade to mod_perl 2.0 at /usr/local/rt3/bin/webmux.pl line
59.\nBEGIN failed–compilation aborted at /usr/local/rt3/bin/webmux.pl
line 63.\nCompilation failed in require at (eval 2) line 1.\n

[Thu Oct 06 12:48:07 2005] [error] Can’t load Perl file:
/usr/local/rt3/bin/webmux.pl for server itsupport.omneon.local:0, exiting…

I had a look around on the wiki site but couldn’t find anything right
away! I’ll keep digging.

Just curious, what are you looking for? You need to upgrade your
mod_perl and probably Html::Mason. Version 1.99 is not supported
as stated in the error message.

Stevo


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com
Scott T. Hildreth shildret@scotth.emsphone.com

Scott T. Hildreth wrote:

Just curious, what are you looking for? You need to upgrade your
mod_perl and probably Html::Mason. Version 1.99 is not supported
as stated in the error message.

I’m after some advice on upgrading to mod_perl2. I can’t seem to find
an rpm for FC4 - so I was wondering what the best plan of action is to
get upgraded from mod_perl 1.99 to 2.0.

Have you set up CPAN ? If so I would use ‘make testdeps’ to see what
needs to be upgraded/installed and then ‘make fixdeps’ to
upgrade/install.On Thu, 2005-10-06 at 13:50 -0700, Stevo wrote:

Scott T. Hildreth wrote:

Just curious, what are you looking for? You need to upgrade your
mod_perl and probably Html::Mason. Version 1.99 is not supported
as stated in the error message.

I’m after some advice on upgrading to mod_perl2. I can’t seem to find
an rpm for FC4 - so I was wondering what the best plan of action is to
get upgraded from mod_perl 1.99 to 2.0.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com
Scott T. Hildreth shildret@scotth.emsphone.com

mod_perl2 is going to ask for the location of the apxs program, I
believe it searches /usr/local/apache2/bin by default, so make sure
that the rpm installed it.On Thu, 2005-10-06 at 16:06 -0500, Scott T. Hildreth wrote:

Have you set up CPAN ? If so I would use ‘make testdeps’ to see what
needs to be upgraded/installed and then ‘make fixdeps’ to
upgrade/install.

On Thu, 2005-10-06 at 13:50 -0700, Stevo wrote:

Scott T. Hildreth wrote:

Just curious, what are you looking for? You need to upgrade your
mod_perl and probably Html::Mason. Version 1.99 is not supported
as stated in the error message.

I’m after some advice on upgrading to mod_perl2. I can’t seem to find
an rpm for FC4 - so I was wondering what the best plan of action is to
get upgraded from mod_perl 1.99 to 2.0.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com
Scott T. Hildreth shildret@scotth.emsphone.com

Scott T. Hildreth wrote:

Just curious, what are you looking for? You need to upgrade your
mod_perl and probably Html::Mason. Version 1.99 is not supported
as stated in the error message.

I’m after some advice on upgrading to mod_perl2. I can’t seem to find
an rpm for FC4 - so I was wondering what the best plan of action is to
get upgraded from mod_perl 1.99 to 2.0.

Just curious: do you have some particular reason for wanting mod_perl
instead of fastcgi which eliminates some of the version dependencies?

Les Mikesell
les@futuresource.com

Guys,

My Apache is hosed and I need some help!! I was running mod_perl1.99
and I upgraded to mod_perl2 and now when I try to start apache I get the
following error:

[Thu Oct 06 17:59:13 2005] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /usr/local/rt3/local/lib /usr/local/rt3/lib
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/5.8.6 . /etc/httpd) at (eval 195) line 3.\n
[Thu Oct 06 17:59:13 2005] [error] Can’t load Perl module Apache2 for
server itsupport.omneon.local:0, exiting…

Where do I find Apache2.pm??

-Stevo

Steve,

It’s part of the mod_perl rpm:
basic [root@constantinople ~]$ rpm -qf
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi/Bundle/Apache2.pm
mod_perl-2.0.1-1.fc4

You said earlier you couldn’t find an RPM for it. There is one in the
FC4 updates:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/mod_perl-2.0.1-1.fc4.i386.rpm

Check http://fedora.redhat.com for other versions if you aren’t using i386.

Is this the method you used to upgrade?

–Andy

Stevo wrote:

Stevo wrote:

All,

I’m attempting to upgrade RT from 3.4.3 to 3.4.4 and am having problems
with the mod_perl2 requirements. I’m running RT on a Fedora Core 4 box
that’s running Apache/2.0.53 (httpd-2.0.53-3.3) but with mod_perl1
(mod_perl-1.99_16-3).

I have looked around for rpms to upgrade to mod_perl2, but I can’t find
any. What have other FC4 users done?? Any advice?!

-Stevo

I’ve just written an FC4 install guide and it’s on the wiki, if that’s
any help.

You can yum upgrade mod_perl, or at least I was able to. Manually
compiling it is a bit of a nightmare IIRC.

HTML::Mason is CPANable.

Stewart

There isn’t an Apache2.pm module anymore, I believe this is coming from
Mason. Did you upgrade HTML::Mason?On Thu, 2005-10-06 at 18:49 -0700, Stevo wrote:

Guys,

My Apache is hosed and I need some help!! I was running mod_perl1.99
and I upgraded to mod_perl2 and now when I try to start apache I get the
following error:

[Thu Oct 06 17:59:13 2005] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /usr/local/rt3/local/lib /usr/local/rt3/lib
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/5.8.6 . /etc/httpd) at (eval 195) line 3.\n
[Thu Oct 06 17:59:13 2005] [error] Can’t load Perl module Apache2 for
server itsupport.omneon.local:0, exiting…

Where do I find Apache2.pm??

-Stevo


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com
Scott T. Hildreth shildret@scotth.emsphone.com

There’s one on my system. It came in RH’s mod_perl 2 RPM. I’m using it
in our RT system on Fedora Core 4.

–Andy

Scott T. Hildreth wrote:

I’m using 2.0.1 and it has it:
basic [root@constantinople logs]$ rpm -qi mod_perl | grep Version
Version : 2.0.1 Vendor: Red Hat, Inc.
basic [root@constantinople logs]$ rpm -ql mod_perl | grep Apache2.pm
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi/Bundle/Apache2.pm
basic [root@constantinople logs]$

Unless RH is doing some kind of special version of it.

–Andy

Scott T. Hildreth wrote: