Upgrading from 3.0.7 to 3.4.5 - old bookmarks are no good?

Hi,

I’ve upgraded from 3.0.7 to 3.4.5 on a new system. Before I unleash
users on it, I’ve noticed that old bookmarks do not work in the new
system:

Example:

Old system
http://host/Search/Listing.html?Bookmark=FrT%3B%402|%2|%241|7%8|%2411|DESCRIPTION%245|FIELD%248|OPERATOR%245|VALUE%2417|Subject%20LIKE%20blah%247|Subject%244|LIKE%244|blah%241|8&TicketsSortBy=LastUpdated&TicketsSortOrder=DESC&RowsPerPage=50

New system
Build:
http://newhost/Search/Build.html?Order=ASC&Query=%20Subject%20LIKE%20’blah’&Rows=0&OrderBy=id&Format=’%20%20%20<b><a%20href%3D"%2FTicket%2FDisplay.html%3Fid%3D__id__">__id__<%2Fa><%2Fb>%2FTITLE%3A%23’%2C ‘<b><a%20href%3D"%2FTicket%2FDisplay.html%3Fid%3D__id__">__Subject__<%2Fa><%2Fb>%2FTITLE%3ASubject’%2C Status’%2C%0A’QueueName’%2C%0A’OwnerName’%2C%0A’Priority’%2C%0A’NEWLINE’%2C%0A’’%2C%0A’%3Csmall%3E__Requestors__%3C%2Fsmall%3E’%2C%0A’%3Csmall%3E__CreatedRelative__%3C%2Fsmall%3E’%2C%0A’%3Csmall%3E__ToldRelative__%3C%2Fsmall%3E’%2C%0A’%3Csmall%3E__LastUpdatedRelative__%3C%2Fsmall%3E’%2C%0A’%3Csmall%3E__TimeLeft__%3C%2Fsmall%3E’
Bookmarked: http://newhost/Search/Results.html?Order=ASC&Query=%20Subject%20LIKE%20’blah’&Rows=0&OrderBy=id&Page=1&Format=’%20%20%20<b><a%20href%3D"%2FTicket%2FDisplay.html%3Fid%3D__id__">__id__<%2Fa><%2Fb>%2FTITLE%3A%23’%2C ‘<b><a%20href%3D"%2FTicket%2FDisplay.html%3Fid%3D__id__">__Subject__<%2Fa><%2Fb>%2FTITLE%3ASubject’%2C Status’%2C%0A’QueueName’%2C%0A’OwnerName’%2C%0A’Priority’%2C%0A’NEWLINE’%2C%0A’’%2C%0A’%3Csmall%3E__Requestors__%3C%2Fsmall%3E’%2C%0A’%3Csmall%3E__CreatedRelative__%3C%2Fsmall%3E’%2C%0A’%3Csmall%3E__ToldRelative__%3C%2Fsmall%3E’%2C%0A’%3Csmall%3E__LastUpdatedRelative__%3C%2Fsmall%3E’%2C%0A’%3Csmall%3E__TimeLeft__%3C%2Fsmall%3E’

I can’t find any documentation on “3.0.x” bookmarks breaking in newer
versions. Is this the case? Is there a workaround?

Thanks,
Brian

Hi,

I’ve upgraded from 3.0.7 to 3.4.5 on a new system. Before I unleash
users on it, I’ve noticed that old bookmarks do not work in the new
system:

That’s correct. The search system was entirely overhauled in RT 3.2. The
old bookmars are not compatible.