Upgraded MySQl to 4.1.21 - now getting "transactions not supported"

After the MySQL upgrade, it appears the Rt database was set to myisam. I changed it back to innodb, restarted Mysql and the web server. Still getting this error when I try to comment, reply or resolve any ticket. Any ideas?

error: Transactions not supported by database at /usr/lib/perl5/vendor_perl/5.8.7/i686-linux/DBI.pm line 1657.

context: …
1653: sub begin_work {
1654: my $dbh = shift;
1655: return $dbh->set_err(1, “Already in a transaction”)
1656: unless $dbh->FETCH(‘AutoCommit’);
1657: $dbh->STORE(‘AutoCommit’, 0); # will croak if driver doesn’t support it
1658: $dbh->STORE(‘BegunWork’, 1); # trigger post commit/rollback action
1659: return 1;
1660: }
1661:

code stack: /usr/lib/perl5/vendor_perl/5.8.7/i686-linux/DBI.pm:1657
/usr/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm:682
/opt/rt3/lib/RT/Ticket_Overlay.pm:2302
/opt/rt3/share/html/Ticket/Elements/PreviewScrips:82
/opt/rt3/share/html/Ticket/Update.html:137
/opt/rt3/share/html/autohandler:279

I downgraded to MySQL 4.1.20 and it works fine.

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Peake,
JeremySent: Tuesday, August 15, 2006 8:30 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Upgraded MySQl to 4.1.21 - now getting “transactions
notsupported”

After the MySQL upgrade, it appears the Rt database was set to myisam.
I changed it back to innodb, restarted Mysql and the web server. Still
getting this error when I try to comment, reply or resolve any ticket.
Any ideas?

error: Transactions not supported by database at
/usr/lib/perl5/vendor_perl/5.8.7/i686-linux/DBI.pm line 1657.

context: …
1653: sub begin_work {
1654: my $dbh = shift;
1655: return $dbh->set_err(1, “Already in a transaction”)
1656: unless $dbh->FETCH(‘AutoCommit’);
1657: $dbh->STORE(‘AutoCommit’, 0); # will croak if driver doesn’t
support it
1658: $dbh->STORE(‘BegunWork’, 1); # trigger post commit/rollback
action
1659: return 1;
1660: }
1661:

code stack: /usr/lib/perl5/vendor_perl/5.8.7/i686-linux/DBI.pm:1657
/usr/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm:682
/opt/rt3/lib/RT/Ticket_Overlay.pm:2302
/opt/rt3/share/html/Ticket/Elements/PreviewScrips:82
/opt/rt3/share/html/Ticket/Update.html:137
/opt/rt3/share/html/autohandler:279

ooops, nevermind. it doesn’t work after the downgrade. I can “OPEN” a
ticket. but cannot “TAKE” “COMMENT” “REPLY” “RESOLVE”

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Peake,
JeremySent: Tuesday, August 15, 2006 8:56 AM
To: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Upgraded MySQl to 4.1.21 - now getting
"transactionsnotsupported"

I downgraded to MySQL 4.1.20 and it works fine.

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Peake,
Jeremy
Sent: Tuesday, August 15, 2006 8:30 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Upgraded MySQl to 4.1.21 - now getting “transactions
notsupported”

After the MySQL upgrade, it appears the Rt database was set to myisam.
I changed it back to innodb, restarted Mysql and the web server. Still
getting this error when I try to comment, reply or resolve any ticket.
Any ideas?

error: Transactions not supported by database at
/usr/lib/perl5/vendor_perl/5.8.7/i686-linux/DBI.pm line 1657.

context: …
1653: sub begin_work {
1654: my $dbh = shift;
1655: return $dbh->set_err(1, “Already in a transaction”)
1656: unless $dbh->FETCH(‘AutoCommit’);
1657: $dbh->STORE(‘AutoCommit’, 0); # will croak if driver doesn’t
support it
1658: $dbh->STORE(‘BegunWork’, 1); # trigger post commit/rollback
action
1659: return 1;
1660: }
1661:

code stack: /usr/lib/perl5/vendor_perl/5.8.7/i686-linux/DBI.pm:1657
/usr/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm:682
/opt/rt3/lib/RT/Ticket_Overlay.pm:2302
/opt/rt3/share/html/Ticket/Elements/PreviewScrips:82
/opt/rt3/share/html/Ticket/Update.html:137
/opt/rt3/share/html/autohandler:279

Jeremy,

The MySQL client library has changed.

Recompiling DBD::mysql solved the same problem for me.

David

Peake, Jeremy wrote:

Ahhhhh, thanks a lot!!! That did it.

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of David
Oberlitner
To:
“transactionsnotsupported”

Jeremy,

The MySQL client library has changed.

Recompiling DBD::mysql solved the same problem for me.

David

Peake, Jeremy wrote:

ooops, nevermind. it doesn’t work after the downgrade. I can "OPEN"
a ticket. but cannot “TAKE” “COMMENT” “REPLY” “RESOLVE”



From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] *On Behalf Of
*Peake, Jeremy
Sent: Tuesday, August 15, 2006 8:56 AM
To: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Upgraded MySQl to 4.1.21 - now getting
"transactionsnotsupported"

I downgraded to MySQL 4.1.20 and it works fine.



From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] *On Behalf Of
*Peake, Jeremy
Sent: Tuesday, August 15, 2006 8:30 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Upgraded MySQl to 4.1.21 - now getting
"transactions notsupported"

After the MySQL upgrade, it appears the Rt database was set to myisam.

I changed it back to innodb, restarted Mysql and the web server.
Still getting this error when I try to comment, reply or resolve any
ticket.
Any ideas?

error: Transactions not supported by database at
/usr/lib/perl5/vendor_perl/5.8.7/i686-linux/DBI.pm line 1657.

context: *** …*
1653: sub begin_work {
1654: my $dbh = shift;
1655: return $dbh->set_err(1, “Already in a transaction”)
1656: unless $dbh->FETCH(‘AutoCommit’);
1657: $dbh->STORE(‘AutoCommit’, 0); # will croak if driver
doesn’t
support it
1658: $dbh->STORE(‘BegunWork’, 1); # trigger post commit/rollback
action
1659: return 1;
1660: }
1661:

code stack:
/usr/lib/perl5/vendor_perl/5.8.7/i686-linux/DBI.pm:1657
/usr/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm:682
/opt/rt3/lib/RT/Ticket_Overlay.pm:2302
/opt/rt3/share/html/Ticket/Elements/PreviewScrips:82
/opt/rt3/share/html/Ticket/Update.html:137
/opt/rt3/share/html/autohandler:279



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com Commercial support:
sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com Commercial support:
sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com