Upgrade Problem

I just tried going from 3.0.2 to 3.0.3pre and get the following error
from the admin gui…help

error: Can’t locate object method “TransactionDepth” via package
"RT::Handle" at /opt/rt3/share/html/autohandler line 27.

context: …
23: %# END LICENSE BLOCK
24: <%INIT>
25:
26: # Roll back any dangling transactions from a previous failed
connection
27: $RT::Handle->ForceRollback() if $RT::Handle->TransactionDepth;
28:
29:
30: local *session;
31: %ARGS = map {

code stack: /opt/rt3/share/html/autohandler:27

Never mind…I had to restart Apache and now all is fine…phew!-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Andy Melton
Sent: Wednesday, June 18, 2003 4:29 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] Upgrade Problem

I just tried going from 3.0.2 to 3.0.3pre and get the following error
from the admin gui…help

error: Can’t locate object method “TransactionDepth” via package
"RT::Handle" at /opt/rt3/share/html/autohandler line 27.

context: …
23: %# END LICENSE BLOCK
24: <%INIT>
25:
26: # Roll back any dangling transactions from a previous failed
connection
27: $RT::Handle->ForceRollback() if $RT::Handle->TransactionDepth;
28:
29:
30: local *session;
31: %ARGS = map {

code stack: /opt/rt3/share/html/autohandler:27

rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Andy Melton wrote:

I just tried going from 3.0.2 to 3.0.3pre and get the following error
from the admin gui…help

error: Can’t locate object method “TransactionDepth” via package
"RT::Handle" at /opt/rt3/share/html/autohandler line 27.

You didn’t upgrade DBIx::SearchBuilder to the version
required for the later version of RT. "make testdeps"
is your friend.
Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances