Unable to connect to MySQL during RT upgrade

Hello list,
I’m upgrading from the Debian RT 4.2.8 package to the source 4.4.1, and am
stuck at the ‘make upgrade-database’ step. When I enter the root password,
my version, and ‘y’ to have it begin, it immediately says it can’t connect
and exits with code 255. Here’s what I’ve tried thus far, in no particular
order:

  • restore my backup of the 4.2.8 database to the rt441 database
  • change the username for the RT MySQL account from rtuser (which 4.2.8
    used) to rt_user, since that’s what the RT_Config.pm file has
  • change rt_user’s password to match what’s in the config file (that is,
    PASSWORD(‘pwd’))
  • moved 4.2.8’s configuration files to /opt/rt4/etc/RT_SiteConfig.d, but I
    can’t figure out how to apply them
  • checked that no one else is connected to MySQL (they’re not)
  • restarted and then stopped request-tracker4, stopped the FCGI server for
    4.2.8, and restarted Nginx
  • granted full privileges on rt441 to rt_user, then flushed privileges

I’m out of ideas. Can anyone suggest why the upgrade can’t log in? I know
the account works, because I can use rt_user to log into MySQL directly,
using the same password as in the config file. What have I missed?

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

After a few more repeats of some of the below steps, suddenly things
worked. I’m embarrassed to say I may have forgotten to specify rt441.* when
granting privileges, instead only entering rt441. In any case, the upgrade
finally ran, and I appear to be okay, save one thing: those RT_SiteConfig.d
files. They’re there, but I can’t figure out how to make them apply. The
’update-rt-siteconfig’ command still seems to be working on the 4.2.8
install, not the new 4.4.1. I’m not sure how to get it to work on the new
install.On Mon, Oct 10, 2016 at 5:07 PM, Alex Hall ahall@autodist.com wrote:

Hello list,
I’m upgrading from the Debian RT 4.2.8 package to the source 4.4.1, and am
stuck at the ‘make upgrade-database’ step. When I enter the root password,
my version, and ‘y’ to have it begin, it immediately says it can’t connect
and exits with code 255. Here’s what I’ve tried thus far, in no particular
order:

  • restore my backup of the 4.2.8 database to the rt441 database
  • change the username for the RT MySQL account from rtuser (which 4.2.8
    used) to rt_user, since that’s what the RT_Config.pm file has
  • change rt_user’s password to match what’s in the config file (that is,
    PASSWORD(‘pwd’))
  • moved 4.2.8’s configuration files to /opt/rt4/etc/RT_SiteConfig.d, but I
    can’t figure out how to apply them
  • checked that no one else is connected to MySQL (they’re not)
  • restarted and then stopped request-tracker4, stopped the FCGI server for
    4.2.8, and restarted Nginx
  • granted full privileges on rt441 to rt_user, then flushed privileges

I’m out of ideas. Can anyone suggest why the upgrade can’t log in? I know
the account works, because I can use rt_user to log into MySQL directly,
using the same password as in the config file. What have I missed?


Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

The ‘update-rt-siteconfig’ command still seems to be working on the 4.2.8
install, not the new 4.4.1.

update-alternatives(8)

Or, use the full command name. Try this:

update-rt-siteconfig

“Soccer is one of those things that the rest of world cares about more
than Americans do - you know, like healthcare, education and gun
control” - David Letterman

The ‘update-rt-siteconfig’ command still seems to be working on the 4.2.8
install, not the new 4.4.1.

update-alternatives(8)

Typing the (8) exactly as shown gives me a syntax error, while leaving it off offers options that don’t appear to be what I’m after.

Or, use the full command name. Try this:

update-rt-siteconfig

Unfortunately, no luck here either. The only alternative I can get is update-rt-siteconfig-4, which still applies to the 4.2.8 install. Thanks for the response, but I still seem to be missing the right command. Or is the set of update-* commands stored somewhere, waiting for me to remove the old ones and add the new? Again, I’m pretty new to Linux, so I hope that isn’t a stupid question.

The ‘update-rt-siteconfig’ command still seems to be working on the
4.2.8
install, not the new 4.4.1.

update-alternatives(8)

Typing the (8) exactly as shown gives me a syntax error, while leaving
it off offers options that don’t appear to be what I’m after.

I believe that was a suggestion that you consult the documentation for
"update-alternatives" in the system manual page collection, section 8.
Or in command form:

man 8 update-alternatives

The “()” shorthand as a way to refer to man pages is
traditional Unix-ese, derived from the page headers of the V7 Research
Unix system manual (a thing made of actual paper.)

Hi Alex,On Mon, Oct 10, 2016 at 5:07 PM, Alex Hall ahall@autodist.com wrote:

After a few more repeats of some of the below steps, suddenly things worked.
I’m embarrassed to say I may have forgotten to specify rt441.* when granting
privileges, instead only entering rt441. In any case, the upgrade finally
ran, and I appear to be okay, save one thing: those RT_SiteConfig.d files.
They’re there, but I can’t figure out how to make them apply. The
’update-rt-siteconfig’ command still seems to be working on the 4.2.8
install, not the new 4.4.1. I’m not sure how to get it to work on the new
install.

RT_SiteConfig.d was a Debian-ism until 4.4 - then it became upstream.

In RT 4.4.x you no longer need to run the update-rt-siteconfig - that
is only applicable to Debian RT 4.2.

In RT 4.4.x the config gets dynamically built when the web server is started.

-m

Hi Alex,

After a few more repeats of some of the below steps, suddenly things worked.
I’m embarrassed to say I may have forgotten to specify rt441.* when granting
privileges, instead only entering rt441. In any case, the upgrade finally
ran, and I appear to be okay, save one thing: those RT_SiteConfig.d files.
They’re there, but I can’t figure out how to make them apply. The
’update-rt-siteconfig’ command still seems to be working on the 4.2.8
install, not the new 4.4.1. I’m not sure how to get it to work on the new
install.

RT_SiteConfig.d was a Debian-ism until 4.4 - then it became upstream.

In RT 4.4.x you no longer need to run the update-rt-siteconfig - that
is only applicable to Debian RT 4.2.

In RT 4.4.x the config gets dynamically built when the web server is started.

That’s great to know, thanks! When you say the server, I’m assuming you mean the FCGI server? I’m running this with Nginx, so use spawn-fcgi to start the server that handles RT for Nginx.