Trying to install mod_perl

After couple of apache2 fail, I am trying to install mod_perl in cpan and I got the following error messages:

cpan[1]> install mod_perl
CPAN: Storable loaded ok (v2.18)
Going to read ‘/root/.cpan/Metadata’
Database was generated on Mon, 17 May 2010 14:28:57 GMT
CPAN: YAML loaded ok (v0.71)
Going to read 125 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.8972 secs)
Running install for module ‘mod_perl’
Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory /root/.cpan/build/mod_perl-1.31-OqZLsX
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t install

Please help me resolve this issue. What do I need to do and where is apache2 source directory located?

After couple of apache2 fail, I am trying to install mod_perl in cpan and I
got the following error messages:

cpan[1]> install mod_perl
CPAN: Storable loaded ok (v2.18)
Going to read ‘/root/.cpan/Metadata’
Database was generated on Mon, 17 May 2010 14:28:57 GMT
CPAN: YAML loaded ok (v0.71)
Going to read 125 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.8972 secs)
Running install for module ‘mod_perl’
Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t install

That suggests you already have installed mod_perl. Did you also
configure it in Apache?

See the mod_perl documentation at http://perl.apache.org/, in
particular http://perl.apache.org/docs/2.0/user/config/config.html#Enabling_mod_perl

Please help me resolve this issue. What do I need to do and where is apache2
source directory located?

That really depends on how you installed Apache.

Note that Apache has it’s own mailing lists -
http://httpd.apache.org/userslist.html.

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

Please, keep it on the mailing list.On Mon, May 17, 2010 at 21:32, borngunners@aol.com wrote:

Did you also configure it in Apache?
No I did not

How do you configure it in apache?
I am not too savvy with linux and unix…A guide will be helpful

I linked to the guides you need - I even linked directly to the
particular one for enabling mod_perl in Apache.

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

After I uncomment the PerlRequire in my httpd.conf file, apche2 restart successfully, but then I receive the following message from my web browser:

You’re almost there!
You haven’t yet configured your webserver to run RT. You appear to have installed RT’s web interface correctly, but haven’t yet configured your web server to “run” the RT server which powers the web interface. The next step is to edit your webserver’s configuration file to instruct it to use RT’s mod_perl, FastCGI or SpeedyCGI handler. If you need commercial support, please contact us at sales@bestpractical.com.

What Am I doing wrong in this case?From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Mon, May 17, 2010 4:14 pm
Subject: Re: [rt-users] Trying to install mod_perl

After couple of apache2 fail, I am trying to install mod_perl in cpan and I
got the following error messages:

cpan[1]> install mod_perl
CPAN: Storable loaded ok (v2.18)
Going to read ‘/root/.cpan/Metadata’
Database was generated on Mon, 17 May 2010 14:28:57 GMT
CPAN: YAML loaded ok (v0.71)
Going to read 125 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.8972 secs)
Running install for module ‘mod_perl’
Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t install
That suggests you already have installed mod_perl. Did you also
onfigure it in Apache?
See the mod_perl documentation at http://perl.apache.org/, in
articular http://perl.apache.org/docs/2.0/user/config/config.html#Enabling_mod_perl

Please help me resolve this issue. What do I need to do and where is apache2
source directory located?
That really depends on how you installed Apache.
Note that Apache has it’s own mailing lists -
ttp://httpd.apache.org/userslist.html.
Please keep list traffic on the list.
Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche
Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
uy a copy at http://rtbook.bestpractical.com

After I uncomment the PerlRequire in my httpd.conf file, apche2 restart
successfully, but then I receive the following message from my web browser:

You’re almost there!

You haven’t yet configured your webserver to run RT. You appear to have
installed RT’s web interface correctly, but haven’t yet configured your web
server to “run” the RT server which powers the web interface. The next step
is to edit your webserver’s configuration file to instruct it to use RT’s
mod_perl, FastCGI or SpeedyCGI handler. If you need commercial support,
please contact us at sales@bestpractical.com.

What Am I doing wrong in this case?

http://rt.bestpractical.com/view/ManualApacheConfig

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

I have checked and made necessary corrections. Now, all I am getting is this:
It Works!

What am I missing in this case?-----Original Message-----
From: borngunners borngunners@aol.com
To: rob.macgregor rob.macgregor@gmail.com
Sent: Mon, May 17, 2010 5:27 pm
Subject: Re: [rt-users] Trying to install mod_perl

I have checked and made necessary corrections. Now, all I am getting is this:
It Works!

What am I missing in this case?

-----Original Message-----
From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Mon, May 17, 2010 4:58 pm
Subject: Re: [rt-users] Trying to install mod_perl

On Mon, May 17, 2010 at 21:37, borngunners@aol.com wrote:
After I uncomment the PerlRequire in my httpd.conf file, apche2 restart
successfully, but then I receive the following message from my web browser:

You’re almost there!

You haven’t yet configured your webserver to run RT. You appear to have
installed RT’s web interface correctly, but haven’t yet configured your web
server to “run” the RT server which powers the web interface. The next step
is to edit your webserver’s configuration file to instruct it to use RT’s
mod_perl, FastCGI or SpeedyCGI handler. If you need commercial support,
please contact us at sales@bestpractical.com.

What Am I doing wrong in this case?
http://rt.bestpractical.com/view/ManualApacheConfig
Please keep list traffic on the list.
Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche
Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
uy a copy at http://rtbook.bestpractical.com

I don’t need to get multiple copies of all of your emails - please
send them to the list and the list alone.On Mon, May 17, 2010 at 22:28, borngunners@aol.com wrote:

I have checked and made necessary corrections. Now, all I am getting is
this:
It Works!

What am I missing in this case?

Appropriate configuration of Apache :wink:

Did you read the URL I previously directed you to? It’s apparent that
you haven’t made the appropriate RT changes to your Apache install.

Can you upload a copy of your Apache configuration file (such as at
http://pastebin.com/) and provide a link to where it can be found?

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

I read the link that you sent me and that helps me get the result that I got. I have pasted the configuration in the link that you sent me and
created a private link http://pastebin.com/8n6vemSK-----Original Message-----
From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Mon, May 17, 2010 5:47 pm
Subject: Re: [rt-users] Trying to install mod_perl

I don’t need to get multiple copies of all of your emails - please
end them to the list and the list alone.
On Mon, May 17, 2010 at 22:28, borngunners@aol.com wrote:

I have checked and made necessary corrections. Now, all I am getting is
this:
It Works!

What am I missing in this case?
Appropriate configuration of Apache :wink:
Did you read the URL I previously directed you to? It’s apparent that
ou haven’t made the appropriate RT changes to your Apache install.
Can you upload a copy of your Apache configuration file (such as at
ttp://pastebin.com/) and provide a link to where it can be found?
Please keep list traffic on the list.
Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche
Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
uy a copy at http://rtbook.bestpractical.com

Hi,

have you tried to rename or remove
/root/.cpan/build/mod_perl-1.31-OqZLsX

than try reinstall.

raymond

Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
� Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX

After I uncomment the PerlRequire in my httpd.conf file, apche2 restart successfully, but then I receive the following message from my web browser:

You’re almost there!
You haven’t yet configured your webserver to run RT. You appear to have installed RT’s web interface correctly, but haven’t yet configured your web server to “run” the RT server which powers the web interface. The next step is to edit your webserver’s configuration file to instruct it to use RT’s mod_perl, FastCGI or SpeedyCGI handler. If you need commercial support, please contact us at sales@bestpractical.com.

What Am I doing wrong in this case?

-----Original Message-----
From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Mon, May 17, 2010 4:14 pm
Subject: Re: [rt-users] Trying to install mod_perl

After couple of apache2 fail, I am trying to install mod_perl in cpan and I
got the following error messages:

cpan[1]> install mod_perl
CPAN: Storable loaded ok (v2.18)
Going to read ‘/root/.cpan/Metadata’
Database was generated on Mon, 17 May 2010 14:28:57 GMT
CPAN: YAML loaded ok (v0.71)
Going to read 125 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.8972 secs)
Running install for module ‘mod_perl’
Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t install
That suggests you already have installed mod_perl. Did you also
onfigure it in Apache?
See the mod_perl documentation at http://perl.apache.org/, in
articular http://perl.apache.org/docs/2.0/user/config/config.html#Enabling_mod_perl

Please help me resolve this issue. What do I need to do and where is apache2
source directory located?
That really depends on how you installed Apache.
Note that Apache has it’s own mailing lists -
ttp://httpd.apache.org/userslist.html.

Regards,

Raymond Wong

Personal motto: P.E.A.C.E
Enjoy the present
Assert your goals
Champion peace
Entrust others

This is the error that I got after I did the following :
#rm -rf /root/.cpan/build/mod_perl-1.31-OqZLsX
#cpan
CPAN> install mod_perl

CPAN: File::Temp loaded ok (v0.22)
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t installFrom: raymond raymond@pilotsupplies.com
To: borngunners borngunners@aol.com
Cc: rob.macgregor rob.macgregor@gmail.com; RT-Users RT-Users@lists.bestpractical.com
Sent: Tue, May 18, 2010 1:32 pm
Subject: Re: [rt-users] Trying to install mod_perl

Hi,
have you tried to rename or remove
root/.cpan/build/mod_perl-1.31-OqZLsX
than try reinstall.
raymond

Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX

n Mon, 17 May 2010, borngunners@aol.com wrote:

After I uncomment the PerlRequire in my httpd.conf file, apche2 restart
uccessfully, but then I receive the following message from my web browser:

You’re almost there!
You haven’t yet configured your webserver to run RT. You appear to have
nstalled RT’s web interface correctly, but haven’t yet configured your web
erver to “run” the RT server which powers the web interface. The next step is
o edit your webserver’s configuration file to instruct it to use RT’s mod_perl,
astCGI or SpeedyCGI handler. If you need commercial support, please contact us
t sales@bestpractical.com.

What Am I doing wrong in this case?

From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Mon, May 17, 2010 4:14 pm
Subject: Re: [rt-users] Trying to install mod_perl

After couple of apache2 fail, I am trying to install mod_perl in cpan and I
got the following error messages:

cpan[1]> install mod_perl
CPAN: Storable loaded ok (v2.18)
Going to read ‘/root/.cpan/Metadata’
Database was generated on Mon, 17 May 2010 14:28:57 GMT
CPAN: YAML loaded ok (v0.71)
Going to read 125 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.8972 secs)
Running install for module ‘mod_perl’
Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t install
That suggests you already have installed mod_perl. Did you also
onfigure it in Apache?
See the mod_perl documentation at http://perl.apache.org/, in
articular http://perl.apache.org/docs/2.0/user/config/config.html#Enabling_mod_perl

Please help me resolve this issue. What do I need to do and where is apache2
source directory located?
That really depends on how you installed Apache.
Note that Apache has it’s own mailing lists -
ttp://httpd.apache.org/userslist.html.

Regards,
Raymond Wong

ersonal motto: P.E.A.C.E
njoy the present
ssert your goals
hampion peace
ntrust others

I have remove it and successfully reinstall it without the messages that showed up. Apache still keeps failing with the following error message after I look into my log:

[Tue May 18 14:47:36 2010] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server UHC Helpdesk:0, exiting…

This is my configuration file:

ServerName "UHC Helpdesk" ServerAdmin helpdesk@health.umd.edu ErrorLog /var/log/apache2/helpdesk-error.log # config for your main content DocumentRoot /opt/rt3/share/html/ AddDefaultCharset UTF-8 PerlRequire /opt/rt3/bin/webmux.pl Order Allow,Deny Allow from all SetHandler perl-script

PerlResponseHandler RT::Mason



From: raymond raymond@pilotsupplies.com
To: borngunners borngunners@aol.com
Cc: rob.macgregor rob.macgregor@gmail.com; RT-Users RT-Users@lists.bestpractical.com
Sent: Tue, May 18, 2010 1:32 pm
Subject: Re: [rt-users] Trying to install mod_perl

Hi,
have you tried to rename or remove
root/.cpan/build/mod_perl-1.31-OqZLsX
than try reinstall.
raymond

Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX

n Mon, 17 May 2010, borngunners@aol.com wrote:

After I uncomment the PerlRequire in my httpd.conf file, apche2 restart
uccessfully, but then I receive the following message from my web browser:

You’re almost there!
You haven’t yet configured your webserver to run RT. You appear to have
nstalled RT’s web interface correctly, but haven’t yet configured your web
erver to “run” the RT server which powers the web interface. The next step is
o edit your webserver’s configuration file to instruct it to use RT’s mod_perl,
astCGI or SpeedyCGI handler. If you need commercial support, please contact us
t sales@bestpractical.com.

What Am I doing wrong in this case?

From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Mon, May 17, 2010 4:14 pm
Subject: Re: [rt-users] Trying to install mod_perl

After couple of apache2 fail, I am trying to install mod_perl in cpan and I
got the following error messages:

cpan[1]> install mod_perl
CPAN: Storable loaded ok (v2.18)
Going to read ‘/root/.cpan/Metadata’
Database was generated on Mon, 17 May 2010 14:28:57 GMT
CPAN: YAML loaded ok (v0.71)
Going to read 125 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.8972 secs)
Running install for module ‘mod_perl’
Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t install
That suggests you already have installed mod_perl. Did you also
onfigure it in Apache?
See the mod_perl documentation at http://perl.apache.org/, in
articular http://perl.apache.org/docs/2.0/user/config/config.html#Enabling_mod_perl

Please help me resolve this issue. What do I need to do and where is apache2
source directory located?
That really depends on how you installed Apache.
Note that Apache has it’s own mailing lists -
ttp://httpd.apache.org/userslist.html.

Regards,
Raymond Wong

ersonal motto: P.E.A.C.E
njoy the present
ssert your goals
hampion peace
ntrust others

I have remove it and successfully reinstall it without the messages that
showed up. Apache still keeps failing with the following error message after
I look into my log:

[Tue May 18 14:47:36 2010] [error] Can’t load Perl file:
/opt/rt3/bin/webmux.pl for server UHC Helpdesk:0, exiting…

Does that file exist? Can the user you’re running Apache as access it?

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

Does that file exist? Can the user you’re running Apache as access it?

I checked the file and it was in there and I am running apache as root and root seems to own the file.-----Original Message-----
From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Tue, May 18, 2010 5:39 pm
Subject: Re: [rt-users] Trying to install mod_perl

On Tue, May 18, 2010 at 19:55, borngunners@aol.com wrote:

I have remove it and successfully reinstall it without the messages that
showed up. Apache still keeps failing with the following error message after
I look into my log:

[Tue May 18 14:47:36 2010] [error] Can’t load Perl file:
/opt/rt3/bin/webmux.pl for server UHC Helpdesk:0, exiting…

Does that file exist? Can the user you’re running Apache as access it?

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

I checked the file and it was in there and I am running apache as root and
root seems to own the file.

I really hope you’re not actually running Apache as root - that’s a
major security risk.

Note that pastebin.com appears to be down, you may want to upload a
copy of your Apache configuration to a different site
(http://en.wikipedia.org/wiki/Comparison_of_pastebins).

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

Dear non german RT Users,
sorry for the post in german below. This is just a “last call” to all german RT Users for the upcoming RT Event at the German Unix User Group.

Hallo RT User,
hiermit nochmal ein letzter Aufruf fuer den RT Workshop auf dem FFG der GUUG in Koeln.

Weitere Informationen:

Allgemein: http://www.guug.de/veranstaltungen/ffg2010/index.html
Programm: http://www.guug.de/veranstaltungen/ffg2010/programm.html

Vortrag: http://www.guug.de/veranstaltungen/ffg2010/abstracts.html#3_8_2
Workshop: http://www.guug.de/veranstaltungen/ffg2010/abstracts.html#2_2_5

Wir wuerden uns freuen so viele RT Anhaenger wie moeglich begruessen zu koennen…

Torsten

Kuehne + Nagel (AG & Co.) KG, Geschaeftsleitung: Hans-Georg Brinkmann (Vors.), Dirk Blesius, Reiner Heiken, Bruno Mang, Alfred Manke, Christian Marnetté, Mark Reinhardt, Jens Wollesen, Rainer Wunn, Sitz: Bremen, Registergericht: Bremen, HRA 21928, USt-IdNr.: DE 812773878, Persoenlich haftende Gesellschaft: Kuehne & Nagel A.G., Sitz: Contern/Luxemburg Geschaeftsfuehrender Verwaltungsrat: Klaus-Michael Kuehne

HI,

does perl.load exists in

/etc/apache2/mods-enabled#

or in your main httpd.conf ?

raymondOn Tue, 18 May 2010, borngunners@aol.com wrote:

I have remove it and successfully reinstall it without the messages that showed up. Apache still keeps failing with the following error message after I look into my log:

[Tue May 18 14:47:36 2010] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server UHC Helpdesk:0, exiting…

This is my configuration file:

ServerName "UHC Helpdesk" ServerAdmin helpdesk@health.umd.edu ErrorLog /var/log/apache2/helpdesk-error.log # config for your main content DocumentRoot /opt/rt3/share/html/ AddDefaultCharset UTF-8 PerlRequire /opt/rt3/bin/webmux.pl Order Allow,Deny Allow from all SetHandler perl-script

PerlResponseHandler RT::Mason



-----Original Message-----
From: raymond raymond@pilotsupplies.com
To: borngunners borngunners@aol.com
Cc: rob.macgregor rob.macgregor@gmail.com; RT-Users RT-Users@lists.bestpractical.com
Sent: Tue, May 18, 2010 1:32 pm
Subject: Re: [rt-users] Trying to install mod_perl

Hi,
have you tried to rename or remove
root/.cpan/build/mod_perl-1.31-OqZLsX
than try reinstall.
raymond

Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX

n Mon, 17 May 2010, borngunners@aol.com wrote:

After I uncomment the PerlRequire in my httpd.conf file, apche2 restart
uccessfully, but then I receive the following message from my web browser:

You’re almost there!
You haven’t yet configured your webserver to run RT. You appear to have
nstalled RT’s web interface correctly, but haven’t yet configured your web
erver to “run” the RT server which powers the web interface. The next step is
o edit your webserver’s configuration file to instruct it to use RT’s mod_perl,
astCGI or SpeedyCGI handler. If you need commercial support, please contact us
t sales@bestpractical.com.

What Am I doing wrong in this case?

-----Original Message-----
From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Mon, May 17, 2010 4:14 pm
Subject: Re: [rt-users] Trying to install mod_perl

On Mon, May 17, 2010 at 20:31, borngunners@aol.com wrote:
After couple of apache2 fail, I am trying to install mod_perl in cpan and I
got the following error messages:

cpan[1]> install mod_perl
CPAN: Storable loaded ok (v2.18)
Going to read ‘/root/.cpan/Metadata’
Database was generated on Mon, 17 May 2010 14:28:57 GMT
CPAN: YAML loaded ok (v0.71)
Going to read 125 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.8972 secs)
Running install for module ‘mod_perl’
Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t install
That suggests you already have installed mod_perl. Did you also
onfigure it in Apache?
See the mod_perl documentation at http://perl.apache.org/, in
articular http://perl.apache.org/docs/2.0/user/config/config.html#Enabling_mod_perl

Please help me resolve this issue. What do I need to do and where is apache2
source directory located?
That really depends on how you installed Apache.
Note that Apache has it’s own mailing lists -
ttp://httpd.apache.org/userslist.html.

Regards,

Raymond Wong

Personal motto: P.E.A.C.E
Enjoy the present
Assert your goals
Champion peace
Entrust others

So, lets say I have reinstall the entire OS and install the dependencies and get the following results, which at the end all dependencies have been found. Why am I missing the 3 things in red? What have I missed?

root@helpdesk:~/rt-3.8.8# make install
/usr/bin/perl ./sbin/rt-test-dependencies --verbose --with-mysql --with-fastcgi
perl:
>=5.8.3(5.10.0) …found
users:
rt group (www) …MISSING
bin owner (root) …found
libs owner (root) …found
libs group (bin) …found
web owner (www) …MISSING
web group (www) …MISSINGFrom: raymond raymond@pilotsupplies.com
To: borngunners borngunners@aol.com
Cc: RT-Users RT-Users@lists.bestpractical.com
Sent: Wed, May 19, 2010 1:03 pm
Subject: Re: [rt-users] Trying to install mod_perl

HI,
does perl.load exists in
/etc/apache2/mods-enabled#
or in your main httpd.conf ?
raymond

n Tue, 18 May 2010, borngunners@aol.com wrote:

I have remove it and successfully reinstall it without the messages that
howed up. Apache still keeps failing with the following error message after I
ook into my log:

[Tue May 18 14:47:36 2010] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl
or server UHC Helpdesk:0, exiting…

This is my configuration file:

ServerName "UHC Helpdesk" ServerAdmin helpdesk@health.umd.edu ErrorLog /var/log/apache2/helpdesk-error.log # config for your main content DocumentRoot /opt/rt3/share/html/ AddDefaultCharset UTF-8 PerlRequire /opt/rt3/bin/webmux.pl Order Allow,Deny Allow from all SetHandler perl-script

PerlResponseHandler RT::Mason



From: raymond raymond@pilotsupplies.com
To: borngunners borngunners@aol.com
Cc: rob.macgregor rob.macgregor@gmail.com; RT-Users RT-Users@lists.bestpractical.com
Sent: Tue, May 18, 2010 1:32 pm
Subject: Re: [rt-users] Trying to install mod_perl

Hi,
have you tried to rename or remove
root/.cpan/build/mod_perl-1.31-OqZLsX
than try reinstall.
raymond

Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX

n Mon, 17 May 2010, borngunners@aol.com wrote:

After I uncomment the PerlRequire in my httpd.conf file, apche2 restart
uccessfully, but then I receive the following message from my web browser:

You’re almost there!
You haven’t yet configured your webserver to run RT. You appear to have
nstalled RT’s web interface correctly, but haven’t yet configured your web
erver to “run” the RT server which powers the web interface. The next step is
o edit your webserver’s configuration file to instruct it to use RT’s
od_perl,
astCGI or SpeedyCGI handler. If you need commercial support, please contact us
t sales@bestpractical.com.

What Am I doing wrong in this case?

From: Rob MacGregor rob.macgregor@gmail.com
To: RT-Users RT-Users@lists.bestpractical.com
Sent: Mon, May 17, 2010 4:14 pm
Subject: Re: [rt-users] Trying to install mod_perl

After couple of apache2 fail, I am trying to install mod_perl in cpan and I
got the following error messages:

cpan[1]> install mod_perl
CPAN: Storable loaded ok (v2.18)
Going to read ‘/root/.cpan/Metadata’
Database was generated on Mon, 17 May 2010 14:28:57 GMT
CPAN: YAML loaded ok (v0.71)
Going to read 125 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.8972 secs)
Running install for module ‘mod_perl’
Running make for G/GO/GOZER/mod_perl-1.31.tar.gz
Has already been unwrapped into directory
/root/.cpan/build/mod_perl-1.31-OqZLsX
’/usr/bin/perl Makefile.PL INSTALLDIRS=site’ returned status 2, won’t make
Running make test
Make had some problems, won’t test
Running make install
Make had some problems, won’t install
That suggests you already have installed mod_perl. Did you also
onfigure it in Apache?
See the mod_perl documentation at http://perl.apache.org/, in
articular http://perl.apache.org/docs/2.0/user/config/config.html#Enabling_mod_perl

Please help me resolve this issue. What do I need to do and where is apache2
source directory located?
That really depends on how you installed Apache.
Note that Apache has it’s own mailing lists -
ttp://httpd.apache.org/userslist.html.

Regards,
Raymond Wong

ersonal motto: P.E.A.C.E
njoy the present
ssert your goals
hampion peace
ntrust others