Trying to get fastcgi to work w/apache2

Hi all,

I’ve been reading the
http://wiki.bestpractical.com/index.cgi?FastCGIConfiguration wiki
backwards and forwards trying to test out RT 3.2.1 w/FastCGI and no
matter which approach I try in the wiki I get:

[Fri Mar 04 10:21:47 2005] [error] [client 10.1.2.50] client denied by
server configuration: /usr/bin/mason_handler.fcgi

FastCGI starts up properly:

[Fri Mar 04 10:21:44 2005] [notice] FastCGI: process manager initialized
(pid 7336)
[Fri Mar 04 10:21:44 2005] [warn] FastCGI: server
"/usr/bin/mason_handler.fcgi" started (pid 7337)
[Fri Mar 04 10:21:44 2005] [notice] Apache configured – resuming normal
operations
[Fri Mar 04 10:21:45 2005] [warn] FastCGI: server
"/usr/bin/mason_handler.fcgi" started (pid 7343)
[Fri Mar 04 10:21:46 2005] [warn] FastCGI: server
"/usr/bin/mason_handler.fcgi" started (pid 7344)
[Fri Mar 04 10:21:47 2005] [warn] FastCGI: server
"/usr/bin/mason_handler.fcgi" started (pid 7346)

RT runs with mod_perl properly on the same machine.

I’ve added the webserver to the RT group, I’ve run suexec, I’ve edited
/usr/bin/mason_handler.fcgi to use suidperl, all to no avail. What
should I try?

Chris Covington
IT
Plus One Health Management
75 Maiden Lane Suite 801
NY, NY 10038
646-312-6269
http://www.plusoneactive.com

Hi all,

This was a problem because Gentoo’s build of Request Tracker places
mason_handler.fcgi in /usr/bin. So I had to allow access to that
directory in Apache2. This is what my running Gentoo FastCGI
configuration looks like:

<Directory /var/www/localhost/htdocs/rt>
Options FollowSymLinks ExecCGI
AllowOverride None

<Directory /usr/bin>
Options FollowSymLinks
Order allow,deny
allow from all

Alias /NoAuth/images/ /var/www/localhost/htdocs/rt/NoAuth/images/
FastCgiIpcDir /tmp
FastCgiServer /usr/bin/mason_handler.fcgi -idle-timeout 120 -processes 4
AddHandler fastcgi-script fcgi
ScriptAlias /rt /usr/bin/mason_handler.fcgi

I didn’t need to chown any RT files to apache2 or anything like that.

BTW - Apache 2 / FastCGI seems much faster than Apache 1 / mod_perl!

Chris Covington
IT
Plus One Health Management
75 Maiden Lane Suite 801
NY, NY 10038
646-312-6269
http://www.plusoneactive.com-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of
Covington, Chris
Sent: Friday, March 04, 2005 10:31 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] trying to get fastcgi to work w/apache2

Hi all,

I’ve been reading the
http://wiki.bestpractical.com/index.cgi?FastCGIConfiguration wiki
backwards and forwards trying to test out RT 3.2.1 w/FastCGI and no
matter which approach I try in the wiki I get:

[Fri Mar 04 10:21:47 2005] [error] [client 10.1.2.50] client denied by
server configuration: /usr/bin/mason_handler.fcgi

FastCGI starts up properly:

[Fri Mar 04 10:21:44 2005] [notice] FastCGI: process manager initialized
(pid 7336) [Fri Mar 04 10:21:44 2005] [warn] FastCGI: server
"/usr/bin/mason_handler.fcgi" started (pid 7337) [Fri Mar 04 10:21:44
2005] [notice] Apache configured – resuming normal operations [Fri Mar
04 10:21:45 2005] [warn] FastCGI: server “/usr/bin/mason_handler.fcgi"
started (pid 7343) [Fri Mar 04 10:21:46 2005] [warn] FastCGI: server
”/usr/bin/mason_handler.fcgi" started (pid 7344) [Fri Mar 04 10:21:47
2005] [warn] FastCGI: server “/usr/bin/mason_handler.fcgi” started (pid
7346)

RT runs with mod_perl properly on the same machine.

I’ve added the webserver to the RT group, I’ve run suexec, I’ve edited
/usr/bin/mason_handler.fcgi to use suidperl, all to no avail. What
should I try?

Chris Covington
IT
Plus One Health Management
75 Maiden Lane Suite 801
NY, NY 10038
646-312-6269
http://www.plusoneactive.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon!
(Boston, San Francisco, Austin, Sydney) Contact
training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com