Trying to backup and restore but comments are not restoring

Hello all!

I have searched through the archives and sadly the only references I am
finding are that sometimes the attachments table does not backup properly
without setting a binary switch.

I am running a backup of mysql (everything in it as the server only runs RT
3.4.6) with:

mysqldump -u root -p p@55w0rd -A | gzip > ./rt346.dbdump.gz

Then, on my restore system, I run:

zcat rt346.dbdump.gz | mysql -u root -p p@55w0rd

The restore runs just fine.

However after the restore all comments on all tickets are not visible.

I checked on my account rights and I am in **AdminGroup,
AdminGroupMembership, EditSavedSearches, ModifyOwnMembership, SeeGroup, and
ShowSavedSearches. But still I see no comments.

I would like to use mysql to query the comments field, but I am not sure
which table that field is in. I also suspect that comments may be stored in
non-clear text format as grepping the dump file for strings that should be
in the comments field is not working.

I have tried using the -T switch to export, exporting attachments table
separately, etc, but all to no avail.

This worked last time I tried it about 7 months ago. And now we want to
upgrade to lastest and greatest RT, but we need to be sure to preserve our
existing data. The 1st step in that process is to restore the data to a new

Any ideas guys? Anything I could tell you that would help diagnose?

“il n’y a pas de liberté s’il y a dépendance”