Trouble with RHEL 4 and installing FastCgi

I’ trying to install and I’m following the step-by-step road book at
http://wiki.bestpractical.com/index.cgi?RHEL4InstallGuide

My problem is with compiling the FastCGI

wget http://www.fastcgi.com/dist/mod_fastcgi-2.4.2.tar.gz
gunzip mod_fastcgi-2.4.2.tar.gz
tar -xvf mod_fastcgi-2.4.2.tar
cd mod_fastcgi-2.4.2
cp Makefile.AP2 Makefile
edit Makefile:
###Modify for location of apache 2 installation:
top_dir = /etc/httpd
make
make install

when I try to execute “make” a get the error:

"Makefile:12: /etc/httpd/build/special.mk: no such file or directory

Make: *** No rule to make target ‘/etc/build/special.mk’. Stop. "

I have the httpd-devel installed, do I have to do any other step??

Please I need some help on this.

Best regards

Pedro Ponte

mailto:pponte@netcabo.pt pponte@netcabo.pt

TV Cabo Portugal

Direccao de Rede e Servicos IP

Tel. +351215002139

smime.p7s (2.97 KB)

Are you positive you have httpd-devel installed? Because the error sounds like its looking for files in the http-devel build directories…

Are you using RHEL4? If not, the httpd directories are in a different place, and you’ll have to alter the top_dir statement of the Makefile.

Try doing a locate special.mk and see where it reports the file to be… it should report it as being in /usr/lib/httpd/build, which is symlinked to /etc/httpd/build…-----Original Message-----
From: Pedro Ponte [mailto:pponte@netcabo.pt]
Sent: Wednesday, June 15, 2005 3:57 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Trouble with RHEL 4 and installing FastCgi

I’ trying to install and I’m following the step-by-step road book at http://wiki.bestpractical.com/index.cgi?RHEL4InstallGuide

My problem is with compiling the FastCGI

wget http://www.fastcgi.com/dist/mod_fastcgi-2.4.2.tar.gz
gunzip mod_fastcgi-2.4.2.tar.gz
tar -xvf mod_fastcgi-2.4.2.tar
cd mod_fastcgi-2.4.2
cp Makefile.AP2 Makefile
edit Makefile:
###Modify for location of apache 2 installation:
top_dir = /etc/httpd
make
make install

when I try to execute “make” a get the error:

"Makefile:12: /etc/httpd/build/special.mk: no such file or directory

Make: *** No rule to make target ‘/etc/build/special.mk’. Stop. "

I have the httpd-devel installed, do I have to do any other step??

Please I need some help on this…

Best regards

Pedro Ponte

mailto:pponte@netcabo.pt pponte@netcabo.pt

TV Cabo Portugal

Direccao de Rede e Servicos IP

Tel. +351215002139

What if the locate special.mk hasn’t found anything?

I’m using RHEL 4, and I executed rpm -qa grep httpd and I got:

httpd-manual-2.0.52-12.ent

httpd-suexec-2.0.52-12.ent

httpd-2.0.52-12.ent

system-config-httpd-1.3.1-1

And from this command a can be sure that the http-devel is installed right?
Or it is not installed?

Best regards

Pedro Ponte

mailto:pponte@netcabo.pt pponte@netcabo.pt

TV Cabo Portugal

Direccao de Rede e Servicos IP

Tel. +351215002139From: William Harrison [mailto:harrison@itrd.gov]
Sent: quarta-feira, 15 de Junho de 2005 13:48
To: Pedro Ponte
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Trouble with RHEL 4 and installing FastCgi

Are you positive you have httpd-devel installed? Because the error sounds
like its looking for files in the http-devel build directories…

Are you using RHEL4? If not, the httpd directories are in a different place,
and you’ll have to alter the top_dir statement of the Makefile.

Try doing a locate special.mk and see where it reports the file to be… it
should report it as being in /usr/lib/httpd/build, which is symlinked to
/etc/httpd/build…

smime.p7s (2.97 KB)

Never mind that! I’ve successfully installed it (http-devel. :-))!

And I have successfully installed RT!

Thank you all

Best regards,

Pedro Ponte

pponte@netcabo.pt

TV Cabo Portugal

Direccao de Rede e Servicos IP

Tel. +351215002139From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Pedro Ponte
Sent: quinta-feira, 16 de Junho de 2005 9:32
To: 'William Harrison’
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Trouble with RHEL 4 and installing FastCgi

What if the locate special.mk hasn’t found anything?

I’m using RHEL 4, and I executed rpm -qa grep httpd and I got:

httpd-manual-2.0.52-12.ent

httpd-suexec-2.0.52-12.ent

httpd-2.0.52-12.ent

system-config-httpd-1.3.1-1

And from this command a can be sure that the http-devel is installed right?
Or it is not installed?

Best regards

Pedro Ponte

mailto:pponte@netcabo.pt pponte@netcabo.pt

TV Cabo Portugal

Direccao de Rede e Servicos IP

Tel. +351215002139

From: William Harrison [mailto:harrison@itrd.gov]
Sent: quarta-feira, 15 de Junho de 2005 13:48
To: Pedro Ponte
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Trouble with RHEL 4 and installing FastCgi

Are you positive you have httpd-devel installed? Because the error sounds
like its looking for files in the http-devel build directories…

Are you using RHEL4? If not, the httpd directories are in a different place,
and you’ll have to alter the top_dir statement of the Makefile.

Try doing a locate special.mk and see where it reports the file to be… it
should report it as being in /usr/lib/httpd/build, which is symlinked to
/etc/httpd/build…

smime.p7s (2.97 KB)

Hi all,
Can anyone tell me how the parameter passing from a URL can be accessed
within the Ticket_Overlay.pm. I tried $ARGS(’ parameter passed’) in the
.pm program but that didn’t work .Can anyoen give me soem ideas.

Regards,
Ahalya Nathan
Senior Programmer / Analyst
Information Technology, Metropolitan Utilities District
(402) 449-8218 phone
(402) 449-8131 fax
ahalya_nathan@mudnebr.com

Hi all,
Can anyone tell me how the parameter passing from a URL can be accessed
within the Ticket_Overlay.pm. I tried $ARGS(’ parameter passed’) in the
.pm program but that didn’t work .Can anyoen give me soem ideas.

$ARGS{‘parameter passed’}