Trouble installing 1.0.7]


#1

Hmmm… no response to my original question. Did I miss some point of
list etiquitte and am being ignored? If so, I humbly apologise and ask
for correction.

  • Lyle

#2

I suspect it’s that nobody actually knows the answer.
Do you run into this with other CGIs running under CGIWrap?
I’ve never seen nor touched cgi-wrap

    jesseOn Thu, Apr 05, 2001 at 02:17:48PM -0700, Lyle Scheer wrote:

Hmmm… no response to my original question. Did I miss some point of
list etiquitte and am being ignored? If so, I humbly apologise and ask
for correction.

  • Lyle

Date: Wed, 04 Apr 2001 14:04:58 -0700
From: Lyle Scheer lyle.scheer@Sun.COM
Organization: Sun Microsystems, Inc.
X-Mailer: Mozilla 4.75 [en] (X11; U; Linux 2.2.16-22 i686)
To: rt-users@lists.fsck.com
Subject: [rt-users] Trouble installing 1.0.7
List-Id: For users of RT: Request Tracker <rt-users.lists.fsck.com>

I’m trying to install RT version 1.0.7 on a Cobalt RaQ 3, which runs
CGIwrap. I’m having the following problem:

I install RT with a path of /home/sites/home/web (which happens to

be the document root of the web site). I invoke
http:///bin/cgi/webrt.cgi. I get the login page. I type my name
and password. I get the failure from CGIwrap: Execution of this script
not permitted:

Execution of

(/home/sites/home/web/bin/cgi/webrt.cgi/bin/cgi/webrt.cgi) is not
permitted for the following reason: Script file not found.

Any clues on why I'm getting the double

“bin/cgi/webrt.cgi/bin/cgi/webrt.cgi” ?

  • Lyle

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Pelcgb-serrqbz abj!


#3

Jesse wrote:

I suspect it’s that nobody actually knows the answer.
Do you run into this with other CGIs running under CGIWrap?
I’ve never seen nor touched cgi-wrap

Story of my life… I run into the tricky problems. I haven’t used CGIWrap
much myself, but I’ll look into it. I was hoping someone might be able to
point out a common error in an apache configuration that might do this (as
I’ve also not used apache much), or that it was a common misconfiguration of
RT. I’m assuming the RT login CGI is doing a post of the login data that it
gathers, and suspected that the path for the post is misconfigured (though I
don’t know how it might be).

  • Lyle

#4

Here’s a wild guess. :slight_smile:

Note the following line in the source (this bit was specificially snagged
from rt/lib/rt/ui/web/manipulate.pm, but it also appears in at least one
other place, admin.pm)

$ScriptURL=$ENV{‘SCRIPT_NAME’}.$ENV{‘PATH_INFO’};

ScriptURL is used so rt can point back at itself, obviously. Some (brief)
experimentation leads me to believe that PATH_INFO never gets set to
anything on my stock vanilla Apache install (no CGIWrap) on any of the
machines I’m in charge of. Maybe CGIWrap is setting PATH_INFO, so the
$Script_URL var is getting built incorrectly.

This reeks of cheephack, but try changing the definition of $ScriptURL
in the source to leave out the PATH_INFO env. variable.On Thu, Apr 05, 2001 at 05:32:28PM -0400, Jesse wrote:

I suspect it’s that nobody actually knows the answer.
Do you run into this with other CGIs running under CGIWrap?
I’ve never seen nor touched cgi-wrap

    jesse
Any clues on why I'm getting the double

“bin/cgi/webrt.cgi/bin/cgi/webrt.cgi” ?

  • Lyle

john.case@tenzing.com


#5

So you know, that will break RT’s ‘frames’ mode, which uses PATH_INFO to
determine if it’s enabled.

    -jOn Thu, Apr 05, 2001 at 04:18:03PM -0700, John Case wrote:

Here’s a wild guess. :slight_smile:

Note the following line in the source (this bit was specificially snagged
from rt/lib/rt/ui/web/manipulate.pm, but it also appears in at least one
other place, admin.pm)

$ScriptURL=$ENV{‘SCRIPT_NAME’}.$ENV{‘PATH_INFO’};

ScriptURL is used so rt can point back at itself, obviously. Some (brief)
experimentation leads me to believe that PATH_INFO never gets set to
anything on my stock vanilla Apache install (no CGIWrap) on any of the
machines I’m in charge of. Maybe CGIWrap is setting PATH_INFO, so the
$Script_URL var is getting built incorrectly.

This reeks of cheephack, but try changing the definition of $ScriptURL
in the source to leave out the PATH_INFO env. variable.

On Thu, Apr 05, 2001 at 05:32:28PM -0400, Jesse wrote:

I suspect it’s that nobody actually knows the answer.
Do you run into this with other CGIs running under CGIWrap?
I’ve never seen nor touched cgi-wrap

    jesse
Any clues on why I'm getting the double

“bin/cgi/webrt.cgi/bin/cgi/webrt.cgi” ?

  • Lyle


john.case@tenzing.com


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

<Dr_Memory> the point is that words were exchanged. neurolinguistic
programming will do the rest. they should be showing up at my house
any day now.


#6

Looks correct on both points. The “cheap hack” of truncating the
$ENV{‘PATH_INFO’} does indeed let me complete the login, and frames are indeed
broken.

  • Lyle

Jesse wrote: