Trouble getting RT to start in apache

Hello RT users,

I am very new to RT, need your help badly.

Here is my situation:
I installed all the Perl modules, installed RT 4.4.2 Beta releases, I can bring up the standalone server. But I can’t seem to see to start RT with apache. Here is my configuration:

### Optional apache logs for RT
ErrorLog /opt/RT/var/log/apache2.error
TransferLog /opt/RT/var/log/apache2.access
LogLevel debug

    AddDefaultCharset UTF-8

    DocumentRoot "/opt/RT/4.4.2/share/html"
    <Location />
        <IfVersion >= 2.4>
            Require all granted
        <IfVersion < 2.4>
            Order allow,deny
            Allow from all

        SetHandler modperl
        PerlResponseHandler Plack::Handler::Apache2
        PerlSetVar psgi_app /opt/RT/4.4.2/sbin/rt-server
        use Plack::Handler::Apache2;

I tried the fastgd configuration as well:


ErrorLog /opt/RT/var/log/apache2.error

TransferLog /opt/RT/var/log/apache2.access

LogLevel debug


AddDefaultCharset UTF-8

ScriptAlias / /opt/RT/4.4.2/sbin/rt-server.fcgi

# Unset since we are using /rt, DocumentRoot “/opt/RT/4.4.2/share/html/”

DocumentRoot “/opt/RT/4.4.2/share/html”

#= 2.4>

Require all granted


#<IfVersion < 2.4> # For Apache 2.2

# Order allow,deny

# Allow from all


Options +ExecCGI

#AddHandler fastcgi-script fcgi

AddHandler fcgid-script fcgi


when i type, I get nothing, blank page. apache error or access log does not report anything.

what am I doing wrong here? Below is my RTConfig file :

Set( $rtname, ‘myRT’);
Set($Organization, “”);
Set($CorrespondAddress, ‘hpc-request’);
Set($CommentAddress, ‘hpc-request’);
Set($WebDomain, “”);
Set($WebPort, 8080);
#Set($WebPath, “/rt”);
Set($Timezone, “US/Pacific”);
Set($DatabaseHost, “localhost”);
Set($DatabaseRTHost, “”);
Set($DatabasePassword, q{xxxxxxx});
Set($LogToSyslog, “error”);
Set($LogToSTDERR, “error”);
Set($OwnerEmail, ‘rtowner’);
Set($OverrideOutgoingMailFrom, {
‘Default’ => ‘’,
‘General’ => ‘’,

Please help!