Timezone and FreeBSD

Hi everyone,

You know, I’ve been having a problem ever since I first fired up RT, on
about 3 different FreeBSD systems. No matter what I do, the timezone in RT
always shows up as GMT. In config.pm, I’ve tried every possible combination
of entries for the time zone.

I’m running FreeBSD 4.4-STABLE. Any ideas, anyone? This is making me look
quite stupid to my bosses that I can’t figure this out. :frowning:

Thanks in advance!

-Rob.

Date: Thu, 15 Nov 2001 17:53:21 -0800
From: Rob Mitzel rmitzel@peer1.net
To: rt-users@lists.fsck.com
Subject: [rt-users] Timezone and FreeBSD

Hi everyone,

You know, I’ve been having a problem ever since I first fired up RT, on
about 3 different FreeBSD systems. No matter what I do, the timezone in RT
always shows up as GMT. In config.pm, I’ve tried every possible combination
of entries for the time zone.

I’m running FreeBSD 4.4-STABLE. Any ideas, anyone? This is making me look
quite stupid to my bosses that I can’t figure this out. :frowning:

Thanks in advance!

-Rob.

assuming that you want EST this will make fbsd happy:

$Timezone = ‘EST5EDT’;

see /usr/share/zoneinfo for others.

cheers,

Derek Marshall

Smash and Pow Inc > 'digital plumber’

[timezone issues]

I fixed a LOT of timezone issues by using the correct timezone
"Australia/New South Wales" instead of GMT+10.

The other thing that helped immensely was putting a ‘SetEnv’ directive in
my apache config file.

T�o de Hesselle, \ One possible reason that things
Unix Systems Administrator \ aren’t going according to plan
\ is that there never was a plan
University of Technology, Sydney \ in the first place.

You know, I’ve been having a problem ever since I first fired up RT,
on about 3 different FreeBSD systems. No matter what I do, the
timezone in RT always shows up as GMT. In config.pm, I’ve tried every
possible combination of entries for the time zone.

I’m running FreeBSD 4.4-STABLE. Any ideas, anyone? This is making me
look quite stupid to my bosses that I can’t figure this out. :frowning:

Are you running anything else under mod_perl? I had trouble with cricket
timestamps always showing as GMT because the time was set incorrectly in
RT, at one point. Fixing the time in RT fixed the time in cricket …

As cool as mod_perl is, I think fastcgi is probably a better way to go,
because of these weird pollution problems.

Charlie Watts
cewatts@frontier.net
Frontier Internet, Inc.
http://www.frontier.net/

“RM” == Rob Mitzel rmitzel@peer1.net writes:

RM> You know, I’ve been having a problem ever since I first fired up
RM> RT, on about 3 different FreeBSD systems. No matter what I do,
RM> the timezone in RT always shows up as GMT. In config.pm, I’ve
RM> tried every possible combination of entries for the time zone.

The comments say:

It should be set to a timezone recognized by your local unix box.

The default ‘US/Eastern’ is not so recognized by FreeBSD. Try
’EST5EDT’ or your equivalent in config.pm.

“CW” == Charlie Watts cewatts@frontier.net writes:

CW> As cool as mod_perl is, I think fastcgi is probably a better way to go,
CW> because of these weird pollution problems.

True, but the deeper issue here I think is the system date/time
libraries. Once initialized, you can’t change the timezone by simply
changing the TZ environment variable. So each process can only work
in one timezone – the one first specified. I think this might put a
kink in the plans to make the times appear local to the user depending
on the user’s preferences.

For my install, I have a private instantiation of Apache just for RT
running on a high-number port (with SSL enabled).

Derek,

That worked PERFECTLY!! Thank you!!

-Rob.