Time

This is going to seem like an asinine question… But, here goes. I
am running RT 2 on FreeBSD 4.5 (stable). I can’t get the time to post
correctly for the life of me! I have tried setting just about
everything in config.pm, $Timezone = ‘US/Pacific’;
Etc etc. The problem, as I understand it, is FreeBSD doesn’t recognize
the conventional use of Time Zone naming conventions. Or perhaps I
don’t understand the problem at all. In any case, has anyone tackled
this already? Or perhaps have something else I can try?

Thanks much,

Tyler Baker
Network Administrator
tbaker@swiftcomm.com

(This should probably go to rt-users, not -devel. Re-aiming.)

Tyler Baker wrote:

This is going to seem like an asinine question… But, here goes. I
am running RT 2 on FreeBSD 4.5 (stable). I can’t get the time to post
correctly for the life of me! I have tried setting just about
everything in config.pm, $Timezone = ‘US/Pacific’;
Etc etc. The problem, as I understand it, is FreeBSD doesn’t recognize
the conventional use of Time Zone naming conventions. Or perhaps I
don’t understand the problem at all. In any case, has anyone tackled
this already? Or perhaps have something else I can try?

Timezone is documented as:

It should be set to a timezone recognized by your local unix box.

You need to pick a timezone from under /usr/share/zoneinfo.

Thanks Phil.

Is there anything special I have to do to re-read config.pm? I have
modified it to a recognized zone (i.e. Pacific) in config.pm, and
unfortunately it has made no difference. I restarted apache for good
measure, but alas, I’m still on Eastern time.

(This should probably go to rt-users, not -devel. Re-aiming.)

Tyler Baker wrote:

This is going to seem like an asinine question… But, here goes.
I
am running RT 2 on FreeBSD 4.5 (stable). I can’t get the time to post
correctly for the life of me! I have tried setting just about
everything in config.pm, $Timezone = ‘US/Pacific’;
Etc etc. The problem, as I understand it, is FreeBSD doesn’t
recognize
the conventional use of Time Zone naming conventions. Or perhaps I
don’t understand the problem at all. In any case, has anyone tackled
this already? Or perhaps have something else I can try?

Timezone is documented as:

It should be set to a timezone recognized by your local unix box.

You need to pick a timezone from under /usr/share/zoneinfo.

rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

Did you stop and then start apache? Restart won’t cut it.

At 07:59 AM 5/30/2002 -0700, Tyler Baker wrote:

Is there anything special I have to do to re-read config.pm? I have
modified it to a recognized zone (i.e. Pacific) in config.pm, and
unfortunately it has made no difference. I restarted apache for good
measure, but alas, I’m still on Eastern time.

Russ Johnson
http://www.dimstar.net

Judge a man by his questions rather than his answers.
- Voltaire

Tyler Baker wrote:

Is there anything special I have to do to re-read config.pm? I have
modified it to a recognized zone (i.e. Pacific) in config.pm, and

“Pacific” isn’t a recognised timezone, either. It’s a directory.
So “Pacific/Auckland” would be valid, or “Pacific/Tahiti”, but
not “Pacific”.

(No, I don’t know US timezones enough to point you at the right one.
But it’s probably not under Pacific.)

unfortunately it has made no difference. I restarted apache for good
measure, but alas, I’m still on Eastern time.

Russ Johnson’s comment also stands:

Hi

how can I change the time which apper in the tickets to be the same as the time in the Linux machine?

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now