Ticket is not showing in the RT server

I tried to create a ticket in RT from postman using the following API
https://rt.reflectionsinfo.com//REST/1.0/ticket/new?user=akhilsiby&pass=password&content=Queue: SMGSubject: Test ticket Status:newRequestor:akhil.siby@reflectionsinfos.com

I got the response that the ticket is created and the ticket number also showed. But the ticket is not showing on the RT server. Also, I search for that ticket using the ticket id from the postman. But it’s not getting. Showing the error that you have no permission for viewing the ticket. Can someone please help me to solve this issue?

It means your RT user does not have enough rights within RT to view the newly created ticket. You can login as a superuser or have an RT admin grant more rights to your user so that you can see/edit/etc that new ticket

But I can see the tickets which I created directly in RT UI using these same credentials. This problem is happening only when I tried with POSTMAN using the api
I am adding the screenshots of ticket creation and searching for that particular ticket below

So if you go to ticket 22550 logged in as “akhilsiby” in the web UI you can view the ticket?

nop. 22550 is the ticket that I created from the postman. And I can’t see lt in RT UI.
I can see the only the tickets created directly from the UI

How do you grant “SeeTicket” for the queue that ticket is in?

If you’re using RT5.x and have access to the Admin interface to RT, you could try going to Admin->Tools->Rights Inspector and seeing if that shows the rights differences between the two tickets (assuming the tickets are in the same queue of course). Pop user:akhilsiby into the Principal filter, t:22550 into the Object column and see what rights you have from the system, queue and ticket. Then change the object filter to match a ticket you’ve created in the RT UI and see what rights that has.

I understood that not showing ticket in the RT server because of the Requestor name is (ie email) is not in the raised ticket. But I already send requestor details while creating the ticket. Still, it is not with the ticket.
Why it is happening so?. Can someone please help?
I am adding my ticket content below. MY RT version is 4.4.4

Queue: SMG

Subject: Test ticket

Status: new


You need a space after the “:”. For example, “https://your.rt/REST/1.0/ticket/new?user=USERNAME&pass=PASSWORD&content=Queue:+QUEUENAME%0ASubject:+SUBJECT%0AStatus:+new%0ARequestor:+test@test.test

Those “+” signs in the URL there are URL-encoded spaces (and %0A is a newline).