Ticket by email with several attachments


#1

Hello,

When creating a ticket with an attachment, it arrives correctly in RT.
But when there are several attachments no ticket is created…

Have you encountered this problem?
Thank you in advance for your answers

Best regards


#2

Hi

Does it happen if you mail in, as opposed to using the RT create page?

regards
Garry


#3

Thank you for your answer.

Only with requests by email.
Via the RT interface this works correctly.

regards.


#4

Do you have an attachment limit on your mail server?


#5

No, the only limitation is the maximum size of attachments (20 MB)

I can see the mail that arrived in the inbox of the account associated with RT but when reading it with POP, the ticket is not created in the queue


#6

Ah so your not mailing directly into RT, you’re using a mailbox and having RT pick it up from there?


#7

Yes, that’s right.
I have a main account and several aliases for the queues


#8

So are any of your aliases, ones that mail directly into RT, ratherthan to a mailbox? If so do they work with multiple attachements


#9

Hello,

Yes, with aliases that have multiple attachments, the ticket is not created.

regards.


#10

What do get in your mail logs? Is it set as multipart alternative?


#11

I have made progress on my problem.
I have created several".docx" files (11KB), it works within the 80KB limit…

The emails are well received in the RT box but no ticket creation afterwards


#12

Hi

What does the 80KB limit relate to?

regards
Garry


#13

I don’t know exactly, the email account (Zimbra) is correct (5GB quota) and the maximum size of attachments is 20MB.


#14

If you don’t know what the 80KB limit relates to, how do you know there’s an 80KB limit?


#15

I have performed several tests with 10 Kb files…
Do I have to define Set($MaxAttachmentSize)?


#16

Do you have $DropLongAttachments or $TruncateLongAttachments set or are you using Oracle as the database for RT? If you can say “no” for all of those the documentation says that the $MaxAttachmentSize setting is irrelevant.

If you create a single attachment with a size great than 80KB, does the ticket get created and the file attached to it OK? Checking this will let you (and us) know if the issue is the overall size of attachments on tickets, or the presence of multiple attachments.

Do you see anything in the RT or web server logs when RT tries to process an email with multiple attachments in it? If there’s nothing in there, have you tried (temporarily) increasing the RT log level to see if that provides any more tracing information?


#17

Hello,

Thank you for your answers.
1/ The answer is no, no definition of $DropLongAttachments or $TruncateLongAttachments and the base is mysql
2/ Several files whose overall size is less than about 100Kb => OK but only one file whose size is larger => non-OK
3/ I found this varning in the apache logs:
mod_fcgid: HTTP request length 134400 (so far) exceeds MaxRequestLen (131072)


#18

I finally found ! thanks to this post:
https://forum.bestpractical.com/t/problem-with-attachment-size-limits/

I have defined in my file “/etc/apache2/mods-enabled/fcgid.conf”:
FcgidMaxRequestLen 20000000

Now it works perfectly.

Thank you again for your help and answers