Themes?

Hi

I upgraded my RT installation to 3.8.1 and have now
completely lost all of the themes.

Can someone point out where I might be able to change
the setting( or configuration) to allow the use of
themes? In the preferences, I have set it to web2,
but at the moment, it only shows a non-graphical
RT interface.

I’m running Apache 2.0.54 with PHP 5.4.4.

Any help appreciated.

Edmund

Hi

I upgraded my RT installation to 3.8.1 and have now
completely lost all of the themes.

Can someone point out where I might be able to change
the setting( or configuration) to allow the use of
themes? In the preferences, I have set it to web2,
but at the moment, it only shows a non-graphical
RT interface.

I’m running Apache 2.0.54 with PHP 5.4.4.

This seems to be an apache/mod-perl/fastcgi configuration issue as you
doesn’t seems to be able to get static files (images, css).

Can you show us the relevant apache configuration?

Emmanuel Lacour wrote:

This seems to be an apache/mod-perl/fastcgi configuration issue as you
doesn’t seems to be able to get static files (images, css).

Can you show us the relevant apache configuration?

Here’s the configuration part of my apache

<VirtualHost *:80>
ServerName rt.localserver.local
DocumentRoot /var/rt3/share/html
<Directory /var/rt3/share/html/>
AllowOverride All
Options ExecCGI FollowSymLinks
Order allow,deny
Allow from all

AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /var/rt3/bin/webmux.pl

SetHandler perl-script
PerlHandler RT::Mason

Edmund

Emmanuel Lacour wrote:

This seems to be an apache/mod-perl/fastcgi configuration issue as you
doesn’t seems to be able to get static files (images, css).

Can you show us the relevant apache configuration?

Here’s the configuration part of my apache

I have more experience with fastcgi, but see my remarks:

<VirtualHost *:80>
ServerName rt.localserver.local
DocumentRoot /var/rt3/share/html

<Directory /var/rt3/share/html/>
AllowOverride All
Options ExecCGI FollowSymLinks

No need for ExecCGI theoritically.

  Order allow,deny
  Allow from all

AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /var/rt3/bin/webmux.pl

Try adding:

<Location /NoAuth/images>
        SetHandler default
</Location>

(but shouldn’t be needed)

SetHandler perl-script PerlHandler RT::Mason

Also, are-you sure that you have “Set($WebPath, “”);” in you’re
RT_SiteConfig.pm (and not Set($WebPath, “/rt”);)?

What happens (look also in apache logs) if you try to access
/NoAuth/css/web2/main-squished.css ?

Emmanuel Lacour wrote:

No need for ExecCGI theoritically.

I’ll remove it. :slight_smile:

Try adding:

<Location /NoAuth/images>
        SetHandler default
</Location>

Ok.

Also, are-you sure that you have “Set($WebPath, “”);” in you’re
RT_SiteConfig.pm (and not Set($WebPath, “/rt”);)?

In my RT_SiteConfig.pm, I don’t have a Set($WebPath,"");.

What happens (look also in apache logs) if you try to access
/NoAuth/css/web2/main-squished.css ?

I get an error:

Error during compilation of /var/rt3/share/html/NoAuth/css/dhandler:
Can’t locate CSS/Squish.pm in @INC (@INC contains:
/var/rt3/bin/…/local/lib /var/rt3/bin/…/lib
/usr/local/lib/perl5/5.8.6/i686-linux /usr/local/lib/perl5/5.8.6
/usr/local/lib/perl5/site_perl/5.8.6/i686-linux
/usr/local/lib/perl5/site_perl/5.8.6 /usr/local/lib/perl5/site_perl .
/var/www) at /var/rt3/share/html/NoAuth/css/dhandler line 67.

It seems as if this is the problem. It couldn’t find CSS::Squish.
I copied it from my 5.8.8 tree to the 5.8.6 and now it’s working!
(Ok, I admit. It is cheating a bit, since the 5.8.8 compilation
might not even work with 5.8.6, but apparently it does!)

Thanks Emmanuel for pointing that last part out. I don’t
think I would’ve figured that was the problem since none
of the errors was being shown in the logs.

Edmund