The Exchange Server <-> RT relationship

I’m sure I’m not the only one…

My primary email server here is Exchange 5.5. My rt machine lives at
rt.ciphergen.com. So I’ve setup “Custom Recipients” on my exchange server
for all my queues. This causes all internal mail sent to say ITSUPPORT to be
redirected to itsupport@rt.ciphergen.com. This custom recipient also
receives (and redirects to rt) mail to itsupport@ciphergen.com,
it_support@ciphergen.com, etc. My ITSUPPORT queue is setup to send mail as

The problem is in the email my internal users receive from RT. The message
is sent back with a header of say "From: “Joe via RT"
it_support@ciphergen.com”. I really like that “Joe via RT” part, tho I
think it should be “Joe via $QueueName” or some such thing rather then the
shameless RT plug. =)
Back to the problem. Outlook takes a look at the From: header and sees the
email address of it_support@ciphergen.com. Outlook being such a smart mail
client checks the Global Address List and finds this address associated with
my ITSUPPORT custom recipient. So it then displays From: ITSUPPORT rather
then From: Joe via RT.

James Satterfield

rt-users wrote:

Hi,

Von: James Satterfield [mailto:JSatterfield@ciphergen.com]
Bereitgestellt: Montag, 9. September 2002 23:08

I’m sure I’m not the only one…

My primary email server here is Exchange 5.5. My rt machine
lives at rt.ciphergen.com. So I’ve setup "Custom Recipients"
on my exchange server for all my queues. This causes all
internal mail sent to say ITSUPPORT to be redirected to
itsupport@rt.ciphergen.com. Outlook takes a look at the From: header
and sees the email address of it_support@ciphergen.com. Outlook being
such a smart mail client checks the Global Address List and
finds this address associated with my ITSUPPORT custom
recipient. So it then displays From: ITSUPPORT rather then
From: Joe via RT.

You could try to hide your custom recipient in the exchange address
book. Just a guess,

We had exactly the same problem, but it was provoked differently. All
worked happily for us for some time until our IT Dept upgraded our Trend

rt-users wrote:

Hi,

Von: James Satterfield [mailto:JSatterfield@ciphergen.com]
Bereitgestellt: Montag, 9. September 2002 23:08

I’m sure I’m not the only one…

My primary email server here is Exchange 5.5. My rt machine
lives at rt.ciphergen.com. So I’ve setup "Custom Recipients"
on my exchange server for all my queues. This causes all
internal mail sent to say ITSUPPORT to be redirected to
itsupport@rt.ciphergen.com. Outlook takes a look at the From: header
and sees the email address of it_support@ciphergen.com. Outlook being
such a smart mail client checks the Global Address List and
finds this address associated with my ITSUPPORT custom
recipient. So it then displays From: ITSUPPORT rather then
From: Joe via RT.

You could try to hide your custom recipient in the exchange address
book. Just a guess,

We had exactly the same problem, but it was provoked differently. All
worked happily for us for some time until our IT Dept upgraded our Trend
Scan Mail virus scanner and then our ‘via RT’ FROM stuff stopped working,
and it all came from the “real” from address.

After much prodding Trend produced the following registry key change which
their software upgrade apparently reset:

HKEY_LOCAL_MACHINE\system\Current Control Set\Services
MSExchangeIMC\Parameters :

   Reroute ViaStore key altered from 1 to 0

This may not work for you, but you could try it. Reboot required.

Neil.

Neil,
Thanks for the suggestion. I’ll give this a shot, but I’m a little wary of
the consequences it might bring. This registry setting allows incoming
internet mail to bypass the MTA. As most (if not all) exchange server virus
scanning agents scan at the MTA and not really at the IMC, this could cause
your anti-virus software to be useless when it comes to real time internet
mail scanning.
I can see how this may solve my From: problem, but perhaps at too great a
cost. I’ll do a bit of research and testing to see how my virus scanning
theory pans out.

Thanks for the idea. This registry setting hadn’t crossed my mind.
James.From: Neil Bingham [mailto:neil.bingham@pace.co.uk]
Sent: Tuesday, September 10, 2002 6:40 AM
To: rt-users@lists.fsck.com
Subject: RE: [rt-users] The Exchange Server <-> RT relationship.

rt-users wrote:

Hi,

Von: James Satterfield [mailto:JSatterfield@ciphergen.com]
Bereitgestellt: Montag, 9. September 2002 23:08

I’m sure I’m not the only one…

My primary email server here is Exchange 5.5. My rt machine lives at
rt.ciphergen.com. So I’ve setup “Custom Recipients” on my exchange
server for all my queues. This causes all internal mail sent to say
ITSUPPORT to be redirected to itsupport@rt.ciphergen.com. Outlook
takes a look at the From: header and sees the email address of
it_support@ciphergen.com. Outlook being such a smart mail client
checks the Global Address List and finds this address associated with
my ITSUPPORT custom recipient. So it then displays From: ITSUPPORT
rather then
From: Joe via RT.

You could try to hide your custom recipient in the exchange address
book. Just a guess,

We had exactly the same problem, but it was provoked differently. All
worked happily for us for some time until our IT Dept upgraded our Trend
Scan Mail virus scanner and then our ‘via RT’ FROM stuff stopped working,
and it all came from the “real” from address.

After much prodding Trend produced the following registry key change which
their software upgrade apparently reset:

HKEY_LOCAL_MACHINE\system\Current Control Set\Services
MSExchangeIMC\Parameters :

   Reroute ViaStore key altered from 1 to 0

This may not work for you, but you could try it. Reboot required.

Neil.
rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm