The actual HTTP_HOST does NOT match the configured WebDomain

I’m trying to set up the email gateway on my shiny new install of 4.0.2.
I think I have everything set up correctly, except that the email never
gets there and I get this error in the apache log files:

[Wed Sep 7 20:16:02 2011] [warn]: The actual HTTP_HOST (tracker) does NOT
match the configured WebDomain (xxx.xxx.xxx). Perhaps you should
Set($WebDomain, ‘tracker’); in RT_SiteConfig.pm, otherwise your internal
links may be broken. (/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:1087)

I’m not sure where the system is picking up ‘tracker’ for HTTP_HOST so I’m
at a loss on how to change it to the correct hostname.

exim4 says:

2011-09-07 13:15:59 1R1OXP-0001FT-85 == |/opt/rt4/bin/rt-mailgate --queue
General --action correspond --url http://rt.subutil.com
rt-email@rt.subutil.com R=system_aliases T=address_pipe defer (0): Child
process of address_pipe transport returned 75 (could mean temporary error)
from command: /opt/rt4/bin/rt-mailgate

How do I go about changing the HTTP_HOST for rt?

In 2012 we get to choose whether to throw out the baby with the bathwater,
deny that the baby needs a bath, or have the government pay for the baby
and the bathwater.

I’m trying to set up the email gateway on my shiny new install of 4.0.2.
I think I have everything set up correctly, except that the email never
gets there and I get this error in the apache log files:

[Wed Sep 7 20:16:02 2011] [warn]: The actual HTTP_HOST (tracker) does NOT
match the configured WebDomain (xxx.xxx.xxx). Perhaps you should
Set($WebDomain, ‘tracker’); in RT_SiteConfig.pm, otherwise your internal
links may be broken. (/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:1087)

This is a warning, and shouldn’t stop rt-mailgate. You probably want
to post all of the log messages.

What this message is saying is that you’ve set your WebDomain in your
config to xxx.xxx.xxx but someone is connecting to the machine as
’tracker’ and this may cause problems. From your rt-mailgate
invocation below, I’m guessing it isn’t caused by the mailgate, unless
you’re proxying things.

-kevin

I’m trying to set up the email gateway on my shiny new install of 4.0.2.
I think I have everything set up correctly, except that the email never
gets there and I get this error in the apache log files:

[Wed Sep 7 20:16:02 2011] [warn]: The actual HTTP_HOST (tracker) does
NOT
match the configured WebDomain (xxx.xxx.xxx). Perhaps you should
Set($WebDomain, ‘tracker’); in RT_SiteConfig.pm, otherwise your internal
links may be broken. (/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:1087)

This is a warning, and shouldn’t stop rt-mailgate. You probably want
to post all of the log messages.

What this message is saying is that you’ve set your WebDomain in your
config to xxx.xxx.xxx but someone is connecting to the machine as
’tracker’ and this may cause problems. From your rt-mailgate
invocation below, I’m guessing it isn’t caused by the mailgate, unless
you’re proxying things.

All of this is happening on the same machine. I am using the mail command
to send mail to the mailgate on the same host, so no proxying.

Where and how do I enable logging to see more details? What I posted is
all I’m getting. I get nothing else in the logs pertaining to the
warning; the email just doesn’t show up. I have allowed ticket creation
for everyone.

All of this is happening on the same machine. I am using the mail
command to send mail to the mailgate on the same host, so no proxying.

Never mind… Turned out to be a stale DNS cache issue…
http://localhost works; http://canonical.name doesn’t…