Strange issue with fetchmail rewriting addresses

Greetings, all!

I’m having the weirdest problem, I’m hoping someone can please help me. I’m
working on setting up RT on SuSE 9.3, apache 2, mysql and pulling down mail
from MS Exchange via POP using fetchmail and procmail to pump it into RT.
My MTA is postfix.

My organization currently uses simple dlists to distribute mail coming into
our organization to addresses like “support@” and “sales@”. We’re growing,
so we’re looking at a more sophisticated method, hence RT.

So, I set up a single Exchange account which I called
mailto:rt@mycompany.com rt@mycompany.com. To it, I added aliases for
teseting like mailto:rtsales@mycompany.com rtsales@mycompany.com,
mailto:rtsales-comment@mycompany.com rtsales-comment@mycompany.com, and
the same for support (rtsupport, etc).

Everything worked flawlessly. Mail set to rtsales would be successfully
pulled down via fetchmail and imported into RT via procmail.

This weekend I attempted to cutover to production using the real addresses
"sales@" and “support@”. So I deleted the old dlists and added “sales@” and
"support@" to the alias for the Exchange user so fetchmail would pull down
the mail. I modified my .procmailrc to specify the correct regexes for
sales and support (just removing the prefixed ‘rt’s from ‘rtsales’ and
’rtsupport’). I logged into RT and reconfigured the queues so that their
Reply Addresses and Comment Addresses were set appropriately.

And then something weird started happening.

Fetchmail would pull down the email, but in doing so would rewrite the email
headers changing the To: field from sales@mycompany.com into
sales@mylinuxbox.myotherdomain.com. And the regexes for procmail failed,
and the mail sat in the rt linux user’s mailbox.

But if I send email to rtsales@mycompany.com, it still comes through fine,
and doesn’t get rewritten!

I have no “sales” or “support” linux users on my linux box. I can’t
understand why fetchmail would want to rewrite those addresses.

I’m not a fetchmail expert, or a linux mail expert for that matter. Is
there some setting somewhere that would explain why fetchmail is rewriting
only certain addresses?

Thanks,

Larry