Sperl vs. suidperl

Hi RTUsers,

sorry, it’s me again.

I have under /usr/bin two files

sperl5.6.0 and
suidperl

both same in size and date - and they’re not symlinked.
Which s*perl is used?

And another one: yast (SuSE 7.1) is always killing the suid
flag … any good idea to work around that?

Cheers,

Vince

‘’'
���

Hi,

I have under /usr/bin two files
sperl5.6.0 and
suidperl
both same in size and date - and they’re not symlinked.
They are identical, and can be attributed to the superlative German engineering brought to us by SuSE!!
Which s*perl is used?
To leave them is no harm, and saves you the trouble of searching it out :slight_smile:
An interesting question. I just noticed that the last access time for both of mine is identical.

And another one: yast (SuSE 7.1) is always killing the suid
flag … any good idea to work around that?
Set-
PERMISSION_SECURITY="easy local"
in your /etc/rc.config and this should do it; I believe this is the cause.
If this breaks other permissions you need then you are looking at creating a custom solution. But that shouldn’t be too hard, after all the /etc/permissions file looks pretty editable.

Regards, Harold

| I have under /usr/bin two files
|
| sperl5.6.0 and
| suidperl
|
| both same in size and date - and they’re not symlinked.
| Which s*perl is used?
±–>8

That’d be becaause they’re hard links.

“suidperl” will always be the “current” version of Perl. Given that
mod_perl is version-dependent, I’d use the other one instead.

| And another one: yast (SuSE 7.1) is always killing the suid
| flag … any good idea to work around that?
±–>8

Edit /etc/permissions to set the appropriate permissions; SuSE 7.x is more
paranoid than earlier releases and resets permissions on suid files not in
/etc/permissions whenever /sbin/SuSEconfig runs. (Which would be less of a
problem if it actually honored PERMISSION_SECURITY in /etc/rc.config so you
could add the correct permissions to /etc/permissions.local and not have
them be overwritten when aaa_base is upgraded…)

brandon s. allbery [os/2][linux][solaris][freebsd] allbery@kf8nh.apk.net
system administrator [JAPH][WAY too many hats] allbery@ece.cmu.edu
electrical and computer engineering KF8NH
carnegie mellon university [linux: proof of the million monkeys theory]

“Brandon S. Allbery KF8NH” wrote:

±----
| I have under /usr/bin two files
|
| sperl5.6.0 and
| suidperl
|
| both same in size and date - and they’re not symlinked.
| Which s*perl is used?
±–>8

That’d be becaause they’re hard links.

“suidperl” will always be the “current” version of Perl. Given that
mod_perl is version-dependent, I’d use the other one instead.

| And another one: yast (SuSE 7.1) is always killing the suid
| flag … any good idea to work around that?
±–>8

edit /etc/permissions.easy . suidperl is set to 0755 by default (for security
reasons - if You don’t need it, break it (-: )
change the entry on line 247 (true for SuSE 7.2) to reflect You know what You’re
doing (i.e., change the 0755 to 4755).

Don’t forget to change the permissions on the binaries as well.

Regards,
Harald

Harald Wagener | Systemadministrator
FCB/Wilkens GmbH | Tel.:+49-40-2881-1252
An der Alster 42 | Fax.:+49-40-2881-1263
20099 Hamburg | http://www.fcb-wilkens.com