Source code display for html attachment

Hello,
We have got RT(3.8.1 and 3.8.2) on linux
machine(centos).
When we send a html attachement with a ticket, it
is display as text (the source code) in it.

To resolve that we have to record the html file
with UTF-8 encodage selected. This is not always possible, and it makes longer the ticket resolution process.

Thank you for your help

William

Hello,
We have got RT(3.8.1 and 3.8.2) on linux machine(centos).
When we send a html attachement with a ticket, it is display as text (the source code) in it.

To resolve that we have to record the html file with UTF-8 encodage selected. This is not
always possible, and it makes longer the ticket resolution process.

Sounds like you missed TrustHTMLAttachments and other config options.

-kevin

Helle,
Thank you for your suggestion, but i already test it and it didn’t work.
I tried this in vain:

– update EmailInputEncodings

utf-8, iso-8859-1, us-ascii
to EmailInputEncodings iso-8859-1, utf-8, us-ascii
– SET TrustHTMLAttachments to true
– comment adddefaultcharset UTF-8 on httpd.conf

here is my file RT_SiteConfig.pm

Hello,
We have got RT(3.8.1 and 3.8.2) on linux machine(centos).
When we send a html attachement with a ticket, it is display as text (the source code) in it.

To resolve that we have to record the html file with UTF-8 encodage selected. This is not
always possible, and it makes longer the ticket resolution process.

Sounds like you missed TrustHTMLAttachments and other config options.

Regars
William

-kevin

Hello,
We have got RT(3.8.1 and 3.8.2) on linux machine(centos).
When we send a html attachement with a ticket, it is display as text (the source code) in it.

To resolve that we have to record the html file with UTF-8 encodage selected. This is not
always possible, and it makes longer the ticket resolution process.

Sounds like you missed TrustHTMLAttachments and other config options.

-kevinDe: jet jet jettejpopi@yahoo.fr
Objet: Source code display for html attachment
À: "rt-users@lists.bestpractical.com" rt-users@lists.bestpractical.com
Date: Mardi 9 Février 2010, 10h31

Hello,
We have got RT(3.8.1 and 3.8.2) on linux
machine(centos).
When we send a html attachement with a ticket, it
is display as text (the source code) in it.

To resolve that we have to record the html file
with UTF-8 encodage selected. This is not always possible, and it makes longer the ticket resolution process.

Thank you for your help

William

Here is the error i found in httpd logs:

[Thu Feb 11 18:17:51 2010] [error]: Encoding error: UTF-16:Unrecognised BOM 3c at /usr/lib/perl5/5.10.0/i386-linux-thread-multi/Encode.pm line 182.

Stack:
[/usr/lib/perl5/5.10.0/i386-linux-thread-multi/Encode.pm:182]
[/usr/lib/perl5/vendor_perl/5.10.0/RT/I18N.pm:235]
[/usr/lib/perl5/vendor_perl/5.10.0/RT/I18N.pm:153]
[/usr/lib/perl5/vendor_perl/5.10.0/RT/Interface/Web.pm:836]
[/usr/share/rt3/html/Ticket/Update.html:217]
[/usr/share/rt3/html/autohandler:311]
defaulting to ISO-8859-1 -> UTF-8 (/usr/lib/perl5/vendor_perl/5.10.0/RT/I18N.pm:239)

Regards
WilliamDate: Thu, 11 Feb 2010 15:28:52 +0000 (GMT)
From: jet jet jettejpopi@yahoo.fr
Subject: [rt-users] Source code display for html attachment
To: "rt-users@lists.bestpractical.com"
rt-users@lists.bestpractical.com
Message-ID: 512692.64331.qm@web28605.mail.ukl.yahoo.com
Content-Type: text/plain; charset=“iso-8859-1”

Helle,
Thank you for your suggestion, but i already test it and it didn’t work.
I tried this in vain:

– update EmailInputEncodings

utf-8, iso-8859-1, us-ascii
to EmailInputEncodings iso-8859-1, utf-8, us-ascii

– SET TrustHTMLAttachments to true
– comment adddefaultcharset UTF-8 on httpd.conf

here is my file RT_SiteConfig.pm

Hello,
We have got RT(3.8.1 and 3.8.2) on linux machine(centos).
When we send a html attachement with a ticket, it is display as text (the source code) in it.

To resolve that we have to record the html file with UTF-8 encodage selected. This is not
always possible, and it makes longer the ticket resolution process.

Sounds like you missed TrustHTMLAttachments and other config options.

Regars
William

-kevin

Hello,
We have got RT(3.8.1 and 3.8.2) on linux machine(centos).
When we send a html attachement with a ticket, it is display as text (the source code) in it.

To resolve that we have to record the html file with UTF-8 encodage selected. This is not
always possible, and it makes longer the ticket resolution process.

Sounds like you missed TrustHTMLAttachments and other config options.

-kevin

De: jet jet jettejpopi@yahoo.fr
Objet: Source code display for html attachment
?: "rt-users@lists.bestpractical.com" rt-users@lists.bestpractical.com
Date: Mardi 9 F?vrier 2010, 10h31

Hello,
We have got RT(3.8.1 and 3.8.2) on linux
machine(centos).
When we?send a html?attachement?with a ticket, it
is display as text (the source code) in it.

To resolve that we have to record the html file
with UTF-8 encodage selected. This is not always possible, and it makes longer the ticket resolution process.
?
Thank you for your help

William

-------------- next part --------------
An HTML attachment was scrubbed…
URL: http://lists.bestpractical.com/pipermail/rt-users/attachments/20100211/95d17843/attachment.html

RT-Users mailing list
RT-Users@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

End of RT-Users Digest, Vol 71, Issue 28