Something wrong using rt-mailgate

My mail pipe is failing with a 500 error for some reason. If I GET GET
http://rt.domain.com/REST/1.0/NoAuth/mail-gateway on a working RT
install I get:
okTicket: 5Queue: GeneralOwner: NobodyStatus: newSubject: Requestor:

However when I GET http://rt.domain.com/REST/1.0/NoAuth/mail-gateway on
my own rt install I get a 500 error. Does anyone have any suggestions on
why this may be happening? I’m getting desperate here.

-steven

steven collins wrote:

My mail pipe is failing with a 500 error for some reason. If I GET GET
http://rt.domain.com/REST/1.0/NoAuth/mail-gateway on a working RT
install I get:
okTicket: 5Queue: GeneralOwner: NobodyStatus: newSubject: Requestor:

However when I GET http://rt.domain.com/REST/1.0/NoAuth/mail-gateway on
my own rt install I get a 500 error. Does anyone have any suggestions on
why this may be happening? I’m getting desperate here.

What’s in your apache error log? What’s in your /var/log/messages?

Jesse

signature.asc (189 Bytes)

steven collins wrote:

My mail pipe is failing with a 500 error for some reason. If I GET GET
http://rt.domain.com/REST/1.0/NoAuth/mail-gateway on a working RT
install I get:
okTicket: 5Queue: GeneralOwner: NobodyStatus: newSubject: Requestor:

However when I GET http://rt.domain.com/REST/1.0/NoAuth/mail-gateway on
my own rt install I get a 500 error. Does anyone have any suggestions on
why this may be happening? I’m getting desperate here.

What’s in your apache error log? What’s in your /var/log/messages?

Jesse

Here is (a slightly) edited snip from my error log:

[Wed Jan 25 09:23:43 2006] [error] [client 24.11.153.198] FastCGI:
server “/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi” stderr:
Callback called exit.
[Wed Jan 25 09:23:43 2006] [error] [client 24.11.153.198] FastCGI:
server “/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi” stderr:
Callback called exit.
[Wed Jan 25 09:23:43 2006] [error] [client 24.11.153.198] FastCGI:
incomplete headers (0 bytes) received from server
"/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi"
[Wed Jan 25 09:23:43 2006] [warn] FastCGI: server
"/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi" (pid 7540)
terminated by calling exit with status ‘12’
[Wed Jan 25 09:23:43 2006] [warn] FastCGI: server
"/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi" has remained
running for more than 30 seconds, its restart interval has been restored
to 5 seconds
[Wed Jan 25 09:23:43 2006] [warn] FastCGI: server
"/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi" (uid 1007, gid
1007) restarted (pid 18649) Out of memory!
Out of memory!
[Wed Jan 25 09:23:53 2006] [error] [client 24.11.153.198] FastCGI:
server “/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi” stderr:
Callback called exit.
[Wed Jan 25 09:23:53 2006] [error] [client 24.11.153.198] FastCGI:
server “/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi” stderr:
Callback called exit.
[Wed Jan 25 09:23:53 2006] [error] [client 24.11.153.198] FastCGI:
incomplete headers (0 bytes) received from server
"/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi"
[Wed Jan 25 09:23:53 2006] [warn] FastCGI: server
"/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi" (pid 7546)
terminated by calling exit with status ‘12’
[Wed Jan 25 09:23:53 2006] [warn] FastCGI: server
"/var/www/rt.domain.com/rt-3.4.5/bin/mason_handler.fcgi" (uid 1007, gid
1007) restarted (pid 21391)

The two puzzling parts are “incomplete headers (0 bytes) received from
server” and “Out of memory!”. The server has plenty of memory. I’m not
running SElinux or any sort of memory limiter that I’m aware of. The
kernel is compiled with 4G high mem support as well.

-steven