Something was missing!

Hi

Im trying to upgrade to version 3.6.0 from 3.4.5 and in trying to install
all the perl dependencies I keep getting the following error which I presume
is about Test::Expect but as you can see when it tries to install it, it
finds that it is already installed. I just really wanted to know if its safe
to still proceed as Ive put the upgrade on hold for the moment.

/home/test/rt-3.6.0# ./sbin/rt-test-dependencies -with-mysql -v --install

perl:

    >=5.8.3(5.008004)...found

users:

    rt group (rt)...found

    bin owner (root)...found

    libs owner (root)...found

    libs group (bin)...found

    web owner (www-data)...found

    web group (rt3)...found

MASON dependencies:

    Params::Validate >=0.02...found

    Cache::Cache...found

    Exception::Class >=1.14...found

    HTML::Mason >=1.23...found

    MLDBM...found

    Errno...found

    FreezeThaw...found

    Digest::MD5 >=2.27...found

    CGI::Cookie >=1.20...found

    Storable >=2.08...found

    Apache::Session >=1.53...found

    XML::RSS >=1.05...found

    HTTP::Server::Simple >=0.07...found

    HTTP::Server::Simple::Mason >=0.09...found

    GD...found

    GD::Graph...found

    GD::Text...found

    Text::WikiFormat >=0.76...found

CLI dependencies:

    Getopt::Long >=2.24...found

DEV dependencies:

    Regexp::Common...found

    Test::Inline...found

    Apache::Test...found

    HTML::Form...found

    HTML::TokeParser...found

    WWW::Mechanize...found

    Test::WWW::Mechanize >=1.04...found

    Module::Refresh >=0.03...found

    Test::Expect 0.30...MISSING

Install module Test::Expect

CPAN: File::HomeDir loaded ok

Going to read /root/.cpan/Metadata

Database was generated on Thu, 06 Jul 2006 09:29:08 GMT

Test::Expect is up to date (0.30).

MYSQL dependencies:

    DBD::mysql >=2.1018...found

MAILGATE dependencies:

    HTML::TreeBuilder...found

    HTML::FormatText...found

    Getopt::Long...found

    LWP::UserAgent...found

CORE dependencies:

    Calendar::Simple...found

    Digest::base...found

    Digest::MD5 >=2.27...found

    DBI >=1.37...found

    Test::Inline...found

    Class::ReturnValue >=0.40...found

    DBIx::SearchBuilder >=1.39...found

    Text::Template...found

    File::Spec >=0.8...found

    HTML::Entities...found

    HTML::Scrubber >=0.08...found

    Net::Domain...found

    Log::Dispatch >=2.0...found

    Locale::Maketext >=1.06...found

    Locale::Maketext::Lexicon >=0.32...found

    Locale::Maketext::Fuzzy...found

    MIME::Entity >=5.108...found

    Mail::Mailer >=1.57...found

    Net::SMTP...found

    Text::Wrapper...found

    Time::ParseDate...found

    Time::HiRes...found

    File::Temp...found

    Term::ReadKey...found

    Text::Autoformat...found

    Text::Quoted >=1.3...found

    Tree::Simple >=1.04...found

    Scalar::Util...found

    Module::Versions::Report...found

    Cache::Simple::TimedExpiry...found

    XML::Simple...found

    Calendar::Simple...found

SOMETHING WAS MISSING!

Looks like your test died before it could output anything.

What I’ve found is that if you have a newer version that it usually
doesn’t matter. I had the same problem with XML::RSS. Make testdeps
wouldn’t find v1.05 however, I have v1.10 installed. Everything still
worked as expected.

I suspect that some items are hard-coded for a particular version and
ignore anything other than that one version. If you have a newer
version installed, chances are it will still work.

Mathew

Brent Geach wrote:

Hi

Im trying to upgrade to version 3.6.0 from 3.4.5 and in trying to
install all the perl dependencies I keep getting the following error
which I presume is about Test::Expect but as you can see when it tries
to install it, it finds that it is already installed. I just really
wanted to know if its safe to still proceed as Ive put the upgrade on
hold for the moment.

/home/test/rt-3.6.0# ./sbin/rt-test-dependencies -with-mysql -v --install

perl:

    >=5.8.3(5.008004)...found

users:

    rt group (rt)...found

    bin owner (root)...found

    libs owner (root)...found

    libs group (bin)...found

    web owner (www-data)...found

    web group (rt3)...found

MASON dependencies:

    Params::Validate >=0.02...found

    Cache::Cache...found

    Exception::Class >=1.14...found

    HTML::Mason >=1.23...found

    MLDBM...found

    Errno...found

    FreezeThaw...found

    Digest::MD5 >=2.27...found

    CGI::Cookie >=1.20...found

    Storable >=2.08...found

    Apache::Session >=1.53...found

    XML::RSS >=1.05...found

    HTTP::Server::Simple >=0.07...found

    HTTP::Server::Simple::Mason >=0.09...found

    GD...found

    GD::Graph...found

    GD::Text...found

    Text::WikiFormat >=0.76...found

CLI dependencies:

    Getopt::Long >=2.24...found

DEV dependencies:

    Regexp::Common...found

    Test::Inline...found

    Apache::Test...found

    HTML::Form...found

    HTML::TokeParser...found

    WWW::Mechanize...found

    Test::WWW::Mechanize >=1.04...found

    Module::Refresh >=0.03...found

    Test::Expect 0.30...MISSING

Install module Test::Expect

CPAN: File::HomeDir loaded ok

Going to read /root/.cpan/Metadata

Database was generated on Thu, 06 Jul 2006 09:29:08 GMT

Test::Expect is up to date (0.30).

MYSQL dependencies:

    DBD::mysql >=2.1018...found

MAILGATE dependencies:

    HTML::TreeBuilder...found

    HTML::FormatText...found

    Getopt::Long...found

    LWP::UserAgent...found

CORE dependencies:

    Calendar::Simple...found

    Digest::base...found

    Digest::MD5 >=2.27...found

    DBI >=1.37...found

    Test::Inline...found

    Class::ReturnValue >=0.40...found

    DBIx::SearchBuilder >=1.39...found

    Text::Template...found

    File::Spec >=0.8...found

    HTML::Entities...found

    HTML::Scrubber >=0.08...found

    Net::Domain...found

    Log::Dispatch >=2.0...found

    Locale::Maketext >=1.06...found

    Locale::Maketext::Lexicon >=0.32...found

    Locale::Maketext::Fuzzy...found

    MIME::Entity >=5.108...found

    Mail::Mailer >=1.57...found

    Net::SMTP...found

    Text::Wrapper...found

    Time::ParseDate...found

    Time::HiRes...found

    File::Temp...found

    Term::ReadKey...found

    Text::Autoformat...found

    Text::Quoted >=1.3...found

    Tree::Simple >=1.04...found

    Scalar::Util...found

    Module::Versions::Report...found

    Cache::Simple::TimedExpiry...found

    XML::Simple...found

    Calendar::Simple...found

SOMETHING WAS MISSING!

Looks like your test died before it could output anything.



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

If we don’t protect freedom of speech, how will we know who the assholes
are?

What I’ve found is that if you have a newer version that it usually
doesn’t matter. I had the same problem with XML::RSS. Make testdeps
wouldn’t find v1.05 however, I have v1.10 installed. Everything still
worked as expected.

I had some similar problems. I don’t remember exactly what I did…
futz around until it worked. Didn’t seem too hard… until I updated
way too many packages on my netbsd system (en masse) and it choked big
time!