Some Assistance Please!

So we have a fresh install of 4.4.4 on CentOS. I understand that it comes with Postfix already installed, but we use an existing MTA to handle all mail delivery, so all I want to be able to do is relay inbound/outbound email from this server to our current SMTP box. That said, I can’t find any documentation here on how to configure postfix to simply relay…HELP!

Postfix makes it super easy to use an external SMTP relay, the config is actually just need this config value in your Postfix config ( Using gmail as the example SMTP server ):

 relayhost =

And then you may need to set-up a sasl_passwd file and the config options to use that password auth. Some examples can be found in this link I found with a quick search:

Thanks for the info Knation……I am relatively new to Linux distros so it takes me some playing to work through stuff. Fairly straight forward once I set my hostname and relayhost parameters! I tested on a ticket and received and email notification as expected. When I reply to the ticket however, it doesn’t update the ticket, nor generate another email notice. I suspect this is a result of not creating aliases for each of my queues? Where would I place those?

The aliases file is located usually at “/etc/aliases” and you need to run newaliases command after updating that file.

You need to add something like this from the README:

rt:  "|/opt/rt5/bin/rt-mailgate --queue general --action correspond --url"

I’d also watch your postfix mail logs sometimes located “/var/logs/mail.log” to ensure that the email is actually reaching your RT server.

so do I need to create that file beforehand or is it created by the rt-mailgate script? When I checked that directory, it wasn’t there

I believe installing postfix may make the file by default. You can check the postfix config and look for a reference to the aliases file to see where it points.

Basically Postfix gets an email in “” and looks at the aliases file for what to do with the user “rt”.

The line above says pipe “rt” users emails into RT.

It appears my postfix config already has the default entries of

alias_maps = hash:/etc/aliases

as well as

alias_database = hash:/etc/aliases

Yet no specific alias or aliases file exists there. So I’m assuming if I create the file there then it should work

Just not sure whether it’s supposed to be a standard text file

I think it can just be a normal text file, nothing shows up if you do vi /etc/aliases?

Ok…added the following to my aliases

ServerAdmin: /opt/rt4/bin/rt-mailgate --queue ServerAdmin --action reply --url

Creating the ticket works fine, but reply to that notification yields a bounceback

This is the mail system at host

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<>: cannot append message to file
/opt/rt4/bin/rt-mailgate: cannot open file: Permission denied

<>: bad recipient address syntax:

<>: unknown user: “serveradmin”

<>: bad recipient address syntax:

<> (expanded from <>): unknown
user: “reply”

You’re missing quotes around everything after “ServerAdmin:”

I must be missing something with the syntax, still getting

<>: cannot append message to file
/opt/rt4/bin/rt-mailgate --queue ServerAdmin --action reply --url cannot create file exclusively: No such file or

Should be:

ServerAdmin: "|/opt/rt4/bin/rt-mailgate --queue ServerAdmin --action reply --url"

The pipe “|” is crucial to tell the mailsystem that you’re feeding it to a program.

the missing pipe was a problem for sure! That said, I’m now at this scenario…I can send an email to the queue ServerAdmin and it creates the ticket as well as generates an email notification to me

With the changes made to the alias file, I can reply to that notification, and I would expect it to update the ticket with my reply text.

I no longer get an error on attempting to reply, but it also doesn’t update the ticket with my additional text
I have both the Reply and Comment fields for the queue populated with ServerAdmin@myserver.mydomain

also I have nothing being logged in my maillog for some reason

Check your RT log, I’d guess you do not have the right to reply to the ticket

Issues were somehow caused by my system flipping from a static IP to DHCP. Explains why postfix wasn’t running and maillog wasn’t collecting etc. Fixed the network problem, but now I seem to have run into another snag. Generating a ticket (which was working) by email generates the following

nothing in the webserver logs to indicate a problem either. And I tried passing the --no-verify-ssl parameter thinking it may have been the cert