SLA not getting applied applied automatically

I have set the SLA in the RT_siteconfig file for the specific queue, but it is not getting applied to the tickets. While Creating the ticket using RT web, the SLA option is not selected automatically, instead we have to select it manually. Please help me with this.
Do I need to configure any other things to make it work?