Silent Resolve / Quiet Resolve RT 3.4.0

Hi

I am hoping someone can point me in the right direction to enable Silent
Resolve in RT 3.4.0. (send no email to requestor on resolve)

At the moment I have modified “On Resolve with template Resolved” under
Global > Scrips and changed the Action and Template pulldowns to “-” which I
assume is similiar to “do nothing”

Is this all that needs to be done, as it does work but I now notice the
following in my syslog when a ticket is resolved.

It looks as if its erroring because its still trying to locate a .pm but
being that I changed it to “-” in the pulldowns it is now empty.

Any ideas?

Regards
Kris

Apr 5 18:01:36 thewebshed RT: About to think about scrips for transaction
#10935
Apr 5 18:01:36 thewebshed RT: About to prepare scrips for transaction
#10935
Apr 5 18:01:36 thewebshed RT: Found 2 scrips
Apr 5 18:01:36 thewebshed RT: Scrip Prepare 10 died. - Require of
RT::Action:: failed. Can’t locate RT/Action/.pm in @INC (@INC contains:
/opt/rt3/local/lib /opt/rt3/lib
/usr/local/lib/perl5/site_perl/5.8.5/i386-freebsd-64int
/usr/local/lib/perl5/site_perl/5.8.5/mach
/usr/local/lib/perl5/site_perl/5.8.5 /usr/local/lib/perl5/site_perl
/usr/local/lib/perl5/5.8.5/BSDPAN /usr/local/lib/perl5/5.8.5/mach
/usr/local/lib/perl5/5.8.5 . /usr/local/ /usr/local/lib/perl) at (eval 7156)
line 3. Stack: [(eval 7156):3] [/opt/rt3/lib/RT/Scrip_Overlay.pm:472]
[/opt/rt3/lib/RT/Scrips_Overlay.pm:235]
[/opt/rt3/lib/RT/Transaction_Overlay.pm:160]
[/opt/rt3/lib/RT/Record.pm:1373] [/opt/rt3/lib/RT/Ticket_Overlay.pm:3439]
[/opt/rt3/lib/RT/Ticket_Overlay.pm:3176] [/opt/rt3/lib/RT/Record.pm:873]
[/opt/rt3/lib/RT/Interface/Web.pm:933]
[/opt/rt3/lib/RT/Interface/Web.pm:1047]
[/opt/rt3/share/html/Ticket/Display.html:140]
[/opt/rt3/share/html/Ticket/Update.html:211]
[/opt/rt3/share/html/autohandler:215] Stack: [/opt/rt3/lib/RT/Sc
Apr 5 18:01:36 thewebshed /kernel: Apr 5 18:01:36 thewebshed RT: Scrip
Prepare 10 died. - Require of RT::Action:: failed. Can’t locate
RT/Action/.pm in @INC (@INC contains: /opt/rt3/local/lib /opt/rt3/lib
/usr/local/lib/perl5/site_perl/5.8.5/i386-freebsd-64int
/usr/local/lib/perl5/site_perl/5.8.5/mach
/usr/local/lib/perl5/site_perl/5.8.5 /usr/local/lib/perl5/site_perl
/usr/local/lib/perl5/5.8.5/BSDPAN /usr/local/lib/perl5/5.8.5/mach
/usr/local/lib/perl5/5.8.5 . /usr/local/ /usr/local/lib/perl) at (eval 7156)
line 3. Stack: [(eval 7156):3] [/opt/rt3/lib/RT/Scrip_Overlay.pm:472]
[/opt/rt3/lib/RT/Scrips_Overlay.pm:235]
[/opt/rt3/lib/RT/Transaction_Overlay.pm:160]
[/opt/rt3/lib/RT/Record.pm:1373] [/opt/rt3/lib/RT/Ticket_Overlay.pm:3439]
[/opt/rt3/lib/RT/Ticket_Overlay.pm:3176] [/opt/rt3/lib/RT/Record.pm:873]
[/opt/rt3/lib/RT/Interface/Web.pm:933]
[/opt/rt3/lib/RT/Interface/Web.pm:1047]
[/opt/rt3/share/html/Ticket/Display.html:140]
[/opt/rt3/share/html/Ticket/Update.html:211]
[/opt/rt3/share/html/autohandler:215
Apr 5 18:01:36 thewebshed /kernel: Stack: [/opt/rt3/lib/RT/Sc

that is not chopped off either… thats actually exactly what gets logged.
Freebsd btw.

I am hoping someone can point me in the right direction to enable Silent
Resolve in RT 3.4.0. (send no email to requestor on resolve)

Go to Configuration->Global->Scrips and delete the (last?) item for “on
resolve notify requestors with template resolved”.

Russell Mosemann, Ph.D. * Computing Services * Concordia University, Nebraska
"Dances with Wolverines" - unlikley movies