Signing outgoing messages that is created via API


our Request tracker is signing messages that is going out if correspondans i created via the web view, however if we automate things and send correspondens via the REST API 1.0 there messages is not signed. Someone know if there is anything i need to configure in the API that is not documented? i cant seem to find if there is any field/setting that is required for this to work.

Since “Sign by default” is enabled on the queue i was expecting this to happen even if everything is created via the API.

Best regards

Anyone having the same issue? i was thinking that if signing is enabled on the queue even replys sent via the API should be signed with the queue key…

That certainly would have been my expectation.

While finishing setting up GPG encryption has been on my to do list for a while, it hasn’t bubbled to the top yet.