Set default Quick Create owner to Nobody RT-4.4.1

When I new ticket is created via the Quick Ticket Create on the home page, the owner defaults to the submitter and I want it to default to nobody so an admin can claim it and work it. I’ve search both this list and the archives and found two answer to this question, one for 2011 doesn’t work and the other from 2005 isn’t applicable.
What needs to be changes in Element/QuickCreate to change to default owner to Nobody?

Thanks in advance

Jim Ballantine

You want the dropdown to always default to Nobody? Copy share/html/Elements/QuickCreate to local/html/Elements/QuickCreate and change the line that says:

% my $default_owner = $args->{Owner} || $session{'CurrentUser'}->id;


% my $default_owner = RT->Nobody->id;

Clear your mason cache and restart.

Note that you’ll have to monitor this file for changes from now on when you upgrade because your local version will override the version that comes with RT. If you edit share/html/Elements/QuickCreate directly you’ll lose the change on upgrades.

$ diff -u share/html/Elements/QuickCreate local/html/Elements/QuickCreate
--- share/html/Elements/QuickCreate	2016-07-18 16:20:17.000000000 -0400
+++ local/html/Elements/QuickCreate	2017-05-19 01:06:06.000000000 -0400
@@ -61,7 +61,7 @@
 <td class="label"><&|/l&>Owner</&>:</td><td class="value">
 <select type="select" name="Owner">
-% my $default_owner = $args->{Owner} || $session{'CurrentUser'}->id;
+% my $default_owner = RT->Nobody->id;
 <option value="<%$session{'CurrentUser'}->id%>" <% $default_owner == $session{'CurrentUser'}->id ? 'selected="selected"' : '' |n %>><&|/l&>Me</&></option>
 <option value="<%RT->Nobody->id%>" <% $default_owner == RT->Nobody->id ? 'selected="selected"' : '' |n %>><%loc('Nobody')%></option>