ServiceBusinessHours issue with more then one definition

Hi all,

I’m trying to set up ServiceBusinessHours.
For some reason it doesn’t seem to work, when I have more definitions.
Is seems to only use the Default.

Set( %ServiceBusinessHours,
‘Default’ => {
1 => { Name => ‘Monday’, Start => ‘9:00’, End =>
‘18:00’ },
2 => { Name => ‘Tuesday’, Start => ‘9:00’, End =>
‘18:00’ },
holidays => [qw(2012-10-22 2012-10-23 2012-10-29)],
},
‘DEF1’ => {
1 => { Name => ‘Monday’, Start => ‘9:00’, End =>
‘17:30’ },
2 => { Name => ‘Tuesday’, Start => ‘9:00’, End =>
‘17:30’ },
3 => { Name => ‘Wednesday’, Start => ‘9:00’, End =>
‘17:30’ },
holidays => [qw(2012-10-22 2012-10-24 2012-10-29)],
},
‘DEF2’ => {
1 => { Name => ‘Monday’, Start => ‘9:00’, End =>
‘13:30’ },
2 => { Name => ‘Tuesday’, Start => ‘9:00’, End =>
‘13:30’ },
3 => { Name => ‘Wednesday’, Start => ‘9:00’, End =>
‘13:30’ },
holidays => [qw(2012-10-21 2012-10-24 2012-10-29)],
},
);

In the CPAN file on
http://search.cpan.org/~tsibley/RT-Extension-SLA-0.07/lib/RT/Extension/SLA.pm#Configuring_business_hours
I cant find where the keywords, in my case DEF1, DEF2, etc reference
to. I assume it’s to a group.

I want to accomplish the following.

To have more ServiceBusinessHours settings, for different countries
with different timezones, holidays and business hours.

I’m using Request Tracker 4.0.6 and RT-Extension-SLA-0.07.

Regards,

Joop.

In the CPAN file on
RT::Extension::SLA - Service Level Agreements for RT - metacpan.org

I cant find where the keywords, in my case DEF1, DEF2, etc reference to.
I assume it’s to a group.

Not groups but queues. If you start reading at the top of the
Configuration setting, it mentions queues, but perhaps not as
prominently as it could:

In the CPAN file on

RT::Extension::SLA - Service Level Agreements for RT - metacpan.org

I cant find where the keywords, in my case DEF1, DEF2, etc reference
to.
I assume it’s to a group.

Not groups but queues. If you start reading at the top of the
Configuration setting, it mentions queues, but perhaps not as
prominently as it could:

RT::Extension::SLA - Service Level Agreements for RT - metacpan.org

I tested it against queues but it doesn’t seem to work.
Maybe my configuration isn’t correct. This is a test configuration.


Final RT training for 2012 in Atlanta, GA - October 23 & 24
Training — Best Practical Solutions

We’re hiring! http://bestpractical.com/jobs

Regards,

Joop.