SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality (or
adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for transaction
#446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips
(/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for transaction
#446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-5.9.12495554572168@example.com
mailto:rt-3.4.2-27-446-5.9.12495554572168@example.com > #27/446 - Scrip 5
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-5.9.12495554572168@example.com
mailto:rt-3.4.2-27-446-5.9.12495554572168@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-6.12.2683551134008@example.com
mailto:rt-3.4.2-27-446-6.12.2683551134008@example.com > #27/446 - Scrip 6
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-6.12.2683551134008@example.com
mailto:rt-3.4.2-27-446-6.12.2683551134008@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-7.4.03791924549544@example.com
mailto:rt-3.4.2-27-446-7.4.03791924549544@example.com > #27/446 - Scrip 7
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-7.4.03791924549544@example.com
mailto:rt-3.4.2-27-446-7.4.03791924549544@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does not
find the requestor address and if I type in a CC or BCC these items also
never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

At Monday 6/27/2005 11:20 AM, Maciak, TJ wrote:

Anyone else have problems with the “Reply to Requestor” functionality (or
adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:
It finds Scrip #6 (which is the one that sends to Requestor) but it does
not find the requestor address and if I type in a CC or BCC these items
also never get found.

Any help, tips, ideas would be very appreciated.

Can you list all the scrips you have - global and for the queue?

Also - are you the requestor on this ticket?

Steve

I have the same problemFrom: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Maciak,
TJ
Sent: Monday, June 27, 2005 11:20 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality
(or adding an email address in CC: or BCC: fields?).

No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips
(/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-5.9.12495554572168@example.com #27/446 - Scrip 5
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-5.9.12495554572168@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-6.12.2683551134008@example.com #27/446 - Scrip 6
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-6.12.2683551134008@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-7.4.03791924549544@example.com #27/446 - Scrip 7
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-7.4.03791924549544@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does
not find the requestor address and if I type in a CC or BCC these items
also never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713

F: (616)456-3448

And by the way I have all the standard scripts, no custom script
installed.From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Stephen
Turner
Sent: Monday, June 27, 2005 12:05 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] SendEmail.pm troubles

At Monday 6/27/2005 11:20 AM, Maciak, TJ wrote:

Anyone else have problems with the “Reply to Requestor” functionality
(or
adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:
It finds Scrip #6 (which is the one that sends to Requestor) but it
does
not find the requestor address and if I type in a CC or BCC these items

also never get found.

Any help, tips, ideas would be very appreciated.

Can you list all the scrips you have - global and for the queue?

Also - are you the requestor on this ticket?

Steve

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

I have the same problem.-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com]On Behalf Of Labonte, Phil
Sent: Monday, June 27, 2005 12:15 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

I have the same problem

From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Maciak, TJ
Sent: Monday, June 27, 2005 11:20 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality (or adding an email address in CC: or BCC: fields?).

No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips (/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-5.9.12495554572168@example.com> #27/446 - Scrip 5 (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-5.9.12495554572168@example.com> No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-6.12.2683551134008@example.com> #27/446 - Scrip 6 (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-6.12.2683551134008@example.com> No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-7.4.03791924549544@example.com> #27/446 - Scrip 7 (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-7.4.03791924549544@example.com> No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does not find the requestor address and if I type in a CC or BCC these items also never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713

F: (616)456-3448

I have all of the “standard” Global scrips as well.

Current Scrips:

(Check box to delete)
(no value)
On Correspond Open Tickets with template Blank
(no value)
On Owner Change Notify Owner with template Transaction
(no value)
On Create Autoreply To Requestors with template Autoreply
(no value)
On Create Notify AdminCcs with template Transaction
(no value)
On Correspond Notify AdminCcs with template Admin Correspondence
(no value)
On Correspond Notify Requestors and Ccs with template Correspondence
(no value)
On Correspond Notify Other Recipients with template Correspondence
(no value)
On Comment Notify AdminCcs as Comment with template Admin Comment
(no value)
On Comment Notify Other Recipients as Comment with template Correspondence
(no value)On Resolve Notify Requestors with template Resolved I have not made any custom scrips or edited any of these scrips. This particular example I was the requestor also, however last week I did some testing on the system and I tried this With someone else being the requestor (myself doing the reply) and it did not work either. Email does get sent out on Create ticket, resolve ticket etc. I am using RT v3.4.2 T.J. Maciak Internet/Intranet Developer Department of IT City of Grand Rapids P: (616)456-3713 F: (616)456-3448 Original Message----- From: Stephen Turner [mailto:sturner@MIT.EDU] Sent: Monday, June 27, 2005 12:05 PM To: Maciak, TJ; rt-users@lists.bestpractical.com Subject: Re: [rt-users] SendEmail.pm troubles At Monday 6/27/2005 11:20 AM, Maciak, TJ wrote:

Anyone else have problems with the “Reply to Requestor” functionality
(or adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:
It finds Scrip #6 (which is the one that sends to Requestor) but it
does not find the requestor address and if I type in a CC or BCC these
items also never get found.

Any help, tips, ideas would be very appreciated.

Can you list all the scrips you have - global and for the queue?

Also - are you the requestor on this ticket?

Steve

I too have the same problem. In fact I just posted an email to this
group.
Which log (location) are you looking at?

/mikeFrom: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 11:20 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality
(or adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips
(/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-5.9.12495554572168@example.com #27/446 - Scrip 5
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-5.9.12495554572168@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-6.12.2683551134008@example.com #27/446 - Scrip 6
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-6.12.2683551134008@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-7.4.03791924549544@example.com #27/446 - Scrip 7
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-7.4.03791924549544@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does
not find the requestor address and if I type in a CC or BCC these items
also never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

My RT log is located: /opt/rt3/var/log and the name rt.log
This is the “default” log however it can be changed inside the
RT_SiteConfig.pm if you have chosen to do such a thing.

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448From: Dwyer, Mike # ATLANTA [mailto:Mike.Dwyer@globalpay.com]
Sent: Monday, June 27, 2005 4:40 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

I too have the same problem. In fact I just posted an email to this group.
Which log (location) are you looking at?

/mike

From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 11:20 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality (or
adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for transaction
#446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips
(/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for transaction
#446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-5.9.12495554572168@example.com
mailto:rt-3.4.2-27-446-5.9.12495554572168@example.com > #27/446 - Scrip 5
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-5.9.12495554572168@example.com
mailto:rt-3.4.2-27-446-5.9.12495554572168@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-6.12.2683551134008@example.com
mailto:rt-3.4.2-27-446-6.12.2683551134008@example.com > #27/446 - Scrip 6
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-6.12.2683551134008@example.com
mailto:rt-3.4.2-27-446-6.12.2683551134008@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-7.4.03791924549544@example.com
mailto:rt-3.4.2-27-446-7.4.03791924549544@example.com > #27/446 - Scrip 7
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-7.4.03791924549544@example.com
mailto:rt-3.4.2-27-446-7.4.03791924549544@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does not
find the requestor address and if I type in a CC or BCC these items also
never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

exact same issue: "No recipients found. Not sending.
(/usr/local/rt3/lib/RT/Action/SendEmail.pm:247) "From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 4:44 PM
To: Dwyer, Mike # ATLANTA
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

My RT log is located: /opt/rt3/var/log and the name rt.log
This is the “default” log however it can be changed inside the
RT_SiteConfig.pm if you have chosen to do such a thing.

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

From: Dwyer, Mike # ATLANTA [mailto:Mike.Dwyer@globalpay.com]
Sent: Monday, June 27, 2005 4:40 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

I too have the same problem. In fact I just posted an email to this
group.
Which log (location) are you looking at?

/mike

From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 11:20 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality
(or adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips
(/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-5.9.12495554572168@example.com #27/446 - Scrip 5
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-5.9.12495554572168@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-6.12.2683551134008@example.com #27/446 - Scrip 6
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-6.12.2683551134008@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-7.4.03791924549544@example.com #27/446 - Scrip 7
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-7.4.03791924549544@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does
not find the requestor address and if I type in a CC or BCC these items
also never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

I found this issue in the rt archive. Is this the same thing? I really
don’t understand what a watcher is if it’s not just a person who would
be in the loop (watch) a given que. And why someone would have to be
listed as a “watcher” for any email response (other then the initial
one) is beyond me. I will test …

I’ve got rt 2.0.11 up and running, it is accepting emails, creating
tickets and responding to ticket creation via email (as configured).
But
after the initial confirmation to the requestor it will not send out
any
more emails either to Cc’s or requestors. I’ve tried both responding
manually (via the web interface) and having it automatically respond
to
an event via a scrip, neither works. The error log shows:

You need to apply Watchers to the Queues, otherwise no-one is listed as
receiving the ‘regular’ mails to the queue.From: Dwyer, Mike # ATLANTA
Sent: Monday, June 27, 2005 4:54 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

exact same issue: "No recipients found. Not sending.
(/usr/local/rt3/lib/RT/Action/SendEmail.pm:247) "

From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 4:44 PM
To: Dwyer, Mike # ATLANTA
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

My RT log is located: /opt/rt3/var/log and the name rt.log
This is the “default” log however it can be changed inside the
RT_SiteConfig.pm if you have chosen to do such a thing.

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

From: Dwyer, Mike # ATLANTA [mailto:Mike.Dwyer@globalpay.com]
Sent: Monday, June 27, 2005 4:40 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

I too have the same problem. In fact I just posted an email to this
group.
Which log (location) are you looking at?

/mike

From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 11:20 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality
(or adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips
(/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-5.9.12495554572168@example.com #27/446 - Scrip 5
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-5.9.12495554572168@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-6.12.2683551134008@example.com #27/446 - Scrip 6
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-6.12.2683551134008@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-7.4.03791924549544@example.com #27/446 - Scrip 7
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
rt-3.4.2-27-446-7.4.03791924549544@example.com No recipients found.
Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does
not find the requestor address and if I type in a CC or BCC these items
also never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

If this is the case, what is the purpose of creating a global scrip to set the AdminCC???
-> see: http://wiki.bestpractical.com/index.cgi?AddAdminCc

IrisFrom: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com]On Behalf Of Dwyer, Mike # ATLANTA
Sent: Monday, June 27, 2005 5:05 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

I found this issue in the rt archive. Is this the same thing? I really don’t understand what a watcher is if it’s not just a person who would be in the loop (watch) a given que. And why someone would have to be listed as a “watcher” for any email response (other then the initial one) is beyond me. I will test …

I’ve got rt 2.0.11 up and running, it is accepting emails, creating

tickets and responding to ticket creation via email (as configured). But

after the initial confirmation to the requestor it will not send out any

more emails either to Cc’s or requestors. I’ve tried both responding

manually (via the web interface) and having it automatically respond to

an event via a scrip, neither works. The error log shows:

You need to apply Watchers to the Queues, otherwise no-one is listed as

receiving the ‘regular’ mails to the queue.

From: Dwyer, Mike # ATLANTA
Sent: Monday, June 27, 2005 4:54 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

exact same issue: "No recipients found. Not sending. (/usr/local/rt3/lib/RT/Action/SendEmail.pm:247) "

From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 4:44 PM
To: Dwyer, Mike # ATLANTA
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

My RT log is located: /opt/rt3/var/log and the name rt.log
This is the “default” log however it can be changed inside the RT_SiteConfig.pm if you have chosen to do such a thing.

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

From: Dwyer, Mike # ATLANTA [mailto:Mike.Dwyer@globalpay.com]
Sent: Monday, June 27, 2005 4:40 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

I too have the same problem. In fact I just posted an email to this group.
Which log (location) are you looking at?

/mike

From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 11:20 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality (or adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips (/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-5.9.12495554572168@example.com> #27/446 - Scrip 5 (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-5.9.12495554572168@example.com> No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-6.12.2683551134008@example.com> #27/446 - Scrip 6 (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-6.12.2683551134008@example.com> No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-7.4.03791924549544@example.com> #27/446 - Scrip 7 (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]: < rt-3.4.2-27-446-7.4.03791924549544@example.com> No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does not find the requestor address and if I type in a CC or BCC these items also never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

Seems like the replies are working but it will only reply to a requestor
that is not the same as the technician logged into RT.

In other words, I login as myself (tmaciak) and make a reply to a ticket.

As long as the requestor is somebody other than (tmaciak) it appears to send
the reply to the requestors email address.

Is this the same behavior for you too?

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448From: Brookes, Iris [mailto:Iris.Brookes@tdsecurities.com]
Sent: Monday, June 27, 2005 5:11 PM
To: Dwyer, Mike # ATLANTA; Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

If this is the case, what is the purpose of creating a global scrip to set
the AdminCC???
-> see: http://wiki.bestpractical.com/index.cgi?AddAdminCc
http://wiki.bestpractical.com/index.cgi?AddAdminCc

Iris

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com]On Behalf Of Dwyer, Mike #
ATLANTA
Sent: Monday, June 27, 2005 5:05 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

I found this issue in the rt archive. Is this the same thing? I really
don’t understand what a watcher is if it’s not just a person who would be in
the loop (watch) a given que. And why someone would have to be listed as a
"watcher" for any email response (other then the initial one) is beyond me.
I will test …

I’ve got rt 2.0.11 up and running, it is accepting emails, creating

tickets and responding to ticket creation via email (as configured). But

after the initial confirmation to the requestor it will not send out any

more emails either to Cc’s or requestors. I’ve tried both responding

manually (via the web interface) and having it automatically respond to

an event via a scrip, neither works. The error log shows:

You need to apply Watchers to the Queues, otherwise no-one is listed as

receiving the ‘regular’ mails to the queue.

From: Dwyer, Mike # ATLANTA
Sent: Monday, June 27, 2005 4:54 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

exact same issue: "No recipients found. Not sending.
(/usr/local/rt3/lib/RT/Action/SendEmail.pm:247) "

From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 4:44 PM
To: Dwyer, Mike # ATLANTA
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

My RT log is located: /opt/rt3/var/log and the name rt.log
This is the “default” log however it can be changed inside the
RT_SiteConfig.pm if you have chosen to do such a thing.

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

From: Dwyer, Mike # ATLANTA [mailto:Mike.Dwyer@globalpay.com]
Sent: Monday, June 27, 2005 4:40 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

I too have the same problem. In fact I just posted an email to this group.
Which log (location) are you looking at?

/mike

From: Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
Sent: Monday, June 27, 2005 11:20 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] SendEmail.pm troubles

Anyone else have problems with the “Reply to Requestor” functionality (or
adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:

[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for transaction
#446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips
(/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for transaction
#446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-5.9.12495554572168@example.com
mailto:rt-3.4.2-27-446-5.9.12495554572168@example.com > #27/446 - Scrip 5
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-5.9.12495554572168@example.com
mailto:rt-3.4.2-27-446-5.9.12495554572168@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-6.12.2683551134008@example.com
mailto:rt-3.4.2-27-446-6.12.2683551134008@example.com > #27/446 - Scrip 6
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-6.12.2683551134008@example.com
mailto:rt-3.4.2-27-446-6.12.2683551134008@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-7.4.03791924549544@example.com
mailto:rt-3.4.2-27-446-7.4.03791924549544@example.com > #27/446 - Scrip 7
(/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-7.4.03791924549544@example.com
mailto:rt-3.4.2-27-446-7.4.03791924549544@example.com > No recipients
found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)

It finds Scrip #6 (which is the one that sends to Requestor) but it does not
find the requestor address and if I type in a CC or BCC these items also
never get found.

Any help, tips, ideas would be very appreciated.

Thanks,

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

This is as expected. There is a configuration option $NotifyActor, when
set to 0 email is not sent to the person performing an action. When set
to 1, the person perfoming the action will receive email.

Joby Walker
ITI SSG, University of Washington


PGP key: https://staff.washington.edu/joby/joby-u-pub.asc

Maciak, TJ wrote:

Seems like the replies are working but it will only reply to a requestor
that is not the same as the technician logged into RT.

In other words, I login as myself (tmaciak) and make a reply to a ticket.

As long as the requestor is somebody other than (tmaciak) it appears to
send the reply to the requestors email address.

Is this the same behavior for you too?

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448


From: Brookes, Iris [mailto:Iris.Brookes@tdsecurities.com]
Sent: Monday, June 27, 2005 5:11 PM
To: Dwyer, Mike # ATLANTA; Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

If this is the case, what is the purpose of creating a global scrip to
set the AdminCC???
-> see: http://wiki.bestpractical.com/index.cgi?AddAdminCc

Iris

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com]*On Behalf Of *Dwyer,
Mike # ATLANTA
Sent: Monday, June 27, 2005 5:05 PM
To: Maciak, TJ; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] SendEmail.pm troubles

 I found this issue in the rt archive. Is this the same thing? I
really don't understand what a watcher is if it's not just a person
who would be in the loop (watch) a given que. And why someone would
have to be listed as a "watcher" for any email response (other then
the initial one) is beyond me. I will test ......

/ I’ve got rt 2.0.11 up and running, it is accepting emails, creating
/>/ tickets and responding to ticket creation via email (as configured). But
/>/ after the initial confirmation to the requestor it will not send out any
/>/ more emails either to Cc’s or requestors. I’ve tried both responding
/>/ manually (via the web interface) and having it automatically respond to
/>/ an event via a scrip, neither works. The error log shows:
/
You need to apply Watchers to the Queues, otherwise no-one is listed as
receiving the ‘regular’ mails to the queue.

------------------------------------------------------------------------
*From:* Dwyer, Mike # ATLANTA
*Sent:* Monday, June 27, 2005 4:54 PM
*To:* Maciak, TJ; rt-users@lists.bestpractical.com
*Subject:* RE: [rt-users] SendEmail.pm troubles

exact same issue: "No recipients found. Not sending. 
(/usr/local/rt3/lib/RT/Action/SendEmail.pm:247) "
 

------------------------------------------------------------------------
*From:* Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
*Sent:* Monday, June 27, 2005 4:44 PM
*To:* Dwyer, Mike # ATLANTA
*Cc:* rt-users@lists.bestpractical.com
*Subject:* RE: [rt-users] SendEmail.pm troubles

My RT log is located: /opt/rt3/var/log and the name rt.log
This is the "default" log however it can be changed inside the
RT_SiteConfig.pm if you have chosen to do such a thing.
 
T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

 

------------------------------------------------------------------------
*From:* Dwyer, Mike # ATLANTA [mailto:Mike.Dwyer@globalpay.com]
*Sent:* Monday, June 27, 2005 4:40 PM
*To:* Maciak, TJ; rt-users@lists.bestpractical.com
*Subject:* RE: [rt-users] SendEmail.pm troubles

I too have the same problem. In fact I just posted an email to this
group.
Which log (location) are you looking at?
 
/mike
 

------------------------------------------------------------------------
*From:* Maciak, TJ [mailto:tmaciak@ci.grand-rapids.mi.us]
*Sent:* Monday, June 27, 2005 11:20 AM
*To:* rt-users@lists.bestpractical.com
*Subject:* [rt-users] SendEmail.pm troubles

Anyone else have problems with the "Reply to Requestor"
functionality (or adding an email address in CC: or BCC: fields?).
No email gets sent and my log looks like this:
 
[Mon Jun 27 14:12:08 2005] [debug]: About to think about scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:154)
[Mon Jun 27 14:12:08 2005] [debug]: About to prepare scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:158)
[Mon Jun 27 14:12:08 2005] [debug]: Found 5 scrips
(/opt/rt3/lib/RT/Scrips_Overlay.pm:354)
[Mon Jun 27 14:12:09 2005] [debug]: About to commit scrips for
transaction #446 (/opt/rt3/lib/RT/Transaction_Overlay.pm:167)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-5.9.12495554572168@example.com
<mailto:rt-3.4.2-27-446-5.9.12495554572168@example.com>> #27/446 -
Scrip 5  (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-5.9.12495554572168@example.com
<mailto:rt-3.4.2-27-446-5.9.12495554572168@example.com>> No
recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-6.12.2683551134008@example.com
<mailto:rt-3.4.2-27-446-6.12.2683551134008@example.com>> #27/446 -
Scrip 6  (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-6.12.2683551134008@example.com
<mailto:rt-3.4.2-27-446-6.12.2683551134008@example.com>> No
recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-7.4.03791924549544@example.com
<mailto:rt-3.4.2-27-446-7.4.03791924549544@example.com>> #27/446 -
Scrip 7  (/opt/rt3/lib/RT/Action/SendEmail.pm:235)
[Mon Jun 27 14:12:09 2005] [info]:
<rt-3.4.2-27-446-7.4.03791924549544@example.com
<mailto:rt-3.4.2-27-446-7.4.03791924549544@example.com>> No
recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:247)
 
It finds Scrip #6 (which is the one that sends to Requestor) but it
does not find the requestor address and if I type in a CC or BCC
these items also never get found.
 
Any help, tips, ideas would be very appreciated.
 
Thanks,
 
T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCwW5PgA0gpghkf88RArurAKCg9rbkHuJEBOaCFqZlmRsOHSd7fACfekA5
6vcsznhVju/jP8B2m0GmFb0=
=SmWv
-----END PGP SIGNATURE-----