Segmentation fault - mod_perl NOT DSO

On a newly installed machine I installed apache with mod_perl NOT as a DSO.
I still get segmentation faults with losing the css. Following is an
excerpt from my errorlog. Note the "[error] [Mason] File does not exist…"
before every group of segmentation faults. I did a search and could not
find any file such as default.ida on my system.

[Tue Sep 4 21:14:34 2001] [error] [Mason] File does not exist:
/opt/rt2/WebRT/html/default.ida
[Tue Sep 4 21:16:56 2001] [notice] child pid 2490 exit signal Segmentation
fault (11)
[Tue Sep 4 21:43:05 2001] [notice] child pid 2487 exit signal Segmentation
fault (11)
[Tue Sep 4 21:43:30 2001] [notice] child pid 2489 exit signal Segmentation
fault (11)
WebRT: Couldn’t load queue ‘’ ()[Tue Sep 4 22:28:41 2001] [notice] child
pid 6966 exit signal Segmentation fault (11)
[Tue Sep 4 22:45:33 2001] [notice] child pid 8657 exit signal Segmentation
fault (11)
[Tue Sep 4 22:46:25 2001] [notice] child pid 8334 exit signal Segmentation
fault (11)
[Tue Sep 4 22:46:25 2001] [notice] child pid 6973 exit signal Segmentation
fault (11)
[Tue Sep 4 22:53:42 2001] [error] [Mason] File does not exist:
/opt/rt2/WebRT/html/webrt
[Tue Sep 4 22:53:43 2001] [error] [Mason] File does not exist:
/opt/rt2/WebRT/html/webrt
[Tue Sep 4 23:08:01 2001] [notice] child pid 8042 exit signal Segmentation
fault (11)

Can anyone shed some litght on this.

I am escpecially surprised, as I hoped the static install of mod_perl would
help my css problems

btw. I use RH 7.1, rt-2-0-6

Thanks in advance,

Rehan van der Merwe

Rehan,

Two different problems. The default.ida is someone trying to exploit your
machine with the Code Red virus… unrelated and irrelevant.

The segfaults are caused by something in mod_perl/Apache/RT (probably the
former two) and do seem to be related to the CSS problems described
elsewhere on this list.

Any further data you can contribute to this problem would be universally
welcomed.

Regards,
Dave

David C. Troy [dave@toad.net] 410-544-6193 Sales
ToadNet - Want to go fast? 410-544-1329 FAX
570 Ritchie Highway, Severna Park, MD 21146-2925 www.toad.netOn Wed, 5 Sep 2001, Rehan van der Merwe wrote:

On a newly installed machine I installed apache with mod_perl NOT as a DSO.
I still get segmentation faults with losing the css. Following is an
excerpt from my errorlog. Note the "[error] [Mason] File does not exist…"
before every group of segmentation faults. I did a search and could not
find any file such as default.ida on my system.

[Tue Sep 4 21:14:34 2001] [error] [Mason] File does not exist:
/opt/rt2/WebRT/html/default.ida
[Tue Sep 4 21:16:56 2001] [notice] child pid 2490 exit signal Segmentation
fault (11)
[Tue Sep 4 21:43:05 2001] [notice] child pid 2487 exit signal Segmentation
fault (11)
[Tue Sep 4 21:43:30 2001] [notice] child pid 2489 exit signal Segmentation
fault (11)
WebRT: Couldn’t load queue ‘’ ()[Tue Sep 4 22:28:41 2001] [notice] child
pid 6966 exit signal Segmentation fault (11)
[Tue Sep 4 22:45:33 2001] [notice] child pid 8657 exit signal Segmentation
fault (11)
[Tue Sep 4 22:46:25 2001] [notice] child pid 8334 exit signal Segmentation
fault (11)
[Tue Sep 4 22:46:25 2001] [notice] child pid 6973 exit signal Segmentation
fault (11)
[Tue Sep 4 22:53:42 2001] [error] [Mason] File does not exist:
/opt/rt2/WebRT/html/webrt
[Tue Sep 4 22:53:43 2001] [error] [Mason] File does not exist:
/opt/rt2/WebRT/html/webrt
[Tue Sep 4 23:08:01 2001] [notice] child pid 8042 exit signal Segmentation
fault (11)

Can anyone shed some litght on this.

I am escpecially surprised, as I hoped the static install of mod_perl would
help my css problems

btw. I use RH 7.1, rt-2-0-6

Thanks in advance,

Rehan van der Merwe


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users